libzlib-devel-1.2.11-4.mga6.i586.rpm


Advertisement

Description

libzlib-devel - Header files and libraries for developing apps which will use zlib

Distribution: Mageia 6.0
Repository: Mageia Core i586
Package name: libzlib-devel
Package version: 1.2.11
Package release: 4.mga6
Package architecture: i586
Package type: rpm
Installed size: 642.33 KB
Download size: 210.71 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
The zlib-devel package contains the header files and libraries needed to develop programs that use the zlib compression and decompression library. Install the zlib-devel package if you want to develop applications that will use the zlib library.

Alternatives

Provides

  • devel(libz)
  • libz-devel == 1.2.11-4.mga6
  • libzlib-devel == 1.2.11-4.mga6
  • libzlib-devel(x86-32) == 1.2.11-4.mga6
  • pkgconfig(zlib) == 1.2.11
  • zlib-devel == 1.2.11-4.mga6

Obsoletes

  • libz-devel
  • libz1-devel
  • zlib-devel
  • zlib1-devel
  • zlib1-devel < 1.2.5

    Download

    Install Howto

    1. Enable Mageia Core repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install libzlib-devel rpm package:
      # urpmi libzlib-devel

    Files

    • /usr/include/zconf.h
    • /usr/include/zlib.h
    • /usr/lib/libz.a
    • /usr/lib/libz.so
    • /usr/lib/dietlibc/lib-i386/libz.a
    • /usr/lib/pkgconfig/zlib.pc
    • /usr/share/doc/libzlib-devel/ChangeLog
    • /usr/share/doc/libzlib-devel/README
    • /usr/share/doc/libzlib-devel/algorithm.txt
    • /usr/share/man/man3/zlib.3.xz

    Changelog

    2017-03-29 - neoclust <neoclust> 1.2.11-4.mga6 + Revision: 1095154 - Add more conflicts

    2017-03-29 - neoclust <neoclust> 1.2.11-3.mga6 + Revision: 1095142 - Add conflict to ease upgrade from mga5(mga#20562)

    2017-02-06 - zezinho <zezinho> 1.2.11-2.mga6 + Revision: 1085045 - remove biarch build to allow simultaneous install of i586 and x86_64 versions

    2017-01-16 - luigiwalser <luigiwalser> 1.2.11-1.mga6 + Revision: 1082005 - 1.2.11 - remove patch changing internal version (not needed)

    2017-01-09 - luigiwalser <luigiwalser> 1.2.10-3.mga6 + Revision: 1080779 - revert addition of uncompress2 function in 1.2.9

    2017-01-09 - luigiwalser <luigiwalser> 1.2.10-2.mga6 + Revision: 1080775 - change internal version to 1.2.9.1 to work around buggy maven

    2017-01-03 - luigiwalser <luigiwalser> 1.2.10-1.mga6 + Revision: 1079972 - remove upstreamed patches and update URLs - 1.2.10

    2016-10-04 - luigiwalser <luigiwalser> 1.2.8-10.mga6 + Revision: 1058600 - add upstream patches to fix issues found by mozilla security audit

    2016-01-17 - daviddavid <daviddavid> 1.2.8-9.mga6 + Revision: 925180 - switch to %configure2_5x to fix build

    2015-08-21 - tmb <tmb> 1.2.8-8.mga6 + Revision: 867778 - rebuild for new gcc

    Advertisement
    Advertisement