nodejs-optionator-0.8.1-2.mga6.noarch.rpm


Advertisement

Description

nodejs-optionator - Option parsing and help generation

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name nodejs-optionator
Package version 0.8.1
Package release 2.mga6
Package architecture noarch
Package type rpm
Installed size 60.02 KB
Download size 23.91 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Option parsing and help generation

Alternatives

Package Version Architecture Repository
nodejs-optionator-0.8.1-2.mga6.noarch.rpm 0.8.1 noarch Mageia Core
nodejs-optionator - - -

Requires

Name Value
nodejs(engine) >= 0.8.0
npm(deep-is) >= 0.1.3
npm(deep-is) < 0.2
npm(fast-levenshtein) >= 1.1.0
npm(fast-levenshtein) < 2
npm(levn) >= 0.3.0
npm(levn) < 0.4
npm(prelude-ls) < 1.2
npm(prelude-ls) >= 1.1.2
npm(type-check) >= 0.3.2
npm(type-check) < 0.4
npm(wordwrap) >= 1.0.0
npm(wordwrap) < 1.1

Provides

Name Value
nodejs-optionator == 0.8.1-2.mga6
npm(optionator) == 0.8.1

Download

Type URL
Binary Package nodejs-optionator-0.8.1-2.mga6.noarch.rpm
Source Package nodejs-optionator-0.8.1-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install nodejs-optionator rpm package:
    # urpmi nodejs-optionator

Files

Path
/usr/lib/node_modules/optionator/package.json
/usr/lib/node_modules/optionator/lib/coerce.js
/usr/lib/node_modules/optionator/lib/help.js
/usr/lib/node_modules/optionator/lib/index.js
/usr/lib/node_modules/optionator/lib/parse-type.js
/usr/lib/node_modules/optionator/lib/util.js
/usr/lib/node_modules/optionator/node_modules/deep-is
/usr/lib/node_modules/optionator/node_modules/fast-levenshtein
/usr/lib/node_modules/optionator/node_modules/levn
/usr/lib/node_modules/optionator/node_modules/prelude-ls
/usr/lib/node_modules/optionator/node_modules/type-check
/usr/lib/node_modules/optionator/node_modules/wordwrap
/usr/share/doc/nodejs-optionator/CHANGELOG.md
/usr/share/doc/nodejs-optionator/README.md
/usr/share/licenses/nodejs-optionator/LICENSE

Changelog

2017-05-17 - neoclust <neoclust> 0.8.1-2.mga6
+ Revision: 1102318
- imported package nodejs-optionator
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2016-02-16 - Jared Smith <jsmith@fedoraproject.org> - 0.8.1-1
- Initial packaging

See Also

Package Description
nodejs-os-locale-1.4.0-2.mga6.noarch.rpm Get the system locale
nodejs-packaging-9-1.mga6.noarch.rpm RPM Macros and Utilities for Node.js Packaging
nodejs-paperboy-0.0.5-1.mga6.noarch.rpm A node.js module for delivering static files
nodejs-path-is-absolute-1.0.0-1.mga6.noarch.rpm Node.js 0.12 path.isAbsolute() ponyfill
nodejs-prelude-ls-1.1.2-2.mga6.noarch.rpm The prelude.ls library is a functionally oriented utility
nodejs-pretty-bytes-3.0.1-2.mga6.noarch.rpm Convert bytes to a human readable string
nodejs-process-nextick-args-1.0.7-2.mga6.noarch.rpm The process.nextTick() but always with args
nodejs-promise-4.0.0-2.mga6.noarch.rpm Bare bones Promises/A+ implementation for Node.js
nodejs-read-package-json-2.0.3-2.mga6.noarch.rpm npm's package.json parser
nodejs-readable-stream-2.0.5-2.mga6.noarch.rpm Streams3, a user-land copy of the stream library from Node.js v0.10.x
nodejs-readdirp-2.0.0-1.mga6.noarch.rpm Recursive version of Node's fs.readdir with a streaming API
nodejs-repeat-string-1.5.2-2.mga6.noarch.rpm Repeat the given string n times. Fastest implementation for repeating a string
nodejs-replace-require-self-1.1.1-2.mga6.noarch.rpm Require($THIS_PACKAGE) -> require('./')
nodejs-requirejs-2.1.11-5.mga6.noarch.rpm Node.js adapter for RequireJS, for loading AMD modules
nodejs-resolve-1.1.7-1.mga6.noarch.rpm Resolve like require.resolve() on behalf of files asynchronously/synchronously
Advertisement
Advertisement