nodejs-promise-4.0.0-2.mga6.noarch.rpm


Advertisement

Description

nodejs-promise - Bare bones Promises/A+ implementation for Node.js

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name nodejs-promise
Package version 4.0.0
Package release 2.mga6
Package architecture noarch
Package type rpm
Installed size 16.38 KB
Download size 13.14 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This is a bare bones Promises/A+ implementation for Node.js. It is designed
to get the basics spot on correct, so that you can build extended promise
implementations on top of it.

Alternatives

Package Version Architecture Repository
nodejs-promise-4.0.0-2.mga6.noarch.rpm 4.0.0 noarch Mageia Core
nodejs-promise - - -

Requires

Name Value
nodejs(engine) -
npm(asap) >= 1.0.0
npm(asap) < 1.1

Provides

Name Value
nodejs-promise == 4.0.0-2.mga6
npm(promise) == 4.0.0

Download

Type URL
Binary Package nodejs-promise-4.0.0-2.mga6.noarch.rpm
Source Package nodejs-promise-4.0.0-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install nodejs-promise rpm package:
    # urpmi nodejs-promise

Files

Path
/usr/lib/node_modules/promise/core.js
/usr/lib/node_modules/promise/index.js
/usr/lib/node_modules/promise/package.json
/usr/lib/node_modules/promise/node_modules/asap
/usr/share/doc/nodejs-promise/LICENSE
/usr/share/doc/nodejs-promise/Readme.md

Changelog

2016-02-08 - umeabot <umeabot> 4.0.0-2.mga6
+ Revision: 950431
- Mageia 6 Mass Rebuild
2014-10-29 - tv <tv> 4.0.0-1.mga5
+ Revision: 794325
- imported package nodejs-promise
2014-10-29 - Thierry Vignaud <tv@mageia.org> 4.0.0-1.mga5
- import from FC
2014-03-02 - Jamie Nguyen <jamielinux@fedoraproject.org> - 4.0.0-1
- initial package

See Also

Package Description
nodejs-read-package-json-2.0.3-2.mga6.noarch.rpm npm's package.json parser
nodejs-readable-stream-2.0.5-2.mga6.noarch.rpm Streams3, a user-land copy of the stream library from Node.js v0.10.x
nodejs-readdirp-2.0.0-1.mga6.noarch.rpm Recursive version of Node's fs.readdir with a streaming API
nodejs-repeat-string-1.5.2-2.mga6.noarch.rpm Repeat the given string n times. Fastest implementation for repeating a string
nodejs-replace-require-self-1.1.1-2.mga6.noarch.rpm Require($THIS_PACKAGE) -> require('./')
nodejs-requirejs-2.1.11-5.mga6.noarch.rpm Node.js adapter for RequireJS, for loading AMD modules
nodejs-resolve-1.1.7-1.mga6.noarch.rpm Resolve like require.resolve() on behalf of files asynchronously/synchronously
nodejs-resumer-0.0.0-1.mga6.noarch.rpm A stream that starts paused and resumes on the next tick
nodejs-right-align-0.1.3-2.mga6.noarch.rpm Right-align the text in a string
nodejs-rimraf-2.2.2-2.mga6.noarch.rpm A deep deletion module for node.js
nodejs-runforcover-0.0.2-3.mga6.noarch.rpm Require plugin for JS code coverage
nodejs-semver-5.1.0-2.mga6.noarch.rpm Semantic versioner for npm
nodejs-shelljs-0.3.0-4.mga6.noarch.rpm Portable Unix shell commands for Node.js
nodejs-should-8.2.2-3.mga6.noarch.rpm A test framework agnostic BDD-style assertions for Node.js
nodejs-should-equal-0.7.3-1.mga6.noarch.rpm Deep comparison of two instances for should.js
Advertisement
Advertisement