nodejs-should-8.2.2-3.mga6.noarch.rpm


Advertisement

Description

nodejs-should - A test framework agnostic BDD-style assertions for Node.js

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package name nodejs-should
Package version 8.2.2
Package release 3.mga6
Package architecture noarch
Package type rpm
Installed size 216.43 KB
Download size 41.60 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
should is an expressive, readable, test framework agnostic, behavior-driven
development (BDD)-style assertion library for Node.js.
It extends the Object prototype with a single non-enumerable getter that
allows you to express how that object should behave.
should literally extends Node's assert module. For example,
should.equal(str, 'foo') will work, just as assert.equal(str, 'foo') would,
and should.AssertionError is assert.AssertionError, meaning any test framework
supporting this constructor will function properly with should.

Alternatives

Package Version Architecture Repository
nodejs-should-8.2.2-3.mga6.noarch.rpm 8.2.2 noarch Mageia Core
nodejs-should - - -

Requires

Name Value
nodejs(engine) -
npm(should-equal) >= 0.7.3
npm(should-equal) < 0.8
npm(should-format) == 0.3.2
npm(should-type) == 0.2.0

Provides

Name Value
nodejs-should == 8.2.2-3.mga6
npm(should) == 8.2.2

Obsoletes

Name Value
nodejs-should-promised < 0.3.1-2

Download

Type URL
Binary Package nodejs-should-8.2.2-3.mga6.noarch.rpm
Source Package nodejs-should-8.2.2-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install nodejs-should rpm package:
    # urpmi nodejs-should

Files

Path
/usr/lib/node_modules/should/index.js
/usr/lib/node_modules/should/package.json
/usr/lib/node_modules/should/should.js
/usr/lib/node_modules/should/lib/assertion-error.js
/usr/lib/node_modules/should/lib/assertion.js
/usr/lib/node_modules/should/lib/config.js
/usr/lib/node_modules/should/lib/should.js
/usr/lib/node_modules/should/lib/util.js
/usr/lib/node_modules/should/lib/ext/_assert.js
/usr/lib/node_modules/should/lib/ext/assert.js
/usr/lib/node_modules/should/lib/ext/bool.js
/usr/lib/node_modules/should/lib/ext/chain.js
/usr/lib/node_modules/should/lib/ext/contain.js
/usr/lib/node_modules/should/lib/ext/eql.js
/usr/lib/node_modules/should/lib/ext/error.js
/usr/lib/node_modules/should/lib/ext/match.js
/usr/lib/node_modules/should/lib/ext/number.js
/usr/lib/node_modules/should/lib/ext/promise.js
/usr/lib/node_modules/should/lib/ext/property.js
/usr/lib/node_modules/should/lib/ext/string.js
/usr/lib/node_modules/should/lib/ext/type.js
/usr/lib/node_modules/should/node_modules/should-equal
/usr/lib/node_modules/should/node_modules/should-format
/usr/lib/node_modules/should/node_modules/should-type
/usr/share/doc/nodejs-should/CONTRIBUTING.md
/usr/share/doc/nodejs-should/History.md
/usr/share/doc/nodejs-should/Readme.md
/usr/share/licenses/nodejs-should/LICENSE

Changelog

2016-12-04 - daviddavid <daviddavid> 8.2.2-3.mga6
+ Revision: 1072406
- add upstream patch to fix testsuite under Node.js >= 6.5.0
2016-05-25 - neoclust <neoclust> 8.2.2-2.mga6
+ Revision: 1018360
- Fix npm(should-equal) deps
2016-05-25 - neoclust <neoclust> 8.2.2-1.mga6
+ Revision: 1018294
- New version 8.2.2
2016-02-08 - umeabot <umeabot> 3.3.1-2.mga6
+ Revision: 950299
- Mageia 6 Mass Rebuild
2014-10-28 - tv <tv> 3.3.1-1.mga5
+ Revision: 794037
- imported package nodejs-should
2014-10-28 - Thierry Vignaud <tv@mageia.org> 3.3.1-1.mga5
- import from FC
2014-04-20 - Jamie Nguyen <jamielinux@fedoraproject.org> - 3.3.1-1
- update to upstream release 3.3.1
2014-03-02 - Jamie Nguyen <jamielinux@fedoraproject.org> - 3.1.3-1
- update to upstream release 3.1.3

See Also

Package Description
nodejs-should-equal-0.7.3-1.mga6.noarch.rpm Deep comparison of two instances for should.js
nodejs-should-format-0.3.2-3.mga6.noarch.rpm Formatting of objects for should.js
nodejs-should-type-0.2.0-3.mga6.noarch.rpm Simple module to get instance type
nodejs-sigmund-1.0.0-2.mga6.noarch.rpm Quick and dirty signatures for Objects
nodejs-simple-assert-1.0.0-1.mga6.noarch.rpm Vanilla assertions for Node.js
nodejs-slide-1.1.6-1.mga6.noarch.rpm A flow control library that fits in a slideshow
nodejs-source-map-0.5.3-2.mga6.noarch.rpm Node.js library that generates and consumes source maps
nodejs-spdx-correct-1.0.2-3.mga6.noarch.rpm Correct invalid SPDX identifiers
nodejs-spdx-exceptions-1.0.4-2.mga6.noarch.rpm A list of SPDX standard license exceptions
nodejs-spdx-expression-parse-1.0.2-3.mga6.noarch.rpm Parse SPDX license expressions
nodejs-spdx-license-ids-1.2.0-5.mga6.noarch.rpm A list of SPDX license identifiers
nodejs-sprintf-js-1.0.3-5.mga6.noarch.rpm JavaScript sprintf implementation
nodejs-stream-replace-1.0.0-3.mga6.noarch.rpm Replace text in a stream
nodejs-string-dot-prototype-dot-repeat-0.2.0-3.mga6.noarch.rpm A robust & optimized `String.prototype.repeat` polyfill
nodejs-string-dot-prototype-dot-trim-1.1.2-1.mga6.noarch.rpm ES5 spec-compliant shim for String.prototype.trim
Advertisement
Advertisement