openldap-2.4.45-2.mga6.i586.rpm


Advertisement

Description

openldap - LDAP servers and sample clients

Distribution: Mageia 6.0
Repository: Mageia Core i586
Package name: openldap
Package version: 2.4.45
Package release: 2.mga6
Package architecture: i586
Package type: rpm
Installed size: 15.14 KB
Download size: 21.53 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
OpenLDAP is an open source suite of LDAP (Lightweight Directory Access Protocol) applications and development tools. The suite includes a stand-alone LDAP server (slapd) which is in the -servers package, libraries for implementing the LDAP protocol (in the lib packages), and utilities, tools, and sample clients (in the -clients package). The openldap binary package includes only configuration files used by the libraries. Install openldap if you need LDAP applications and tools.

Alternatives

Provides

  • config(openldap) == 2.4.45-2.mga6
  • openldap == 2.4.45-2.mga6
  • openldap(x86-32) == 2.4.45-2.mga6

    Download

    Install Howto

    1. Enable Mageia Core repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install openldap rpm package:
      # urpmi openldap

    Files

    • /etc/openldap/ldap.conf
    • /etc/openldap/ldapserver
    • /usr/share/doc/openldap/README.mageia
    • /usr/share/man/man5/ldap.conf.5.xz
    • /usr/share/man/man5/ldif.5.xz

    Changelog

    2017-06-04 - neoclust <neoclust> 2.4.45-2.mga6 + Revision: 1106718 - Fix typo in requires + buchan <buchan> - 2.4.45 - Remove upstream patches - Add versioned requirement on liblmdb in -back_mdb - Make mdb the default backend - Fix all incorrect occurences of /etc/sysconfig/ldap - Update documentation patches, and always build docs - Fix conditional tests (but disabled by default)

    2017-06-01 - neoclust <neoclust> 2.4.44-5.mga6 + Revision: 1105744 - Add P100 - Fixes CVE-2017-9287 (mga#21003)

    2016-11-25 - neoclust <neoclust> 2.4.44-4.mga6 + Revision: 1070103 - Do not require openldap-back_bdb for the moment

    2016-11-25 - neoclust <neoclust> 2.4.44-3.mga6 + Revision: 1070089 - Do not use deprecated bdb backend by default

    2016-03-03 - umeabot <umeabot> 2.4.44-2.mga6 + Revision: 983852 - Rebuild for openssl

    2016-02-09 - luigiwalser <luigiwalser> 2.4.44-1.mga6 + Revision: 951827 - 2.4.44 - add patch from opensuse to enforce min DH size of 1024 (CVE-2015-4000, LOGJAM)

    2016-01-08 - buchan <buchan> 2.4.43-3.mga6 + Revision: 920605 - openldap-servers no longer requires back_bdb (added to allow transition from built-in back_bdb support in Mageia 3 to module in Mageia 4) openldap-servers now suggests back_mdb, to become the default in future - Build the pbkdf2 password module in contrib (since 2.4.41) - Clean up configure warnings, including not bulding back-shell by default - Allow either building the internal lmdb (--with lmdbinternal), or building against system lmdbi shared library (default on Mageia > 5) - Update bundled db to 5.3.28 and build it on anything less than 5.3 Allow building without Berkeley DB (--without bdb --without hdb) - Make ldap-config exit non-zero if config checking failed so systemd fails it + luigiwalser <luigiwalser> - 2.4.43

    2015-09-18 - neoclust <neoclust> 2.4.42-1.mga6 + Revision: 880334 - New version 2.4.42 - use system lmdb

    2015-09-11 - luigiwalser <luigiwalser> 2.4.40-6.mga6 + Revision: 876932 - add upstream patch to fix DoS due to assertion left in code (its#8240)

    2015-08-21 - tmb <tmb> 2.4.40-5.mga6 + Revision: 867615 - rebuild for new gcc + luigiwalser <luigiwalser> - support SLAPDSYSLOGLEVEL in service file (mga#13470) - remove unused MAXFILES variable from sysconfig file - add upstream patch to test suite for CVE-2015-1546

    Advertisement
    Advertisement