perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.3-1.mga6.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MetaData-BuiltWith - Go overkill and report everything in all name-spaces

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package name perl-Dist-Zilla-Plugin-MetaData-BuiltWith
Package version 1.4.3
Package release 1.mga6
Package architecture noarch
Package type rpm
Installed size 109.12 KB
Download size 36.15 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Often, distribution authors get module dependencies wrong. So in such
cases, its handy to be able to see what version of various packages they
built with.
Some would prefer to demand everyone install the same version as they did,
but that's also not always necessary.
Hopefully, the existence of the metadata provided by this module will help
users on their end machines make intelligent choices about what modules to
install in the event of a problem.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.3-1.mga6.noarch.rpm 1.4.3 noarch Mageia Core
perl-Dist-Zilla-Plugin-MetaData-BuiltWith - - -

Requires

Name Value
perl >= 0:5.006
perl(CPAN::Meta::Converter) -
perl(Carp) -
perl(Config) -
perl(Devel::CheckBin) -
perl(Dist::Zilla::File::FromCode) -
perl(Dist::Zilla::Role::ConfigDumper) >= 4.101.540
perl(Dist::Zilla::Role::FileGatherer) -
perl(Dist::Zilla::Role::FileMunger) -
perl(Dist::Zilla::Role::MetaProvider) -
perl(JSON::MaybeXS) -
perl(Module::Metadata) -
perl(Module::Runtime) -
perl(Moose) -
perl(Moose) >= 2.0.0
perl(MooseX::Types::Moose) -
perl(Path::Tiny) -
perl(YAML::Tiny) -
perl(namespace::autoclean) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Dist::Zilla::Plugin::MetaData::BuiltWith) == 1.4.3
perl(Dist::Zilla::Plugin::MetaData::BuiltWith::All) == 1.4.3
perl-Dist-Zilla-Plugin-MetaData-BuiltWith == 1.4.3-1.mga6

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.3-1.mga6.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.3-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-MetaData-BuiltWith rpm package:
    # urpmi perl-Dist-Zilla-Plugin-MetaData-BuiltWith

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Dist/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/MetaData/BuiltWith.pm
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/MetaData/BuiltWith/All.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/MYMETA.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaData-BuiltWith/README
/usr/share/man/man3/Dist::Zilla::Plugin::MetaData::BuiltWith.3pm.xz
/usr/share/man/man3/Dist::Zilla::Plugin::MetaData::BuiltWith::All.3pm.xz

Changelog

2016-05-08 - shlomif <shlomif> 1.4.3-1.mga6
+ Revision: 1010603
- update to 1.004003
2016-02-18 - umeabot <umeabot> 1.4.2-2.mga6
+ Revision: 967325
- Mageia 6 Mass Rebuild
2015-06-30 - sander85 <sander85> 1.4.2-1.mga6
+ Revision: 848715
- update to 1.004002
2014-12-11 - sander85 <sander85> 1.3.0-3.mga5
+ Revision: 802698
- Fix BRs
+ umeabot <umeabot>
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2014-09-04 - sander85 <sander85> 1.3.0-1.mga5
+ Revision: 671903
- update to 1.003000
2014-08-18 - sander85 <sander85> 1.2.0-1.mga5
+ Revision: 665106
- update to 1.002000
2014-08-16 - sander85 <sander85> 1.1.1-1.mga5
+ Revision: 664065
- update to 1.001001
2014-08-01 - sander85 <sander85> 1.1.0-1.mga5
+ Revision: 658957
- update to 1.001000
2014-07-21 - sander85 <sander85> 1.0.1-1.mga5
+ Revision: 655063
- update to 1.000001
2014-05-20 - jquelin <jquelin> 1.0.0-1.mga5
+ Revision: 624253
- update to 1.000000

See Also

Package Description
perl-Dist-Zilla-Plugin-MetaProvides-2.1.11-2.mga6.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Class-2.1.0-3.mga6.noarch.rpm Scans Dist::Zilla's .pm files and tries to identify classes using Class::Discover
perl-Dist-Zilla-Plugin-MetaProvides-FromFile-2.1.1-3.mga6.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Package-2.3.2-2.mga6.noarch.rpm Extract namespaces/version from traditional packages for provides
perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-7.mga6.noarch.rpm Metadata resource URLs from Git configuration
perl-Dist-Zilla-Plugin-MetaYAML-Minimal-0.1.0-3.mga6.noarch.rpm Generate a reductionist YAML META file for compatibility only
perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-3.mga6.noarch.rpm Detects the minimum version of Perl required for your dist
perl-Dist-Zilla-Plugin-ModuleBuild-XSOrPP-0.40.0-7.mga6.noarch.rpm Add a --pp option to your Build.PL to force an XS-less build
perl-Dist-Zilla-Plugin-ModuleBuildTiny-0.14.0-3.mga6.noarch.rpm Build a Build.PL that uses Module::Build::Tiny
perl-Dist-Zilla-Plugin-ModuleBuildTiny-Fallback-0.23.0-2.mga6.noarch.rpm Generate a Build.PL that uses Module::Build::Tiny, falling back to Module::Build as needed
perl-Dist-Zilla-Plugin-ModuleInstall-1.1.1-1.mga6.noarch.rpm Build Module::Install based Distributions with Dist::Zilla
perl-Dist-Zilla-Plugin-MojibakeTests-0.800.0-3.mga6.noarch.rpm Release tests for source encoding
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.noarch.rpm Extract previous version from changelog
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-5.mga6.noarch.rpm Avoid running under CPAN Testers
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.7.0-3.mga6.noarch.rpm Make sure no Smart::Comments escape into the wild
Advertisement
Advertisement