perl-Event-Lib-1.40.0-1.mga6.i586.rpm


Advertisement

Description

perl-Event-Lib - Perl extentions for event-based programming

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package name perl-Event-Lib
Package version 1.40.0
Package release 1.mga6
Package architecture i586
Package type rpm
Installed size 108.20 KB
Download size 51.43 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This module is a Perl wrapper around libevent(3) as available from the
http://www.monkey.org/~provos/libevent/ manpage. It allows to execute a
function whenever a given event on a filehandle happens, a timeout occurs
or a signal is received.
Under the hood, one of the available mechanisms for asynchronously dealing
with events is used. This could be 'select', 'poll', 'epoll', 'devpoll' or
'kqueue'. The idea is that you don't have to worry about those details and
the various interfaces they offer. _Event::Lib_ offers a unified interface
to all of them (but see the "CONFIGURATION" manpage further below).
Once you've skimmed through the next two sections (or maybe even now), you
should have a look at the "EXAMPLE: A SIMPLE TCP SERVER" manpage to get a
feeling about how it all fits together.

Alternatives

Package Version Architecture Repository
perl-Event-Lib-1.40.0-1.mga6.x86_64.rpm 1.40.0 x86_64 Mageia Core
perl-Event-Lib - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libevent.so.6 -
libperl.so.5.22 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
perl >= 0:5.006
perl(Exporter) -
perl(XSLoader) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.3

Provides

Name Value
perl(Event::Lib) == 1.40.0
perl-Event-Lib == 1.40.0-1.mga6
perl-Event-Lib(x86-32) == 1.40.0-1.mga6

Download

Type URL
Binary Package perl-Event-Lib-1.40.0-1.mga6.i586.rpm
Source Package perl-Event-Lib-1.40.0-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Event-Lib rpm package:
    # urpmi perl-Event-Lib

Files

Path
/usr/lib/perl5/vendor_perl/5.22.3/i386-linux-thread-multi/
/usr/lib/perl5/vendor_perl/5.22.3/i386-linux-thread-multi/Event/Lib.pm
/usr/lib/perl5/vendor_perl/5.22.3/i386-linux-thread-multi/auto/
/usr/lib/perl5/vendor_perl/5.22.3/i386-linux-thread-multi/auto/Event/
/usr/lib/perl5/vendor_perl/5.22.3/i386-linux-thread-multi/auto/Event/Lib/Lib.so
/usr/share/doc/perl-Event-Lib/Changes
/usr/share/doc/perl-Event-Lib/META.yml
/usr/share/doc/perl-Event-Lib/README
/usr/share/man/man3/Event::Lib.3pm.xz

Changelog

2017-02-21 - mrambo3501 <mrambo3501> 1.40.0-1.mga6
+ Revision: 1087217
- update to latest version
- added patch to fix build error with libevent 2.1.8
- rebuild for new libevent
2016-06-19 - pterjan <pterjan> 1.30.0-13.mga6
+ Revision: 1026983
- Rebuild for perl 5.22.2
2016-02-12 - umeabot <umeabot> 1.30.0-12.mga6
+ Revision: 957273
- Mageia 6 Mass Rebuild
2015-06-25 - tv <tv> 1.30.0-11.mga6
+ Revision: 843608
- rebuild for perl-5.22
2014-10-15 - umeabot <umeabot> 1.30.0-10.mga5
+ Revision: 743905
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.30.0-9.mga5
+ Revision: 684656
- Mageia 5 Mass Rebuild
2014-06-03 - pterjan <pterjan> 1.30.0-8.mga5
+ Revision: 631163
- Rebuild for perl 5.20

See Also

Package Description
perl-Event-RPC-1.80.0-2.mga6.noarch.rpm Event-RPC - Event based transparent Client/Server RPC framework
perl-Excel-Template-0.340.0-7.mga6.noarch.rpm Templating module that generates Excel
perl-Excel-Template-Plus-0.60.0-3.mga6.noarch.rpm Testing module for use with Excel::Template::Plus
perl-Excel-Writer-XLSX-0.890.0-2.mga6.noarch.rpm Light weight re-implementation of XML::Writer
perl-Exception-Base-0.2501-3.mga6.noarch.rpm Lightweight exceptions
perl-Exception-Class-1.400.0-2.mga6.noarch.rpm A module that allows you to declare real exception classes in Perl
perl-Exception-Class-TryCatch-1.130.0-7.mga6.noarch.rpm Syntactic tryE<sol>catch sugar for use with Exception::Class
perl-Expect-1.320.0-3.mga6.noarch.rpm Expect for Perl
perl-Expect-Simple-0.40.0-7.mga6.noarch.rpm Perl wrapper around the Expect module
perl-Exporter-5.720.0-3.mga6.noarch.rpm Implements default import method for modules
perl-Exporter-Declare-0.114.0-3.mga6.noarch.rpm Export class for exports that should be
perl-Exporter-Easy-0.180.0-2.mga6.noarch.rpm Takes even more drudgery out of Exporting symbols
perl-Exporter-Lite-0.80.0-2.mga6.noarch.rpm Exporter-Lite perl module
perl-Exporter-Tidy-0.80.0-3.mga6.noarch.rpm Another way of exporting symbols
perl-Exporter-Tiny-0.42.0-3.mga6.noarch.rpm An exporter with the features of Sub::Exporter but only core dependencies
Advertisement
Advertisement