perl-Module-CPANfile-1.100.200-2.mga6.noarch.rpm


Advertisement

Description

perl-Module-CPANfile - Parse cpanfile

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package filename perl-Module-CPANfile-1.100.200-2.mga6.noarch.rpm
Package name perl-Module-CPANfile
Package version 1.100.200
Package release 2.mga6
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Module-CPANfile
License GPL+ or Artistic
Maintainer -
Download size 36.11 KB
Installed size 70.75 KB
'cpanfile' describes CPAN dependencies required to execute associated Perl
code.

Alternatives

Package Version Architecture Repository
perl-Module-CPANfile-1.100.200-2.mga6.noarch.rpm 1.100.200 noarch Mageia Core
perl-Module-CPANfile - - -

Requires

Name Value
perl(CPAN::Meta) >= 2.120.910
perl(CPAN::Meta::Feature) -
perl(CPAN::Meta::Prereqs) >= 2.120.910
perl(CPAN::Meta::Requirements) -
perl(Carp) -
perl(Cwd) -
perl(Getopt::Long) -
perl(JSON::PP) >= 2.273.0
perl(Module::CPANfile) -
perl(Module::CPANfile::Environment) -
perl(Module::CPANfile::Prereq) -
perl(Module::CPANfile::Prereqs) -
perl(Module::CPANfile::Requirement) -
perl(parent) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Module::CPANfile) == 1.100.200
perl(Module::CPANfile::Environment) -
perl(Module::CPANfile::Prereq) -
perl(Module::CPANfile::Prereqs) -
perl(Module::CPANfile::Requirement) -
perl-Module-CPANfile == 1.100.200-2.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Module-CPANfile-1.100.200-2.mga6.noarch.rpm
Source Package perl-Module-CPANfile-1.100.200-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Module-CPANfile rpm package:
    # urpmi perl-Module-CPANfile

Files

Path
/usr/bin/cpanfile-dump
/usr/bin/mymeta-cpanfile
/usr/lib/perl5/vendor_perl/5.22.2/cpanfile-faq.pod
/usr/lib/perl5/vendor_perl/5.22.2/cpanfile.pod
/usr/lib/perl5/vendor_perl/5.22.2/Module/CPANfile.pm
/usr/lib/perl5/vendor_perl/5.22.2/Module/CPANfile/Environment.pm
/usr/lib/perl5/vendor_perl/5.22.2/Module/CPANfile/Prereq.pm
/usr/lib/perl5/vendor_perl/5.22.2/Module/CPANfile/Prereqs.pm
/usr/lib/perl5/vendor_perl/5.22.2/Module/CPANfile/Requirement.pm
/usr/share/doc/perl-Module-CPANfile/Changes
/usr/share/doc/perl-Module-CPANfile/LICENSE
/usr/share/doc/perl-Module-CPANfile/META.json
/usr/share/doc/perl-Module-CPANfile/META.yml
/usr/share/doc/perl-Module-CPANfile/MYMETA.yml
/usr/share/doc/perl-Module-CPANfile/README
/usr/share/man/man1/cpanfile-dump.1.xz
/usr/share/man/man1/mymeta-cpanfile.1.xz
/usr/share/man/man3/Module::CPANfile.3pm.xz
/usr/share/man/man3/cpanfile-faq.3pm.xz
/usr/share/man/man3/cpanfile.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 1.100.200-2.mga6
+ Revision: 1029947
- Rebuild for perl 5.22.2
2016-02-25 - shlomif <shlomif> 1.100.200-1.mga6
+ Revision: 978804
- update to 1.1002
2016-02-19 - umeabot <umeabot> 1.100.100-2.mga6
+ Revision: 969639
- Mageia 6 Mass Rebuild
2015-09-06 - sander85 <sander85> 1.100.100-1.mga6
+ Revision: 873540
- update to 1.1001
2014-10-19 - umeabot <umeabot> 1.0.200-5.mga5
+ Revision: 789289
- Rebuild to potentially add missing dependencies
2014-10-15 - umeabot <umeabot> 1.0.200-4.mga5
+ Revision: 739085
- Second Mageia 5 Mass Rebuild
2014-10-02 - tv <tv> 1.0.200-3.mga5
+ Revision: 735702
- add exclude
2014-09-16 - umeabot <umeabot> 1.0.200-2.mga5
+ Revision: 685418
- Mageia 5 Mass Rebuild
2014-02-04 - shlomif <shlomif> 1.0.200-1.mga5
+ Revision: 581482
- imported package perl-Module-CPANfile
2014-02-04 - cpan2dist 1.0002-1mga
- initial mageia release, generated with cpan2dist

See Also

Package Description
perl-Module-Compile-0.350.0-3.mga6.noarch.rpm Perl Module Compilation
perl-Module-CoreList-5.201.604.290-1.mga6.noarch.rpm Tell what modules shipped with versions of perl
perl-Module-Data-0.7.0-6.mga6.noarch.rpm Introspect context information about modules in
perl-Module-Depends-0.160.0-6.mga6.noarch.rpm Intrusive discovery of distribution dependencies
perl-Module-Extract-0.10.0-9.mga6.noarch.rpm Base class for working with Perl distributions
perl-Module-Extract-Namespaces-1.20.0-6.mga6.noarch.rpm Extract the package declarations from a module
perl-Module-Extract-Use-1.40.0-6.mga6.noarch.rpm Pull out the modules a module uses
perl-Module-Extract-VERSION-1.10.0-9.mga6.noarch.rpm Extract a module version without running code
perl-Module-ExtractUse-0.341.0-2.mga6.noarch.rpm Find out what modules are used
perl-Module-Find-0.130.0-3.mga6.noarch.rpm Find and use installed modules in a (sub)category
perl-Module-Format-0.0.7-3.mga6.noarch.rpm Convert and manipulate stringified versions of Perl modules
perl-Module-Implementation-0.90.0-5.mga6.noarch.rpm Loads one of several alternate underlying implementations for a module
perl-Module-Info-0.370.0-2.mga6.noarch.rpm Information about Perl modules
perl-Module-Inspector-1.50.0-8.mga6.noarch.rpm An integrated API for inspecting Perl distributions
perl-Module-Install-1.160.0-3.mga6.noarch.rpm Standalone, extensible Perl module installer
Advertisement
Advertisement