perl-Pod-Weaver-Section-AllowOverride-0.50.0-2.mga6.noarch.rpm


Advertisement

Description

perl-Pod-Weaver-Section-AllowOverride - Allow POD to override a Pod::Weaver-provided section

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package name perl-Pod-Weaver-Section-AllowOverride
Package version 0.50.0
Package release 2.mga6
Package architecture noarch
Package type rpm
Installed size 50.11 KB
Download size 23.01 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Sometimes, you might want to override a normally-generic section in one of
your modules. This section plugin replaces the preceding section with the
corresponding section taken from your POD (if it exists). If your POD
doesn't contain a matching section, then the Pod::Weaver-provided one will
be used.
Both the original section in your POD and the section provided by
Pod::Weaver must match the 'header_re'. Also, this plugin must immediately
follow the section you want to replace (unless you set 'match_anywhere' to
a true value).
It's a similar idea to the Pod::Weaver::Role::SectionReplacer manpage,
except that it works the other way around. SectionReplacer replaces the
section from your POD with a section provided by Pod::Weaver.

Alternatives

Package Version Architecture Repository
perl-Pod-Weaver-Section-AllowOverride-0.50.0-2.mga6.noarch.rpm 0.50.0 noarch Mageia Core
perl-Pod-Weaver-Section-AllowOverride - - -

Requires

Name Value
perl >= 1:5.010
perl(Moose) -
perl(Moose::Util::TypeConstraints) -
perl(Pod::Elemental::MakeSelector) -
perl(Pod::Weaver::Role::Section) -
perl(Pod::Weaver::Role::Transformer) -
perl(namespace::autoclean) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Pod::Weaver::Section::AllowOverride) == 0.50.0
perl-Pod-Weaver-Section-AllowOverride == 0.50.0-2.mga6

Download

Type URL
Binary Package perl-Pod-Weaver-Section-AllowOverride-0.50.0-2.mga6.noarch.rpm
Source Package perl-Pod-Weaver-Section-AllowOverride-0.50.0-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Pod-Weaver-Section-AllowOverride rpm package:
    # urpmi perl-Pod-Weaver-Section-AllowOverride

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Pod/
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Weaver/
/usr/lib/perl5/vendor_perl/5.22.2/Pod/Weaver/Section/AllowOverride.pm
/usr/share/doc/perl-Pod-Weaver-Section-AllowOverride/Changes
/usr/share/doc/perl-Pod-Weaver-Section-AllowOverride/LICENSE
/usr/share/doc/perl-Pod-Weaver-Section-AllowOverride/META.json
/usr/share/doc/perl-Pod-Weaver-Section-AllowOverride/META.yml
/usr/share/doc/perl-Pod-Weaver-Section-AllowOverride/README
/usr/share/man/man3/Pod::Weaver::Section::AllowOverride.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 0.50.0-2.mga6
+ Revision: 1032344
- Rebuild for perl 5.22.2
2016-01-01 - shlomif <shlomif> 0.50.0-1.mga6
+ Revision: 917996
- importing from cpan2pkg
2015-12-28 - cpan2dist 0.05-1mga
- initial mageia release, generated with cpan2dist

See Also

Package Description
perl-Pod-Weaver-Section-Availability-1.200.0-7.mga6.noarch.rpm Add an AVAILABILITY pod section
perl-Pod-Weaver-Section-BugsAndLimitations-1.200.0-8.mga6.noarch.rpm Add a BUGS AND LIMITATIONS pod section
perl-Pod-Weaver-Section-BugsRT-0.520.0-8.mga6.noarch.rpm Add a BUGS pod section for rt.cpan.org
perl-Pod-Weaver-Section-Consumes-0.10.0-6.mga6.noarch.rpm Add a list of roles to your POD
perl-Pod-Weaver-Section-Contributors-0.9.0-3.mga6.noarch.rpm A section listing contributors
perl-Pod-Weaver-Section-Extends-0.9.0-6.mga6.noarch.rpm Add a list of parent classes to your POD
perl-Pod-Weaver-Section-GenerateSection-1.20.0-1.mga6.noarch.rpm Add pod section from an interpolated piece of text
perl-Pod-Weaver-Section-Installation-1.101.421-7.mga6.noarch.rpm Add an INSTALLATION pod section
perl-Pod-Weaver-Section-SeeAlso-1.3.0-3.mga6.noarch.rpm Add a SEE ALSO pod section
perl-Pod-Weaver-Section-SourceGitHub-0.540.0-8.mga6.noarch.rpm Add SOURCE pod section for a github repository
perl-Pod-Weaver-Section-Support-1.7.0-3.mga6.noarch.rpm Add a SUPPORT section to your POD
perl-Pod-Weaver-Section-WarrantyDisclaimer-0.121.290-8.mga6.noarch.rpm Add a standard DISCLAIMER OF WARRANTY section (for your Perl module)
perl-Pod-WikiDoc-0.200.0-8.mga6.noarch.rpm Examples of Pod::WikiDoc usage
perl-Pod-Wordlist-hanekomu-1.132.680-6.mga6.noarch.rpm Add words for spell checking POD
perl-Pod-Wrap-0.10.0-3.mga6.noarch.rpm Wrap pod paragraphs, leaving verbatim text and code alone
Advertisement
Advertisement