vim-enhanced-8.0.388-1.mga6.i586.rpm


Advertisement

Description

vim-enhanced - A version of the VIM editor which includes recent enhancements

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name vim-enhanced
Package version 8.0.388
Package release 1.mga6
Package architecture i586
Package type rpm
Installed size 2.69 MB
Download size 1.13 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
VIM (VIsual editor iMproved) is an updated and improved version of the
vi editor.  Vi was the first real screen-based editor for UNIX, and is
still very popular.  VIM improves on vi by adding new features:
multiple windows, multi-level undo, block highlighting and more.  The
vim-enhanced package contains a version of VIM with extra, recently
introduced features like Python and Perl interpreters.
Install the vim-enhanced package if you'd like to use a version of the
VIM editor which includes recently added enhancements like
interpreters for the Python and Perl scripting languages.  You'll also
need to install the vim-common package.

Alternatives

Package Version Architecture Repository
vim-enhanced-8.0.388-1.mga6.x86_64.rpm 8.0.388 x86_64 Mageia Core
vim-enhanced - - -

Requires

Name Value
libacl.so.1 -
libacl.so.1(ACL_1.0) -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgpm.so.2 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libperl.so.5.22 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libruby.so.2.2 -
libtcl8.6.so -
libtinfo.so.6 -
perl-base == 2:5.22.3
update-alternatives -
vim-common >= 8.0.388-1.mga6

Provides

Name Value
vim -
vim-color -
vim-enhanced == 8.0.388-1.mga6
vim-enhanced(x86-32) == 8.0.388-1.mga6

Obsoletes

Name Value
vim-color -

Download

Type URL
Binary Package vim-enhanced-8.0.388-1.mga6.i586.rpm
Source Package vim-8.0.388-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install vim-enhanced rpm package:
    # urpmi vim-enhanced

Files

Path
/usr/bin/ex
/usr/bin/vim-enhanced
/usr/bin/vimdiff
/usr/share/doc/vim-enhanced/README.txt
/usr/share/doc/vim-enhanced/README_ami.txt
/usr/share/doc/vim-enhanced/README_amibin.txt
/usr/share/doc/vim-enhanced/README_amisrc.txt
/usr/share/doc/vim-enhanced/README_bindos.txt
/usr/share/doc/vim-enhanced/README_dos.txt
/usr/share/doc/vim-enhanced/README_extra.txt
/usr/share/doc/vim-enhanced/README_mac.txt
/usr/share/doc/vim-enhanced/README_macros.txt
/usr/share/doc/vim-enhanced/README_ole.txt
/usr/share/doc/vim-enhanced/README_os2.txt
/usr/share/doc/vim-enhanced/README_os390.txt
/usr/share/doc/vim-enhanced/README_src.txt
/usr/share/doc/vim-enhanced/README_srcdos.txt
/usr/share/doc/vim-enhanced/README_tools.txt
/usr/share/doc/vim-enhanced/README_unix.txt
/usr/share/doc/vim-enhanced/README_vms.txt
/usr/share/doc/vim-enhanced/README_w32s.txt

Changelog

2017-03-02 - tv <tv> 8.0.388-1.mga6
+ Revision: 1088468
- new release (security fix, mga#19829)
2017-01-31 - shlomif <shlomif> 8.0.176-2.mga6
+ Revision: 1084399
- Rebuild for the new perl.
+ tv <tv>
- new release
2017-01-12 - tv <tv> 8.0.160-1.mga6
+ Revision: 1081193
- new release
- use FC patch for disabling mouse
- use defaults.vim instead of vimrc_example for system vimrc
2017-01-07 - tv <tv> 8.0.133-3.mga6
+ Revision: 1080494
- enable to copy/paste with mouse like by default in previous versions (mga#19467)
2016-12-20 - tv <tv> 8.0.133-2.mga6
+ Revision: 1076207
- new release
2016-11-23 - neoclust <neoclust> 8.0.095-2.mga6
+ Revision: 1069371
- New version 8.0.0095 ( Fix CVE CVE-2016-1248)
2016-11-08 - tv <tv> 8.0.038-2.mga6
+ Revision: 1065827
- disable gpm support in vim-minimal (mga#19467)
2016-10-26 - tv <tv> 8.0.038-1.mga6
+ Revision: 1063602
- new version
- use FC way to update as upstream patches from FTP server do not apply cleanly
2016-10-11 - pterjan <pterjan> 8.0.5-3.mga6
+ Revision: 1060186
- Rebuild some recently rejected packages, some were due to a bug in the build system
2016-10-04 - daviddavid <daviddavid> 8.0.5-2.mga6
+ Revision: 1058317
- fix a dangling link removing no more needed and useless locale symlink
since "%pre common" section was removed in commit 397203 (mga#19371)

See Also

Package Description
vim-halibut-1.1-2.mga6.noarch.rpm Syntax file for the halibut manual tool
vim-minimal-8.0.388-1.mga6.i586.rpm A minimal version of the VIM editor
vim-powerline-2.5-3.mga6.noarch.rpm Powerline VIM plugin
vim-puppet-4.2.1-4.mga6.noarch.rpm Syntax highlighting for puppet manifests in vim
vimana-2.260.0-7.mga6.noarch.rpm Download a vim plugin package
vinagre-3.22.0-3.mga6.i586.rpm VNC Client for the GNOME Desktop
vino-3.22.0-2.mga6.i586.rpm GNOME VNC server
virglrenderer-test-server-0.5.0-1.mga6.i586.rpm Virgil3D renderer testing server
virt-dib-1.34.3-2.mga6.i586.rpm Safe and secure diskimage-builder replacement
virt-install-1.4.1-1.mga6.noarch.rpm Utilities for installing virtual machines
virt-manager-1.4.1-1.mga6.noarch.rpm Desktop tool for managing virtual machines via libvirt
virt-manager-common-1.4.1-1.mga6.noarch.rpm Common files used by the different Virtual Machine Manager interfaces
virt-v2v-1.34.3-2.mga6.i586.rpm Convert a virtual machine to run on KVM
virt-what-1.15-2.mga6.i586.rpm Detect if we are running in a virtual machine
virtaal-0.7.1-9.mga6.noarch.rpm Localization and translation editor
Advertisement
Advertisement