eclipse-equinox-osgi-4.6.3-6.mga6.x86_64.rpm


Advertisement

Description

eclipse-equinox-osgi - Eclipse OSGi - Equinox

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename eclipse-equinox-osgi-4.6.3-6.mga6.x86_64.rpm
Package name eclipse-equinox-osgi
Package version 4.6.3
Package release 6.mga6
Package architecture x86_64
Package type rpm
Category Development/Java
Homepage http://www.eclipse.org/
License EPL
Maintainer -
Download size 1.45 MB
Installed size 1.61 MB
Eclipse OSGi - Equinox

Alternatives

Package Version Architecture Repository
eclipse-equinox-osgi-4.6.3-6.mga6.i586.rpm 4.6.3 i586 Mageia Core
eclipse-equinox-osgi - - -

Requires

Name Value
eclipse-filesystem -
java-headless -
java-headless >= 1:1.7.0
javapackages-tools -

Provides

Name Value
eclipse-equinox-osgi == 1:4.6.3-6.mga6
eclipse-equinox-osgi(x86-64) == 1:4.6.3-6.mga6
mvn(org.eclipse.osgi:compatibility.state) == 1.0.200.v20170515.1356
mvn(org.eclipse.osgi:compatibility.state:pom:) == 1.0.200.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi) == 3.11.3.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.compatibility.state) == 1.0.200.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.compatibility.state:pom:) == 1.0.200.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.services) == 3.5.100.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.services:pom:) == 3.5.100.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.util) == 3.3.100.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi.util:pom:) == 3.3.100.v20170515.1356
mvn(org.eclipse.osgi:org.eclipse.osgi:pom:) == 3.11.3.v20170515.1356
mvn(org.eclipse.osgi:services) == 3.5.100.v20170515.1356
mvn(org.eclipse.osgi:services:pom:) == 3.5.100.v20170515.1356
mvn(org.eclipse.osgi:util) == 3.3.100.v20170515.1356
mvn(org.eclipse.osgi:util:pom:) == 3.3.100.v20170515.1356
mvn(org.eclipse.tycho:org.eclipse.osgi) == 3.11.3.v20170515.1356
mvn(org.eclipse.tycho:org.eclipse.osgi.compatibility.state) == 1.0.200.v20170515.1356
mvn(org.eclipse.tycho:org.eclipse.osgi.compatibility.state:pom:) == 1.0.200.v20170515.1356
mvn(org.eclipse.tycho:org.eclipse.osgi:pom:) == 3.11.3.v20170515.1356
mvn(org.eclipse:osgi) == 3.11.3.v20170515.1356
mvn(org.eclipse:osgi:pom:) == 3.11.3.v20170515.1356
osgi(org.eclipse.osgi) == 3.11.3
osgi(org.eclipse.osgi.compatibility.state) == 1.0.200
osgi(org.eclipse.osgi.services) == 3.5.100
osgi(org.eclipse.osgi.util) == 3.3.100
osgi(system.bundle) == 1:4.6.3

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package eclipse-equinox-osgi-4.6.3-6.mga6.x86_64.rpm
Source Package eclipse-4.6.3-6.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install eclipse-equinox-osgi rpm package:
    # urpmi eclipse-equinox-osgi

Files

Path
/usr/lib64/eclipse/plugins/org.eclipse.osgi.compatibility.state_1.0.200.v20170515-1356.jar
/usr/lib64/eclipse/plugins/org.eclipse.osgi.services_3.5.100.v20170515-1356.jar
/usr/lib64/eclipse/plugins/org.eclipse.osgi.util_3.3.100.v20170515-1356.jar
/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.11.3.v20170515-1356.jar
/usr/share/java/eclipse/osgi.compatibility.state.jar
/usr/share/java/eclipse/osgi.jar
/usr/share/java/eclipse/osgi.services.jar
/usr/share/java/eclipse/osgi.util.jar
/usr/share/maven-metadata/eclipse-equinox-osgi.xml
/usr/share/maven-poms/JPP.eclipse-osgi.compatibility.state.pom
/usr/share/maven-poms/JPP.eclipse-osgi.pom
/usr/share/maven-poms/JPP.eclipse-osgi.services.pom
/usr/share/maven-poms/JPP.eclipse-osgi.util.pom

Changelog

2017-05-25 - neoclust <neoclust> 1:4.6.3-6.mga6
+ Revision: 1104696
- Rebuild w/o bootstrap
2017-05-22 - neoclust <neoclust> 1:4.6.3-5.mga6
+ Revision: 1104047
- Bootstrap build for arm
- Rebuild against fixed deps
2017-05-15 - neoclust <neoclust> 1:4.6.3-3.mga6
+ Revision: 1101830
- Update to Neon 3
2016-10-08 - neoclust <neoclust> 1:4.6.1-3.mga6
+ Revision: 1059574
- Rebuild for arm
2016-09-16 - daviddavid <daviddavid> 1:4.6.1-1.mga6
+ Revision: 1053469
- Update to Neon.1 (4.6.1) release
- Set qualifiers at source-modification-time instead of build-time, to
eliminate descrepancies between architectures, rhbz#1374938
- Set bootstrap flag for new primary architecture
- Rebuild for new eclipse-ecf
2016-09-11 - daviddavid <daviddavid> 1:4.6.0-3.mga6
+ Revision: 1051438
- Rebuild for latest jsch and sync with fc24:
* Add missing droplets logic to the EngineActivator
* Restore 'p2.runnable' property for droplets
* Improve 'p2.runnable' check in ExtensionLocationArtifactRepository
* Disable droplets being loaded by the reconciler
* Fix possible NPE in droplet p2.runnable property check
2016-07-17 - neoclust <neoclust> 1:4.6.0-2.mga6
+ Revision: 1042364
- Change PopupDialog from SWT.COLOR_INFO* to SWT.COLOR_LIST*
- Update eclipse-pde-tp-support-droplets.patch to handle source bundles.
2016-06-15 - daviddavid <daviddavid> 1:4.6.0-1.mga6
+ Revision: 1021614
- Update to Neon release
2016-06-14 - pterjan <pterjan> 1:4.6.0-0.6.git201605092000.3.mga6
+ Revision: 1021442
- Fix missing symlinks due to _ in the qualifier
- Do not use date as ContextQualifier, this breaks when different arches are not built on the same day
2016-05-14 - shlomif <shlomif> 1:4.6.0-0.6.git201605092000.2.mga6
+ Revision: 1015267
- Rebuild for the new UCI (new major)

See Also

Package Description
eclipse-filesystem-1.0-8.mga6.x86_64.rpm Eclipse Platform Filesystem Layout
eclipse-gcov-5.3.1-3.mga6.noarch.rpm GCov Integration
eclipse-gef-3.11.0-1.mga6.noarch.rpm Graphical Editing Framework (GEF) Eclipse plug-in
eclipse-gef-examples-3.11.0-1.mga6.noarch.rpm Eclipse GEF examples
eclipse-gef-sdk-3.11.0-1.mga6.noarch.rpm Eclipse GEF SDK
eclipse-gef-tests-3.11.0-1.mga6.noarch.rpm Eclipse GEF Tests
eclipse-gprof-5.3.1-3.mga6.noarch.rpm GProf Integration
eclipse-jdt-4.6.3-6.mga6.noarch.rpm Eclipse Java Development Tools
eclipse-jgit-4.7.0-3.mga6.noarch.rpm Eclipse JGit
eclipse-launchbar-2.1.0-1.mga6.noarch.rpm Eclipse Launchbar plug-in
eclipse-license-1.0.1-11.mga6.noarch.rpm Shared license feature for Eclipse
eclipse-linuxtools-5.3.1-3.mga6.noarch.rpm Linux specific Eclipse plugins
eclipse-linuxtools-docker-5.3.1-3.mga6.noarch.rpm Docker Tooling
eclipse-linuxtools-javadocs-5.3.1-3.mga6.noarch.rpm Javadocs documentaton plugin for Eclipse
eclipse-linuxtools-libhover-5.3.1-3.mga6.noarch.rpm Libhover documentaton plugin for Eclipse
Advertisement
Advertisement