fcgi-2.4.0-19.mga6.x86_64.rpm


Advertisement

Description

fcgi - The FastCGI development kit

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package name fcgi
Package version 2.4.0
Package release 19.mga6
Package architecture x86_64
Package type rpm
Installed size 87.46 KB
Download size 37.60 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
FastCGI is an open extension to CGI that provides high performance
for all Internet applications without the penalties of Web server
APIs.
FastCGI is designed to be layered on top of existing Web server
APIs. For instance, the mod_fastcgi Apache module adds FastCGI
support to the Apache server. FastCGI can also be used, with
reduced functionality and reduced performance, on any Web server
that supports CGI.
This FastCGI Developer's Kit is designed to make developing
FastCGI applications easy. The kit currently supports FastCGI
applications written in C/C++, Perl, Tcl, and Java.
This package contains only shared libraries used by programs
developed using FastCGI Developer's Kit and cgi-fcgi (bridge from
CGI to FastCGI).

Alternatives

Package Version Architecture Repository
fcgi-2.4.0-19.mga6.i586.rpm 2.4.0 i586 Mageia Core
fcgi - - -

Requires

Name Value
lib64fcgi0 == 2.4.0
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libfcgi++.so.0()(64bit) -
libfcgi.so.0()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.5)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
fcgi == 2.4.0-19.mga6
fcgi(x86-64) == 2.4.0-19.mga6

Download

Type URL
Binary Package fcgi-2.4.0-19.mga6.x86_64.rpm
Source Package fcgi-2.4.0-19.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install fcgi rpm package:
    # urpmi fcgi

Files

Path
/usr/bin/cgi-fcgi
/usr/share/man/man1/cgi-fcgi.1.xz
/usr/share/man/man3/FCGI_Accept.3.xz
/usr/share/man/man3/FCGI_Finish.3.xz
/usr/share/man/man3/FCGI_SetExitStatus.3.xz
/usr/share/man/man3/FCGI_StartFilterData.3.xz
/var/www/fcgi-bin/authorizer
/var/www/fcgi-bin/echo
/var/www/fcgi-bin/echo-cpp
/var/www/fcgi-bin/echo-x
/var/www/fcgi-bin/log-dump
/var/www/fcgi-bin/size
/var/www/fcgi-bin/threaded

Changelog

2016-02-09 - umeabot <umeabot> 2.4.0-19.mga6
+ Revision: 952424
- Mageia 6 Mass Rebuild
2015-02-25 - luigiwalser <luigiwalser> 2.4.0-18.mga5
+ Revision: 817007
- add patch from fedora to fix CVE-2012-6687
2014-10-15 - umeabot <umeabot> 2.4.0-17.mga5
+ Revision: 741706
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 2.4.0-16.mga5
+ Revision: 679108
- Mageia 5 Mass Rebuild
2013-10-19 - umeabot <umeabot> 2.4.0-15.mga4
+ Revision: 532579
- Mageia 4 Mass Rebuild
2013-08-21 - wally <wally> 2.4.0-14.mga4
+ Revision: 468800
- drop major from devel pkg name

See Also

Package Description
fcitx-4.2.9.1-4.mga6.x86_64.rpm Fcitx - Free Chinese Input Toys for X
fcitx-chewing-0.2.2-2.mga6.x86_64.rpm Chewing Wrapper for Fcitx
fcitx-configtool-0.4.9-1.mga6.x86_64.rpm Gtk configuretool for Fcitx
fcitx-devel-4.2.9.1-4.mga6.x86_64.rpm fcitx development library
fcitx-gir-4.2.9.1-4.mga6.x86_64.rpm GObject Introspection interface description for fcitx
fcitx-gtk-4.2.9.1-4.mga6.x86_64.rpm fcitx gtk module
fcitx-gtk3-4.2.9.1-4.mga6.x86_64.rpm fcitx gtk3 module
fcitx-qt4-4.2.9.1-4.mga6.x86_64.rpm Qt4 immodule for fcitx
fcitx-qt5-1.1.0-2.mga6.x86_64.rpm Fcitx IM module for Qt5
fcitx-qt5-devel-1.1.0-2.mga6.x86_64.rpm Development files for fcitx-qt5
fcode-utils-1.0.2-2.mga6.x86_64.rpm Utilities for dealing with FCode
fcoe-utils-1.0.30-8.git91c0c8c.mga6.x86_64.rpm Fibre Channel over Ethernet utilities
fcron-3.2.0-2.mga6.x86_64.rpm Task scheduler
fdupes-1.51-6.mga6.x86_64.rpm Identify or delete duplicate files
featherpad-0.6-1.mga6.x86_64.rpm Lightweight Qt5 Plain-Text Editor for Linux
Advertisement
Advertisement