gcs-oauth2-boto-plugin-1.9-3.mga6.noarch.rpm


Advertisement

Description

gcs-oauth2-boto-plugin - Plugin for boto to support OAuth 2.0 for Google Cloud Storage

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package name gcs-oauth2-boto-plugin
Package version 1.9
Package release 3.mga6
Package architecture noarch
Package type rpm
Installed size 106.32 KB
Download size 33.29 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
gcs-oauth2-boto-plugin is a Python application whose purpose is to behave
as an auth plugin for the boto auth plugin framework for use with OAuth 2.0
credentials for the Google Cloud Platform.
This plugin is compatible with both user accounts and service accounts,
and its functionality is essentially a wrapper around the oauth2client
package of google-api-python-client with the addition of automatically
caching tokens for the machine in a thread- and process-safe fashion.

Alternatives

Package Version Architecture Repository
gcs-oauth2-boto-plugin-1.9-3.mga6.noarch.rpm 1.9 noarch Mageia Core
gcs-oauth2-boto-plugin - - -

Requires

Name Value
python(abi) == 2.7
pythonegg(2)(boto) >= 2.29.1
pythonegg(2)(google-api-python-client) >= 1.1
pythonegg(2)(httplib2) >= 0.8
pythonegg(2)(pyopenssl) >= 0.13
pythonegg(2)(retry-decorator) >= 1.0.0
pythonegg(2)(socksipy-branch) >= 1.01

Provides

Name Value
gcs-oauth2-boto-plugin == 1.9-3.mga6
pythonegg(2)(gcs-oauth2-boto-plugin) == 1.9

Download

Type URL
Binary Package gcs-oauth2-boto-plugin-1.9-3.mga6.noarch.rpm
Source Package gcs-oauth2-boto-plugin-1.9-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install gcs-oauth2-boto-plugin rpm package:
    # urpmi gcs-oauth2-boto-plugin

Files

Path
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/__init__.py
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/__init__.pyc
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/__init__.pyo
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_client.py
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_client.pyc
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_client.pyo
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_helper.py
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_helper.pyc
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_helper.pyo
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_plugin.py
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_plugin.pyc
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/oauth2_plugin.pyo
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/test_oauth2_client.py
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/test_oauth2_client.pyc
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin/test_oauth2_client.pyo
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/gcs_oauth2_boto_plugin-1.9-py2.7.egg-info/zip-safe

Changelog

2016-04-27 - daviddavid <daviddavid> 1.9-3.mga6
+ Revision: 1006935
- use new python macros
2016-02-19 - umeabot <umeabot> 1.9-2.mga6
+ Revision: 969810
- Mageia 6 Mass Rebuild
2015-09-13 - pterjan <pterjan> 1.9-1.mga6
+ Revision: 878986
- Fix dependencies
- imported package gcs-oauth2-boto-plugin

See Also

Package Description
gcstar-1.7.1-1.mga6.noarch.rpm A collection manager
gd-utils-2.2.4-3.mga6.x86_64.rpm The Utils files for gd
gdal-2.0.2-5.mga6.x86_64.rpm The Geospatial Data Abstraction Library (GDAL)
gdb-7.12-16.mga6.x86_64.rpm A GNU source-level debugger for C, C++, Fortran, Go and other languages
gdb-doc-7.12-16.mga6.noarch.rpm Documentation for GDB (the GNU source-level debugger)
gdb-gdbserver-7.12-16.mga6.x86_64.rpm A standalone server for GDB (the GNU source-level debugger)
gdbm-1.12-1.mga6.x86_64.rpm A GNU set of database routines which use extensible hashing
gdisk-1.0.1-1.mga6.x86_64.rpm An fdisk-like partitioning tool for GPT disks
gdk-pixbuf2.0-2.36.6-1.mga6.x86_64.rpm Image loading and manipulation library for GTK+
gdl-i18n-3.22.0-1.mga6.x86_64.rpm Gnome Docking library - translations
gdm-3.24.2-1.mga6.x86_64.rpm The GNOME Display Manager
gdouros-symbola-fonts-9.00-1.mga6.noarch.rpm A symbol font
gdouros-symbola-fonts-doc-9.00-1.mga6.noarch.rpm Glyph table for gdouros-symbola font
geany-1.30.1-1.mga6.x86_64.rpm Small C editor using GTK+ 2
geany-plugins-1.30-3.mga6.x86_64.rpm A collection of different plugins for Geany
Advertisement
Advertisement