geany-plugins-geanylua-1.30-3.mga6.x86_64.rpm


Advertisement

Description

geany-plugins-geanylua - Lua Scripting for Geany

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename geany-plugins-geanylua-1.30-3.mga6.x86_64.rpm
Package name geany-plugins-geanylua
Package version 1.30
Package release 3.mga6
Package architecture x86_64
Package type rpm
Category Development/Tools
Homepage http://plugins.geany.org/
License GPLv2+ and GPLv3+
Maintainer -
Download size 108.69 KB
Installed size 458.94 KB
This plugin provides extensive support for developing in the lua programming
language.

Alternatives

Package Version Architecture Repository
geany-plugins-geanylua-1.30-3.mga6.i586.rpm 1.30 i586 Mageia Core
geany-plugins-geanylua - - -

Requires

Name Value
geany-plugins-common >= 1.30-3.mga6
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgeany.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
liblua.so.5.1()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
lua5.1 -

Provides

Name Value
geany-plugins-geanylua == 1.30-3.mga6
geany-plugins-geanylua(x86-64) == 1.30-3.mga6
libgeanylua.so()(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package geany-plugins-geanylua-1.30-3.mga6.x86_64.rpm
Source Package geany-plugins-1.30-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install geany-plugins-geanylua rpm package:
    # urpmi geany-plugins-geanylua

Files

Path
/usr/lib64/geany/geanylua.so
/usr/lib64/geany-plugins/geanylua/libgeanylua.so
/usr/share/doc/geany-plugins/geanylua/AUTHORS
/usr/share/doc/geany-plugins/geanylua/COPYING
/usr/share/doc/geany-plugins/geanylua/ChangeLog
/usr/share/doc/geany-plugins/geanylua/NEWS
/usr/share/doc/geany-plugins/geanylua/README
/usr/share/doc/geany-plugins/geanylua/geanylua-index.html
/usr/share/doc/geany-plugins/geanylua/geanylua-input.html
/usr/share/doc/geany-plugins/geanylua/geanylua-intro.html
/usr/share/doc/geany-plugins/geanylua/geanylua-keyfile.html
/usr/share/doc/geany-plugins/geanylua/geanylua-keys.html
/usr/share/doc/geany-plugins/geanylua/geanylua-ref.html
/usr/share/doc/geany-plugins/geanylua/luarefv51.html
/usr/share/geany-plugins/geanylua/
/usr/share/geany-plugins/geanylua/dialogs/basic-dialogs.lua
/usr/share/geany-plugins/geanylua/dialogs/complex-dialog.lua
/usr/share/geany-plugins/geanylua/edit/calculator.lua
/usr/share/geany-plugins/geanylua/edit/lua-replace.lua
/usr/share/geany-plugins/geanylua/edit/proper-case.lua
/usr/share/geany-plugins/geanylua/edit/reverse.lua
/usr/share/geany-plugins/geanylua/edit/right-trim.lua
/usr/share/geany-plugins/geanylua/edit/select-block.lua
/usr/share/geany-plugins/geanylua/info/about.lua
/usr/share/geany-plugins/geanylua/info/app-information.lua
/usr/share/geany-plugins/geanylua/info/file-information.lua
/usr/share/geany-plugins/geanylua/info/list-open-files.lua
/usr/share/geany-plugins/geanylua/info/show-filename.lua
/usr/share/geany-plugins/geanylua/scripting/help.lua
/usr/share/geany-plugins/geanylua/scripting/open-script.lua
/usr/share/geany-plugins/geanylua/scripting/rebuild-menu.lua
/usr/share/geany-plugins/geanylua/scripting/show-examples.lua
/usr/share/geany-plugins/geanylua/work/01.edit-test-script.lua
/usr/share/geany-plugins/geanylua/work/02.run-test-script.lua
/usr/share/geany-plugins/geanylua/work/03.install-test-script.lua

Changelog

2017-06-04 - akien <akien> 1.30-3.mga6
+ Revision: 1106482
- Rebuild for devhelp 3.24.0
2017-03-29 - akien <akien> 1.30-2.mga6
+ Revision: 1095209
- Rebuild for libgit2 0.25.0
2017-03-11 - akien <akien> 1.30-1.mga6
+ Revision: 1091891
- Version 1.30
2016-11-14 - akien <akien> 1.29-1.mga6
+ Revision: 1067107
- Version 1.29
o geanylipsum renamed to lipsum
o new git-changebar plugin
2016-07-28 - akien <akien> 1.28-1.mga6
+ Revision: 1043831
- Turn all Requires to Recommends
- Version 1.28
o geanysendmail plugin is renamed to sendmail
2016-03-21 - daviddavid <daviddavid> 1.27-3.mga6
+ Revision: 993792
- fix bogus requires
2016-03-14 - akien <akien> 1.27-2.mga6
+ Revision: 990626
- Requires -lineoperations
2016-03-14 - akien <akien> 1.27-1.mga6
+ Revision: 990611
- Fix %files, new lineoperations plugin
- Version 1.27
2016-01-13 - akien <akien> 1.26-1.mga6
+ Revision: 922332
- Version 1.26
- gproject plugin renamed to projectorganizer
- adds automark, geanyctags and overview plugins
2015-10-17 - daviddavid <daviddavid> 1.24-5.mga6
+ Revision: 892413
- add more docs to fix build with latest rpm

See Also

Package Description
geany-plugins-geanymacro-1.30-3.mga6.x86_64.rpm User defined Macros for Geany
geany-plugins-geanyminiscript-1.30-3.mga6.x86_64.rpm Geany Mini-Script filter plugin
geany-plugins-geanynumberedbookmarks-1.30-3.mga6.x86_64.rpm Provide users 10 numbered Bookmarks
geany-plugins-geanypg-1.30-3.mga6.x86_64.rpm Encrypt, decrypt and verify signatures with GnuPG
geany-plugins-geanyprj-1.30-3.mga6.x86_64.rpm Provides an alternate project management tool for Geany
geany-plugins-geanypy-1.30-3.mga6.x86_64.rpm Write Geany plugins in Python
geany-plugins-geanyvc-1.30-3.mga6.x86_64.rpm Version Control for Geany
geany-plugins-geniuspaste-1.30-3.mga6.x86_64.rpm Use nopaste services directly from within Geany
geany-plugins-git-changebar-1.30-3.mga6.x86_64.rpm Highlight uncommitted changes and allow to navigate through hunks
geany-plugins-lineoperations-1.30-3.mga6.x86_64.rpm Assortment of simple line functions
geany-plugins-lipsum-1.30-3.mga6.x86_64.rpm Lorem Ipsum generator for Inserting Placeholder Text
geany-plugins-markdown-1.30-3.mga6.x86_64.rpm Real time preview for Markdown documents
geany-plugins-multiterm-1.30-3.mga6.x86_64.rpm MultiTerm support for Geany
geany-plugins-overview-1.30-3.mga6.x86_64.rpm Overview plugin for Geany
geany-plugins-pairtaghighlighter-1.30-3.mga6.x86_64.rpm Pair Tag Highlighter plugin for Geany
Advertisement
Advertisement