gnupg2-2.1.21-2.mga6.x86_64.rpm


Advertisement

Description

gnupg2 - GNU privacy guard - a free PGP replacement

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename gnupg2-2.1.21-2.mga6.x86_64.rpm
Package name gnupg2
Package version 2.1.21
Package release 2.mga6
Package architecture x86_64
Package type rpm
Category File tools
Homepage http://www.gnupg.org
License GPLv3+
Maintainer -
Download size 2.39 MB
Installed size 10.31 MB
GnuPG is GNU's tool for secure communication and data storage.
It can be used to encrypt data and to create digital signatures.
It includes an advanced key management facility and is compliant
with the proposed OpenPGP Internet standard as described in RFC2440.

Alternatives

Package Version Architecture Repository
gnupg2-2.1.21-3.2.mga6.x86_64.rpm 2.1.21 x86_64 Mageia Core Updates
gnupg2-2.1.21-3.2.mga6.i586.rpm 2.1.21 i586 Mageia Core Updates
gnupg2-2.1.21-3.1.mga6.x86_64.rpm 2.1.21 x86_64 Mageia Core Updates
gnupg2-2.1.21-3.1.mga6.i586.rpm 2.1.21 i586 Mageia Core Updates
gnupg2-2.1.21-3.mga6.x86_64.rpm 2.1.21 x86_64 Mageia Core Updates
gnupg2-2.1.21-3.mga6.i586.rpm 2.1.21 i586 Mageia Core Updates
gnupg2-2.1.21-2.mga6.i586.rpm 2.1.21 i586 Mageia Core
gnupg2 - - -

Requires

Name Value
config(gnupg2) == 2.1.21-2.mga6
info-install -
libassuan.so.0()(64bit) -
libassuan.so.0(LIBASSUAN_1.0)(64bit) -
libbz2.so.1()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcrypt.so.20()(64bit) -
libgcrypt.so.20(GCRYPT_1.6)(64bit) -
libgnutls.so.30()(64bit) -
libgnutls.so.30(GNUTLS_3_4)(64bit) -
libgpg-error.so.0()(64bit) -
libgpg-error.so.0(GPG_ERROR_1.0)(64bit) -
libksba.so.8()(64bit) -
libksba.so.8(KSBA_0.9)(64bit) -
liblber-2.4.so.2()(64bit) -
libldap-2.4.so.2()(64bit) -
libnpth.so.0()(64bit) -
libnpth.so.0(NPTH_1.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libreadline.so.6()(64bit) -
libresolv.so.2()(64bit) -
libresolv.so.2(GLIBC_2.2.5)(64bit) -
libsqlite3.so.0()(64bit) -
libusb-1.0.so.0()(64bit) -
libutil.so.1()(64bit) -
libutil.so.1(GLIBC_2.2.5)(64bit) -
libz.so.1()(64bit) -
pinentry -
systemd -

Provides

Name Value
config(gnupg2) == 2.1.21-2.mga6
dirmngr == 2.1.21-2.mga6
gnupg2 == 2.1.21-2.mga6
gnupg2(x86-64) == 2.1.21-2.mga6

Obsoletes

Name Value
dirmngr < 1.2.0-1

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package gnupg2-2.1.21-2.mga6.x86_64.rpm
Source Package gnupg2-2.1.21-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install gnupg2 rpm package:
    # urpmi gnupg2

Files

Path
/etc/sysconfig/gnupg2
/usr/bin/dirmngr
/usr/bin/dirmngr-client
/usr/bin/g13
/usr/bin/gpg-agent
/usr/bin/gpg-connect-agent
/usr/bin/gpg2
/usr/bin/gpgconf
/usr/bin/gpgparsemail
/usr/bin/gpgscm
/usr/bin/gpgsm
/usr/bin/gpgtar
/usr/bin/gpgv2
/usr/bin/kbxutil
/usr/bin/symcryptrun
/usr/bin/watchgnupg
/usr/lib/systemd/user/gpg-agent.service
/usr/libexec/gnupg2/dirmngr_ldap
/usr/libexec/gnupg2/gpg-check-pattern
/usr/libexec/gnupg2/gpg-preset-passphrase
/usr/libexec/gnupg2/gpg-protect-tool
/usr/libexec/gnupg2/gpg-wks-client
/usr/libexec/gnupg2/scdaemon
/usr/sbin/addgnupghome
/usr/sbin/applygnupgdefaults
/usr/sbin/g13-syshelp
/usr/share/doc/gnupg2/ChangeLog
/usr/share/doc/gnupg2/DETAILS
/usr/share/doc/gnupg2/FAQ
/usr/share/doc/gnupg2/HACKING
/usr/share/doc/gnupg2/KEYSERVER
/usr/share/doc/gnupg2/NEWS
/usr/share/doc/gnupg2/OpenPGP
/usr/share/doc/gnupg2/README
/usr/share/doc/gnupg2/THANKS
/usr/share/doc/gnupg2/TODO
/usr/share/doc/gnupg2/TRANSLATE
/usr/share/doc/gnupg2/examples/README
/usr/share/doc/gnupg2/examples/debug.prf
/usr/share/doc/gnupg2/examples/gpgconf.conf
/usr/share/doc/gnupg2/examples/pwpattern.list
/usr/share/doc/gnupg2/examples/scd-event
/usr/share/doc/gnupg2/examples/trustlist.txt
/usr/share/doc/gnupg2/examples/vsnfd.prf
/usr/share/doc/gnupg2/examples/systemd-user/README
/usr/share/doc/gnupg2/examples/systemd-user/dirmngr.service
/usr/share/doc/gnupg2/examples/systemd-user/dirmngr.socket
/usr/share/doc/gnupg2/examples/systemd-user/gpg-agent-browser.socket
/usr/share/doc/gnupg2/examples/systemd-user/gpg-agent-extra.socket
/usr/share/doc/gnupg2/examples/systemd-user/gpg-agent-ssh.socket
/usr/share/doc/gnupg2/examples/systemd-user/gpg-agent.service
/usr/share/doc/gnupg2/examples/systemd-user/gpg-agent.socket
/usr/share/info/gnupg.info-1.xz
/usr/share/info/gnupg.info-2.xz
/usr/share/info/gnupg.info.xz
/usr/share/locale/ca/LC_MESSAGES/gnupg2.mo
/usr/share/locale/cs/LC_MESSAGES/gnupg2.mo
/usr/share/locale/da/LC_MESSAGES/gnupg2.mo
/usr/share/locale/de/LC_MESSAGES/gnupg2.mo
/usr/share/locale/el/LC_MESSAGES/gnupg2.mo
/usr/share/locale/en@boldquot/LC_MESSAGES/gnupg2.mo
/usr/share/locale/en@quot/LC_MESSAGES/gnupg2.mo
/usr/share/locale/eo/LC_MESSAGES/gnupg2.mo
/usr/share/locale/es/LC_MESSAGES/gnupg2.mo
/usr/share/locale/et/LC_MESSAGES/gnupg2.mo
/usr/share/locale/fi/LC_MESSAGES/gnupg2.mo
/usr/share/locale/fr/LC_MESSAGES/gnupg2.mo
/usr/share/locale/gl/LC_MESSAGES/gnupg2.mo
/usr/share/locale/hu/LC_MESSAGES/gnupg2.mo
/usr/share/locale/id/LC_MESSAGES/gnupg2.mo
/usr/share/locale/it/LC_MESSAGES/gnupg2.mo
/usr/share/locale/ja/LC_MESSAGES/gnupg2.mo
/usr/share/locale/nb/LC_MESSAGES/gnupg2.mo
/usr/share/locale/pl/LC_MESSAGES/gnupg2.mo
/usr/share/locale/pt/LC_MESSAGES/gnupg2.mo
/usr/share/locale/ro/LC_MESSAGES/gnupg2.mo
/usr/share/locale/ru/LC_MESSAGES/gnupg2.mo
/usr/share/locale/sk/LC_MESSAGES/gnupg2.mo
/usr/share/locale/sv/LC_MESSAGES/gnupg2.mo
/usr/share/locale/tr/LC_MESSAGES/gnupg2.mo
/usr/share/locale/uk/LC_MESSAGES/gnupg2.mo
/usr/share/locale/zh_CN/LC_MESSAGES/gnupg2.mo
/usr/share/locale/zh_TW/LC_MESSAGES/gnupg2.mo
/usr/share/man/man1/dirmngr-client.1.xz
/usr/share/man/man1/gpg-agent.1.xz
/usr/share/man/man1/gpg-connect-agent.1.xz
/usr/share/man/man1/gpg-preset-passphrase.1.xz
/usr/share/man/man1/gpg2.1.xz
/usr/share/man/man1/gpgconf.1.xz
/usr/share/man/man1/gpgparsemail.1.xz
/usr/share/man/man1/gpgsm.1.xz
/usr/share/man/man1/gpgv2.1.xz
/usr/share/man/man1/scdaemon.1.xz
/usr/share/man/man1/symcryptrun.1.xz
/usr/share/man/man1/watchgnupg.1.xz
/usr/share/man/man7/gnupg.7.xz
/usr/share/man/man8/addgnupghome.8.xz
/usr/share/man/man8/applygnupgdefaults.8.xz
/usr/share/man/man8/dirmngr.8.xz

Changelog

2017-06-19 - ngompa <ngompa> 2.1.21-2.mga6
+ Revision: 1107904
- Add patch to fix tests requiring scdaemon
+ buchan <buchan>
- Dont run autogen.sh, so we dont get warning about development version
- Patch autogen.sh so even if we run it, we indicate its not
a development version but indicate the RPM release in the version
2017-05-16 - luigiwalser <luigiwalser> 2.1.21-1.mga6
+ Revision: 1101859
- 2.1.21
- remove upstreamed libdns patch
2017-05-02 - eatdirt <eatdirt> 2.1.20-2.mga6
+ Revision: 1098635
- Remove obsoleted option --use-standard-socket
2017-04-29 - luigiwalser <luigiwalser> 2.1.20-1.mga6
+ Revision: 1097989
- 2.1.20
- update build patch from fedora
- add patch from fedora to fix libdns aliasing issues
- 2.1.19
2017-01-24 - luigiwalser <luigiwalser> 2.1.18-1.mga6
+ Revision: 1083265
- 2.1.18
2016-12-22 - ngompa <ngompa> 2.1.17-2.mga6
+ Revision: 1076438
- Add patch from Fedora to fix builds on 32-bit arches
- Upgrade to 2.1.17
- Obsolete dirmngr, as it's now part of gnupg2
- Downgrade gnupg Requires to Recommends, as gnupg2 doesn't need it
2016-11-18 - eatdirt <eatdirt> 2.0.30-4.mga6
+ Revision: 1068183
- Disable --keep-display option (mga#19391)
2016-06-01 - eatdirt <eatdirt> 2.0.30-3.mga6
+ Revision: 1019722
- Migrate to systemd user service (mga#14627)
2016-04-18 - luigiwalser <luigiwalser> 2.0.30-1.mga6
+ Revision: 1003506
- 2.0.30
2016-02-11 - umeabot <umeabot> 2.0.29-3.mga6
+ Revision: 954135
- Mageia 6 Mass Rebuild

See Also

Package Description
gnuplot-5.0.6-2.mga6.x86_64.rpm A program for plotting mathematical expressions and data
gnuplot-mode-5.0.6-2.mga6.x86_64.rpm Yet another Gnuplot mode for Emacs
gnuplot-nox-5.0.6-2.mga6.x86_64.rpm A program for plotting mathematical expressions and data
gnuplot-qt-5.0.6-2.mga6.x86_64.rpm A program for plotting mathematical expressions and data
gnupod-0.99.8-11.mga6.noarch.rpm Command-line tools for the iPod
gnupylot-0.1.9-5.mga6.noarch.rpm GUI for gnuplot
gnuradio-3.7.10.1-3.mga6.x86_64.rpm Software defined radio framework
gnuradio-companion-3.7.10.1-3.mga6.x86_64.rpm The GNU Radio Companion
gnuradio-doc-3.7.10.1-3.mga6.noarch.rpm Software Defined Radio
gnuradio-examples-3.7.10.1-3.mga6.x86_64.rpm GNU Radio Example Programs
gnuradio-noaa-3.7.10.1-3.mga6.x86_64.rpm GNU Radio NOAA POES HRPT receiver
gnuradio-pager-3.7.10.1-3.mga6.x86_64.rpm GNU Radio FLEX Pager Decoder
gnuradio-utils-3.7.10.1-3.mga6.x86_64.rpm GNU Radio Utilities
gnustep-base-1.24.8-4.mga6.x86_64.rpm GNUstep Base library package
gnustep-base-devel-1.24.8-4.mga6.x86_64.rpm Header of the GNUstep Base library packes
Advertisement
Advertisement