lib64binutils-devel-2.25.1-7.mga6.x86_64.rpm


Advertisement

Description

lib64binutils-devel - Main library for binutils

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64binutils-devel-2.25.1-7.mga6.x86_64.rpm
Package name lib64binutils-devel
Package version 2.25.1
Package release 7.mga6
Package architecture x86_64
Package type rpm
Category Development/Other
Homepage http://sources.redhat.com/binutils/
License GPLv3+
Maintainer -
Download size 2.33 MB
Installed size 18.40 MB
This package contains BFD and opcodes static libraries and associated
header files.  Only *.a libraries are included, because BFD doesn't
have a stable ABI.  Developers starting new projects are strongly encouraged
to consider using libelf instead of BFD.

Alternatives

Package Version Architecture Repository
lib64binutils-devel-2.32-1.1.mga6.x86_64.rpm 2.32 x86_64 Mageia Core Updates
lib64binutils-devel - - -

Requires

Name Value
zlib-devel -

Provides

Name Value
binutils-devel == 1:2.25.1-7.mga6
lib64binutils-devel == 1:2.25.1-7.mga6
lib64binutils-devel(x86-64) == 1:2.25.1-7.mga6
lib64binutils2-devel == 1:2.25.1-7.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64binutils-devel-2.25.1-7.mga6.x86_64.rpm
Source Package binutils-2.25.1-7.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64binutils-devel rpm package:
    # urpmi lib64binutils-devel

Files

Path
/usr/include/ansidecl.h
/usr/include/bfd.h
/usr/include/bfdlink.h
/usr/include/demangle.h
/usr/include/dis-asm.h
/usr/include/libiberty.h
/usr/include/plugin-api.h
/usr/include/symcat.h
/usr/lib64/libbfd.a
/usr/lib64/libbfd.so
/usr/lib64/libiberty.a
/usr/lib64/libopcodes.a
/usr/lib64/libopcodes.so

Changelog

2017-07-01 - akien <akien> 1:2.25.1-7.mga6
+ Revision: 1108880
- Add FSF binutils patch to fix running readelf on debug info binaries (rhbz#1434050)
2017-07-01 - tmb <tmb> 1:2.25.1-6.mga6
+ Revision: 1108788
- fix CVE-2016-4487/4488/4489/4490/4492/4493/6131 and CVE-2017-6969/7210
+ neoclust <neoclust>
- Add P1000 - Fixes CVE-2016-2226 (mga#18987)
2016-02-10 - umeabot <umeabot> 1:2.25.1-5.mga6
+ Revision: 953250
- Mageia 6 Mass Rebuild
2015-08-20 - tmb <tmb> 1:2.25.1-4.mga6
+ Revision: 866990
- rebuild with new gcc
2015-08-20 - tmb <tmb> 1:2.25.1-3.mga6
+ Revision: 866658
- rebuild with gcc 5.2.1
2015-08-18 - tmb <tmb> 1:2.25.1-2.mga6
+ Revision: 865415
- rebuild with new glibc
2015-08-02 - tmb <tmb> 1:2.25.1-1.mga6
+ Revision: 860852
- push to /release
2015-07-31 - tmb <tmb> 1:2.25.1-0.1.mga6
+ Revision: 859934
- rebase linux32 patch
- drop merged / obsolete patches
- resync current fedora patches
- update to 2.25.1
2015-01-14 - cjw <cjw> 1:2.24-12.mga5
+ Revision: 810639
- patch105: fix for CVE-2014-8738 (mga #15022)
2014-12-04 - cjw <cjw> 1:2.24-11.mga5
+ Revision: 801533
- add more patches from fedora:
+ patch20: Fix decoding of abbrevs using a DW_FORM_ref_addr attribute.
+ patch21: Fix detection of uncompressed .debug_str sections.
+ patch22: Default to -ffat-lto-objects for some ld tests, which was the default in gcc 4.8, but changed in 4.9, and resulted in some failures.
+ patch23: Scan all input files for symbol reference warning.
+ patch26: Backport of fix from HEAD that fixes LTO + ifunc when using ld.bfd instead of gold.
+ patch27: Fix reading of corrupt ELF binaries.
+ patch28: Default strings command to using -a.
+ patch29: Fix problems with the ar program reported in FSF PR 17533.
- patch53: fix ar segfaulting on --plugin, caused by patch16
- patch104: fix compilation with gcc 4.9 and -Werror
- fix patch51 for -Werror
- don't disable -Werror

See Also

Package Description
lib64bison-static-devel-3.0.4-3.mga6.x86_64.rpm Static development library for using Bison-generated parsers
lib64bitcoinconsensus-devel-0.12.0-3.mga6.x86_64.rpm Development files for bitcoinconsensus
lib64bitcoinconsensus0-0.12.0-3.mga6.x86_64.rpm Shared libs for bitcoinconsensus
lib64black-hole-solver-devel-0.14.0-2.mga6.x86_64.rpm The Black Hole Solitaire development tools
lib64black-hole-solver-static-devel-0.14.0-2.mga6.x86_64.rpm The Freecell Solver static libraries
lib64black-hole-solver0-0.14.0-2.mga6.x86_64.rpm The Black Hole Solver dynamic libraries
lib64bladerf-devel-2016.06-1.mga6.x86_64.rpm Development files for bladeRF
lib64bladerf1-2016.06-1.mga6.x86_64.rpm Library files for bladeRF
lib64blas-devel-3.6.1-1.mga6.x86_64.rpm BLAS development libraries
lib64blas3-3.6.1-1.mga6.x86_64.rpm The BLAS (Basic Linear Algebra Subprograms) library
lib64blkid-devel-2.28.2-2.mga6.x86_64.rpm Block device ID library
lib64blkid1-2.28.2-2.mga6.x86_64.rpm Block device ID library
lib64bluez-devel-5.45-2.mga6.x86_64.rpm Headers for developing programs that will use bluez
lib64bluez3-5.45-2.mga6.x86_64.rpm Official Linux Bluetooth protocol stack
lib64bluray-devel-1.0.0-1.mga6.x86_64.rpm libbluray development files
Advertisement
Advertisement