lib64cups2-2.2.3-2.mga6.x86_64.rpm


Advertisement

Description

lib64cups2 - CUPS printing system - CUPS library

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64cups2-2.2.3-2.mga6.x86_64.rpm
Package name lib64cups2
Package version 2.2.3
Package release 2.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.cups.org
License LGPLv2
Maintainer -
Download size 299.71 KB
Installed size 850.57 KB
The CUPS printing system provides a portable printing layer for
UNIX(TM) operating systems. This package contains the CUPS API library
which contains common functions used by both the CUPS daemon and all
CUPS frontends (lpr-cups, xpp, qtcups, kups, ...).
This package you need for both CUPS clients and servers. It is also
needed by Samba.

Alternatives

Package Version Architecture Repository
lib64cups2-2.2.6-1.mga6.x86_64.rpm 2.2.6 x86_64 Mageia Core Updates
lib64cups2-2.2.4-1.mga6.x86_64.rpm 2.2.4 x86_64 Mageia Core Updates
lib64cups2 - - -

Requires

Name Value
hostname -
libavahi-client.so.3()(64bit) -
libavahi-common.so.3()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.16)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcups.so.2()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgnutls.so.30()(64bit) -
libgnutls.so.30(GNUTLS_3_4)(64bit) -
libgssapi_krb5.so.2()(64bit) -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.0)(64bit) -

Provides

Name Value
lib64cups2 == 2.2.3-2.mga6
lib64cups2(x86-64) == 2.2.3-2.mga6
libcups.so.2()(64bit) -
libcups1 == 2.2.3
libcupscgi.so.1()(64bit) -
libcupsimage.so.2()(64bit) -
libcupsmime.so.1()(64bit) -
libcupsppdc.so.1()(64bit) -

Obsoletes

Name Value
libcups1 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64cups2-2.2.3-2.mga6.x86_64.rpm
Source Package cups-2.2.3-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64cups2 rpm package:
    # urpmi lib64cups2

Files

Path
/usr/lib64/libcups.so.2
/usr/lib64/libcupscgi.so.1
/usr/lib64/libcupsimage.so.2
/usr/lib64/libcupsmime.so.1
/usr/lib64/libcupsppdc.so.1

Changelog

2017-05-26 - neoclust <neoclust> 2.2.3-2.mga6
+ Revision: 1104819
- Rebuild to see if it help to fix a crash
2017-03-29 - luigiwalser <luigiwalser> 2.2.3-1.mga6
+ Revision: 1095169
- 2.2.3
2017-03-27 - luigiwalser <luigiwalser> 2.2.2-1.mga6
+ Revision: 1094913
- 2.2.2
- sync patch changes with fedora
2016-12-01 - tv <tv> 2.2.1-1.mga6
+ Revision: 1071394
- new release
- Unable to print from Windows (7) on a Cups-Server with german umlauts in the filename (rhbz#1386751)
- (cups-usb-quirks) usb printer doesn't print (usblp0: USB Bidirectional printer dev) (#873123)
2016-09-30 - tv <tv> 2.2.0-3.mga6
+ Revision: 1057856
- fixing looping in partial failing service (bug #1366775)
2016-09-21 - pterjan <pterjan> 2.2.0-2.mga6
+ Revision: 1054997
- Fix manpage extension in alternatives, this should be made more robust
2016-09-15 - tv <tv> 2.2.0-1.mga6
+ Revision: 1053128
- new version
2016-06-17 - tv <tv> 2.1.4-1.mga6
+ Revision: 1021975
- new release
2016-06-07 - tv <tv> 2.1.3-3.mga6
+ Revision: 1020634
- adjust BRs for latest systemd
2016-04-10 - blino <blino> 2.1.3-2.mga6
+ Revision: 1000167
- drop poppler requires, pdftops was required by filters which have been split out in 1.6

See Also

Package Description
lib64cups2-devel-2.2.3-2.mga6.x86_64.rpm CUPS printing system - Development environment "libcups"
lib64curl-devel-7.54.1-2.mga6.x86_64.rpm Header files and static libraries for libcurl
lib64curl4-7.54.1-2.mga6.x86_64.rpm A library of functions for file transfer
lib64cw-devel-3.3.1-4.mga6.x86_64.rpm Development files for unixcw
lib64cw6-3.3.1-4.mga6.x86_64.rpm Development files for unixcw
lib64cwiid-devel-0.6.01-13.mga6.x86_64.rpm Development headers and libraries for CWiid
lib64cwiid1-0.6.01-13.mga6.x86_64.rpm CWiid Wiimote library
lib64cxsparse3-4.4.4-3.mga6.x86_64.rpm Direct methods for sparse linear systems
lib64cxx-gtk-utils2.2-devel-2.2.13-3.mga6.x86_64.rpm Development files for c++-gtk-utils
lib64cxx-gtk-utils2.2_0-2.2.13-3.mga6.x86_64.rpm A library containing a number of classes and functions for programming GTK+ programs using C++
lib64cxxtools-devel-2.2.1-6.mga6.x86_64.rpm Headers and static library for cxxtools development
lib64cxxtools9-2.2.1-6.mga6.x86_64.rpm Shared library of cxxtools
lib64cyrus-imapd-devel-2.5.11-1.mga6.x86_64.rpm Cyrus IMAP server development files
lib64cyrus-imapd0-2.5.11-1.mga6.x86_64.rpm Cyrus IMAP server library files
lib64d3d1-17.1.4-1.mga6.x86_64.rpm Mesa Direct3D9 state tracker
Advertisement
Advertisement