lib64newt0.52-devel-0.52.20-4.mga6.x86_64.rpm


Advertisement

Description

lib64newt0.52-devel - Newt windowing toolkit development files

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64newt0.52-devel-0.52.20-4.mga6.x86_64.rpm
Package name lib64newt0.52-devel
Package version 0.52.20
Package release 4.mga6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage https://pagure.io/newt
License LGPLv2+
Maintainer -
Download size 138.83 KB
Installed size 587.28 KB
Newt is a programming library for color text mode, widget based user
interfaces. Newt can be used to add stacked windows, entry widgets, checkboxes,
radio buttons, labels, plain text fields, scrollbars, etc., to text mode user
interfaces.  This package contains a /usr/bin/dialog replacement called
whiptail. Newt is based on the slang library.
Install newt-devel if you want to develop applications which will use newt.

Alternatives

Package Version Architecture Repository
lib64newt0.52-devel - - -

Requires

Name Value
devel(libslang(64bit)) -
lib64newt0.52 == 0.52.20-4.mga6
pkgconfig -
slang-devel -

Provides

Name Value
devel(libnewt(64bit)) -
lib64newt0.52-devel == 0.52.20-4.mga6
lib64newt0.52-devel(x86-64) == 0.52.20-4.mga6
libnewt-devel == 0.52.20-4.mga6
newt-devel == 0.52.20-4.mga6
pkgconfig(libnewt) == 0.52.20

Conflicts

Name Value
libnewt0.51-devel -

Obsoletes

Name Value
newt-devel -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64newt0.52-devel-0.52.20-4.mga6.x86_64.rpm
Source Package newt-0.52.20-4.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64newt0.52-devel rpm package:
    # urpmi lib64newt0.52-devel

Files

Path
/usr/include/newt.h
/usr/lib64/libnewt.a
/usr/lib64/libnewt.so
/usr/lib64/pkgconfig/libnewt.pc
/usr/share/doc/lib64newt0.52-devel/tutorial.sgml

Changelog

2017-06-05 - ngompa <ngompa> 0.52.20-4.mga6
+ Revision: 1106761
- Get rid of unnecessary Obsoletes + Conflicts, per luigiwalser
2017-06-04 - ngompa <ngompa> 0.52.20-3.mga6
+ Revision: 1106674
- Ensure packages are upgraded together properly
2017-06-04 - ngompa <ngompa> 0.52.20-2.mga6
+ Revision: 1106670
- Split Python bindings to their own subpackages
- Enable Python 3 bindings
- Slightly modernize package build instructions
2017-04-05 - luigiwalser <luigiwalser> 0.52.20-1.mga6
+ Revision: 1095935
- 0.52.20
- update URLs
2016-05-10 - luigiwalser <luigiwalser> 0.52.19-1.mga6
+ Revision: 1011905
- use correct macros for building
- add patch to use correct include dir for slang.h
- 0.52.19
2016-02-08 - umeabot <umeabot> 0.52.18-2.mga6
+ Revision: 950471
- Mageia 6 Mass Rebuild
2014-11-03 - luigiwalser <luigiwalser> 0.52.18-1.mga5
+ Revision: 795361
- 0.52.18
2014-10-15 - umeabot <umeabot> 0.52.17-5.mga5
+ Revision: 738893
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.52.17-4.mga5
+ Revision: 682875
- Mageia 5 Mass Rebuild
2014-06-18 - tv <tv> 0.52.17-3.mga5
+ Revision: 638036
- remove dietlibc & uclibc builds (no more uneeded by stage1)
+ pterjan <pterjan>
- Rebuild for new Python

See Also

Package Description
lib64nextcloud-client-devel-2.2.4-6.mga6.x86_64.rpm Development files for nextcloud-client
lib64nextcloudsync0-2.2.4-6.mga6.x86_64.rpm The Nextcloud Client Libraries
lib64nfnetlink-devel-1.0.1-7.mga6.x86_64.rpm Development files for libnfnetlink
lib64nfnetlink0-1.0.1-7.mga6.x86_64.rpm Main library for libnfnetlink
lib64nfs-devel-1.11.0-1.mga6.x86_64.rpm Development files for libnfs
lib64nfs8-1.11.0-1.mga6.x86_64.rpm Shared library of libnfs
lib64nfsidmap-devel-0.27-3.mga6.x86_64.rpm Static library and header files for the nfsidmap library
lib64nfsidmap0-0.27-3.mga6.x86_64.rpm Library to help mapping id's, mainly for NFSv4
lib64nftnl-devel-1.0.7-1.mga6.x86_64.rpm Development files for libnftnl
lib64nftnl4-1.0.7-1.mga6.x86_64.rpm Main library for libnftnl
lib64nghttp2-devel-1.9.2-1.mga6.x86_64.rpm Files needed for building applications with libnghttp2
lib64nghttp2_14-1.9.2-1.mga6.x86_64.rpm A library implementing the HTTP/2 protocol
lib64nice-devel-0.1.13-3.mga6.x86_64.rpm Header files, libraries and development documentation for nice
lib64nice-gir0.1-0.1.13-3.mga6.x86_64.rpm GObject Introspection interface description for libnice
lib64nice10-0.1.13-3.mga6.x86_64.rpm Dynamic libraries from nice
Advertisement
Advertisement