lib64nmclient-gir1.0-1.8.0-1.mga6.x86_64.rpm


Advertisement

Description

lib64nmclient-gir1.0 - GObject Introspection interface library for NMClient

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64nmclient-gir1.0-1.8.0-1.mga6.x86_64.rpm
Package name lib64nmclient-gir1.0
Package version 1.8.0
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://wiki.gnome.org/Projects/NetworkManager
License GPLv2+
Maintainer -
Download size 26.64 KB
Installed size 62.54 KB
GObject Introspection interface library for NMClient.

Alternatives

Package Version Architecture Repository
lib64nmclient-gir1.0-1.8.6-1.mga6.x86_64.rpm 1.8.6 x86_64 Mageia Core Updates
lib64nmclient-gir1.0 - - -

Requires

Name Value
lib64nm-glib4 == 1.8.0-1.mga6
libnm-glib.so.4()(64bit) -
libnm-util.so.2()(64bit) -
typelib(DBusGLib) == 1.0
typelib(GLib) == 2.0
typelib(GObject) == 2.0
typelib(Gio) == 2.0
typelib(NetworkManager) == 1.0

Provides

Name Value
lib64nmclient-gir1.0 == 1.8.0-1.mga6
lib64nmclient-gir1.0(x86-64) == 1.8.0-1.mga6
typelib(NMClient) == 1.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64nmclient-gir1.0-1.8.0-1.mga6.x86_64.rpm
Source Package networkmanager-1.8.0-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64nmclient-gir1.0 rpm package:
    # urpmi lib64nmclient-gir1.0

Files

Path
/usr/lib64/girepository-1.0/NMClient-1.0.typelib

Changelog

2017-05-26 - ovitters <ovitters> 1.8.0-1.mga6
+ Revision: 1104726
- new version 1.8.0
- rediff patches
2017-05-06 - luigiwalser <luigiwalser> 1.6.2-5.mga6
+ Revision: 1099316
- fix format security errors
2017-02-23 - wally <wally> 1.6.2-4.mga6
+ Revision: 1087510
- drop conflicts for connman (connman isn't enabled by default anymore and README.urpmi was added to connman to explain to not enable connman and networkmanager at the same time)
2017-02-19 - ovitters <ovitters> 1.6.2-3.mga6
+ Revision: 1086971
- add conflict on connman as it pretends to be NM (mga#20286)
2017-02-19 - wally <wally> 1.6.2-2.mga6
+ Revision: 1086899
- move nmtui man pages to correct pkg
- split out device plugins
- require wifi device plugin by default and recommend others
- drop unneeded requires for mobile-broadband-provider-info
- create /etc/NetworkManager/dnsmasq-shared.d/
2017-02-15 - ovitters <ovitters> 1.6.2-1.mga6
+ Revision: 1086303
- new version 1.6.2
- dropped merged patch 3
2017-02-10 - wally <wally> 1.6.0-11.mga6
+ Revision: 1085508
- fix pppd plugin dir
- no need to require optional dnsmasq-base
- add some missing dirs/files
2017-02-08 - wally <wally> 1.6.0-10.mga6
+ Revision: 1085153
- split out NetworkManager typelib
- move gir files to correct devel pkgs
- don't pkg libnm devel files twice
- tag gtk-docs as docs
- move docs under %_docdir
- create /etc/NetworkManager/conf.d/
2017-02-06 - wally <wally> 1.6.0-9.mga6
+ Revision: 1085040
- add patch from upstream to fix interpreting missing MAC_ADDRESS_RANDOMIZATION as permanent address with ifcfg-rh plugin
- rediff P11 (mga-wireless_essid.patch) to apply with upstream patch added
2017-02-06 - wally <wally> 1.6.0-8.mga6
+ Revision: 1085008
- update P10 (discover-mac-address.patch) one more time

See Also

Package Description
lib64nmgtk-gir1.0-1.8.2-1.mga6.x86_64.rpm GObject Introspection interface description for NMGtk
lib64notesharedprivate5-16.12.3-1.mga6.x86_64.rpm KDEPIM library
lib64notify-devel-0.7.7-1.mga6.x86_64.rpm Desktop notifications library - headers
lib64notify-gir0.7-0.7.7-1.mga6.x86_64.rpm GObject Introspection interface library for libnotify
lib64notify4-0.7.7-1.mga6.x86_64.rpm Desktop notifications library - shared library
lib64nova-devel-0.15.0-4.mga6.x86_64.rpm Development files for libnova
lib64nova0.15_0-0.15.0-4.mga6.x86_64.rpm Library files for libnova
lib64npth-devel-1.5-1.mga6.x86_64.rpm Development files for npth
lib64npth0-1.5-1.mga6.x86_64.rpm The New GNU Portable Threads library
lib64nspr-devel-4.15-2.mga6.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr4-4.15-2.mga6.x86_64.rpm Netscape Portable Runtime
lib64nss-devel-3.28.5-1.mga6.x86_64.rpm Network Security Services (NSS) - development files
lib64nss-mdns2-0.10-16.mga6.x86_64.rpm Multicast dns support for glibc domain resolver
lib64nss-pgsql-1.4.0-12.mga6.x86_64.rpm NSS library for postgresql
lib64nss-static-devel-3.28.5-1.mga6.x86_64.rpm Network Security Services (NSS) - static libraries
Advertisement
Advertisement