lib64openthreads20-3.4.0-8.mga6.x86_64.rpm


Advertisement

Description

lib64openthreads20 - A lightweight C++ thread API

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64openthreads20-3.4.0-8.mga6.x86_64.rpm
Package name lib64openthreads20
Package version 3.4.0
Package release 8.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.openscenegraph.org/
License LGPLv2+ with exceptions
Maintainer -
Download size 18.40 KB
Installed size 31.55 KB
This library is intended to provide a minimal & complete Object-Oriented
thread interface for C++ programmers.  It is loosely modeled on the Java
thread API, and the POSIX Threads standards.
OpenThreads is part of the OpenSceneGraph project.

Alternatives

Package Version Architecture Repository
lib64openthreads20 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
lib64openthreads20 == 3.4.0-8.mga6
lib64openthreads20(x86-64) == 3.4.0-8.mga6
libOpenThreads.so.20()(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64openthreads20-3.4.0-8.mga6.x86_64.rpm
Source Package openscenegraph-3.4.0-8.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64openthreads20 rpm package:
    # urpmi lib64openthreads20

Files

Path
/usr/lib64/libOpenThreads.so.20
/usr/lib64/libOpenThreads.so.3.3.0

Changelog

2017-03-08 - akien <akien> 3.4.0-8.mga6
+ Revision: 1090231
- Rebuild for ffmpeg 3.2.4
2016-11-28 - luigiwalser <luigiwalser> 3.4.0-7.mga6
+ Revision: 1070631
- rebuild for poppler
2016-08-13 - luigiwalser <luigiwalser> 3.4.0-6.mga6
+ Revision: 1046190
- test rebuild for poppler
2016-01-11 - wally <wally> 3.4.0-5.mga6
+ Revision: 921705
- build against gdal also on arm
2016-01-09 - wally <wally> 3.4.0-4.mga6
+ Revision: 920886
- build with gdal again
2016-01-09 - wally <wally> 3.4.0-3.mga6
+ Revision: 920825
- build without gdal for now
2016-01-07 - luigiwalser <luigiwalser> 3.4.0-2.mga6
+ Revision: 920406
- rebuild for giflib
2016-01-06 - wally <wally> 3.4.0-1.mga6
+ Revision: 920107
- new version 3.4.0
- new osg libmajor 130
- drop unneeded patches
- drop unneeded requires
- update BRs and don't BR gdal-devel on arm
2016-01-06 - wally <wally> 3.2.3-1.mga6
+ Revision: 920100
- new version 3.2.3
- drop unneeded patches from upstream
- build with Qt5
2015-08-26 - cjw <cjw> 3.2.1-4.mga6
+ Revision: 869729
- rebuild with gcc 5

See Also

Package Description
lib64openvas-devel-8.0.8-1.mga6.x86_64.rpm Development files for openvas-libraries
lib64openvas8-8.0.8-1.mga6.x86_64.rpm Support libraries for Open Vulnerability Assessment (OpenVAS) Server
lib64openvpn-devel-2.4.3-1.mga6.x86_64.rpm Development package for OpenVPN plugins
lib64openzwave-devel-1.2.919-1.mga6.x86_64.rpm Open-ZWave header files
lib64openzwave1-1.2.919-1.mga6.x86_64.rpm Shared Open-ZWave library
lib64opts25-5.18.6-2.mga6.x86_64.rpm Main library for autogen
lib64opus-devel-1.1.5-1.mga6.x86_64.rpm Files needed to compile a program with Opus support
lib64opus0-1.1.5-1.mga6.x86_64.rpm Opus library
lib64opusfile-devel-0.7-2.mga6.x86_64.rpm Development package for opusfile
lib64opusfile0-0.7-2.mga6.x86_64.rpm A high-level API for decoding and seeking within .opus files
lib64orc-devel-0.4.26-1.mga6.x86_64.rpm The Oil Runtime Compiler
lib64orc0.4_0-0.4.26-1.mga6.x86_64.rpm The Oil Runtime Compiler
lib64orcus-devel-0.12.1-2.mga6.x86_64.rpm Development files for liborcus
lib64orcus0.12_0-0.12.1-2.mga6.x86_64.rpm Standalone file import filter library for spreadsheet documents
lib64ortp-devel-0.27.0-2.mga6.x86_64.rpm Headers, libraries and docs for the oRTP library
Advertisement
Advertisement