lib64puma-devel-2.2-1.mga6.x86_64.rpm


Advertisement

Description

lib64puma-devel - Libraries and header files for aspectc++

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64puma-devel-2.2-1.mga6.x86_64.rpm
Package name lib64puma-devel
Package version 2.2
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage http://www.aspectc.org
License GPLv2+
Maintainer -
Download size 1.67 MB
Installed size 12.27 MB
This package contains the static development libraries and headers needed
to compile applications linked with aspectc++ libraries. This package contains
only the stripped-down MiniPuma version of the library.

Alternatives

Package Version Architecture Repository
lib64puma-devel - - -

Requires

Name Value
aspectc++ == 2.2-1.mga6

Provides

Name Value
aspectc++-devel == 2.2-1.mga6
lib64puma-devel == 2.2-1.mga6
lib64puma-devel(x86-64) == 2.2-1.mga6
puma-devel == 2.2-1.mga6

Obsoletes

Name Value
lib64puma-static -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64puma-devel-2.2-1.mga6.x86_64.rpm
Source Package aspectc++-2.2-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64puma-devel rpm package:
    # urpmi lib64puma-devel

Files

Path
/usr/include/Puma/Array.h
/usr/include/Puma/BCList.h
/usr/include/Puma/BCStack.h
/usr/include/Puma/Chain.h
/usr/include/Puma/ConfOption.h
/usr/include/Puma/Config.h
/usr/include/Puma/ConstSizeMemPool.h
/usr/include/Puma/DString.h
/usr/include/Puma/ErrorCollector.h
/usr/include/Puma/ErrorSeverity.h
/usr/include/Puma/ErrorSink.h
/usr/include/Puma/ErrorStream.h
/usr/include/Puma/FdSource.h
/usr/include/Puma/FileSource.h
/usr/include/Puma/FileUnit.h
/usr/include/Puma/Filename.h
/usr/include/Puma/FilenameInfo.h
/usr/include/Puma/Heap.h
/usr/include/Puma/KeyboardSource.h
/usr/include/Puma/LanguageID.h
/usr/include/Puma/Limits.h
/usr/include/Puma/List.h
/usr/include/Puma/ListElement.h
/usr/include/Puma/Location.h
/usr/include/Puma/MacroUnit.h
/usr/include/Puma/MemPool.h
/usr/include/Puma/OptsParser.h
/usr/include/Puma/ParserKey.h
/usr/include/Puma/PathInfo.h
/usr/include/Puma/PathIterator.h
/usr/include/Puma/PathManager.h
/usr/include/Puma/Pipe.h
/usr/include/Puma/PipedCmd.h
/usr/include/Puma/Printable.h
/usr/include/Puma/Project.h
/usr/include/Puma/ProjectFile.h
/usr/include/Puma/PtrStack.h
/usr/include/Puma/RegComp.h
/usr/include/Puma/SaveMode.h
/usr/include/Puma/SimpleParser.h
/usr/include/Puma/Sink.h
/usr/include/Puma/SmartPtr.h
/usr/include/Puma/Source.h
/usr/include/Puma/Stack.h
/usr/include/Puma/StrCol.h
/usr/include/Puma/StrHashKey.h
/usr/include/Puma/StrHashTable.h
/usr/include/Puma/StringSource.h
/usr/include/Puma/SysCall.h
/usr/include/Puma/TerminalSink.h
/usr/include/Puma/Token.h
/usr/include/Puma/TokenSource.h
/usr/include/Puma/TokenStream.h
/usr/include/Puma/Tokenizer.h
/usr/include/Puma/Unit.h
/usr/include/Puma/UnitIterator.h
/usr/include/Puma/UnitManager.h
/usr/include/Puma/UnitState.h
/usr/include/Puma/UnitTokenSrc.h
/usr/include/Puma/VerboseMgr.h
/usr/include/Puma/VoidPtrArray.h
/usr/include/Puma/WChar.h
/usr/include/Puma/version.h
/usr/lib64/libMiniPuma.a
/usr/share/doc/lib64puma-devel/UsersManual.pdf

Changelog

2017-06-05 - daviddavid <daviddavid> 2.2-1.mga6
+ Revision: 1106881
- new version: 2.2
- add upstream patch to fix build with our clang 3.9.1
+ tmb <tmb>
- rebuild with new llvm
2016-07-13 - daviddavid <daviddavid> 2.1-2.mga6
+ Revision: 1041867
- add patch to support also latest llvm/clang 3.8.1
2016-07-11 - daviddavid <daviddavid> 2.1-1.mga6
+ Revision: 1041070
- new version: 2.1 (fixes build against llvm/clang 3.8.0)
* http://www.aspectc.org/bugzilla/show_bug.cgi?id=600
- add provides on puma-devel and aspectc++-devel
- add BR llvm-static
+ tmb <tmb>
- rebuild for new llvm
+ wally <wally>
- try to fool build process to support clang 3.8.0
+ tv <tv>
- rebuild for new llvm
2016-02-22 - danf <danf> 2.0-1.mga6
+ Revision: 976187
- Upgraded to ver. 2.0
- Use & package libMiniPuma instead of libPuma
- Using libMiniPuma allows removing the binary bootstrap requirement
- Moved the static library into the -devel package
+ umeabot <umeabot>
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 1.2-4.mga5
+ Revision: 739583
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.2-3.mga5
+ Revision: 677918
- Mageia 5 Mass Rebuild

See Also

Package Description
lib64purple-devel-2.12.0-1.mga6.x86_64.rpm Development files for pidgin
lib64purple-events-devel-0.99.1-2.mga6.x86_64.rpm Development package for purple-events
lib64purple-events1-0.99.1-2.mga6.x86_64.rpm libpurple events handling plugin and library
lib64purple0-2.12.0-1.mga6.x86_64.rpm The libpurple library for IM clients like Pidgin and Finch
lib64pwdb-devel-0.62-16.mga6.x86_64.rpm The pwdb include files and link library
lib64pwdb0-0.62-16.mga6.x86_64.rpm The password database library
lib64pwquality-devel-1.3.0-4.mga6.x86_64.rpm Files needed for developing PAM-aware applications and modules for PAM
lib64pwquality1-1.3.0-4.mga6.x86_64.rpm Shared libraries for pwquality
lib64px-devel-0.6.4-9.mga6.x86_64.rpm A library to read Paradox DB files (Development)
lib64px0-0.6.4-9.mga6.x86_64.rpm A library to read Paradox DB files
lib64pyglib2.0_0-2.28.6-18.mga6.x86_64.rpm Python Glib bindings shared library
lib64pyldb-util-devel-1.1.29-1.mga6.x86_64.rpm Development files for utility library for using tdb functions in python
lib64pyldb-util1-1.1.29-1.mga6.x86_64.rpm Utility library for using tdb functions in python
lib64pyside1-1.2.2-12.mga6.x86_64.rpm PySide core library
lib64pytalloc-util-devel-2.1.9-1.mga6.x86_64.rpm Utility functions for using talloc objects with Python
Advertisement
Advertisement