lib64qtshadowsocks-devel-1.8.2-2.mga6.x86_64.rpm


Advertisement

Description

lib64qtshadowsocks-devel - Development headers for libQtShadowsocks

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package name lib64qtshadowsocks-devel
Package version 1.8.2
Package release 2.mga6
Package architecture x86_64
Package type rpm
Installed size 33.37 KB
Download size 16.71 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package provides development headers for libQtShadowsocks.

Alternatives

Package Version Architecture Repository
lib64qtshadowsocks-devel - - -

Requires

Name Value
devel(libQt5Core(64bit)) -
devel(libQt5Network(64bit)) -
devel(libbotan-1.10(64bit)) -
devel(libgcc_s(64bit)) -
devel(libstdc++(64bit)) -
lib64qtshadowsocks1 == 1.8.2
pkgconfig -

Provides

Name Value
devel(libQtShadowsocks(64bit)) -
lib64QtShadowsocks-devel == 1.8.2
lib64qtshadowsocks-devel == 1.8.2-2.mga6
lib64qtshadowsocks-devel(x86-64) == 1.8.2-2.mga6
pkgconfig(QtShadowsocks) == 1.8.2

Obsoletes

Name Value
lib64QtShadowsocks-devel < 1.6.1-3

Download

Type URL
Binary Package lib64qtshadowsocks-devel-1.8.2-2.mga6.x86_64.rpm
Source Package libqtshadowsocks-1.8.2-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64qtshadowsocks-devel rpm package:
    # urpmi lib64qtshadowsocks-devel

Files

Path
/usr/include/qtshadowsocks/QtShadowsocks
/usr/include/qtshadowsocks/address.h
/usr/include/qtshadowsocks/addresstester.h
/usr/include/qtshadowsocks/chacha.h
/usr/include/qtshadowsocks/cipher.h
/usr/include/qtshadowsocks/common.h
/usr/include/qtshadowsocks/controller.h
/usr/include/qtshadowsocks/encryptor.h
/usr/include/qtshadowsocks/encryptorprivate.h
/usr/include/qtshadowsocks/export.h
/usr/include/qtshadowsocks/httpproxy.h
/usr/include/qtshadowsocks/profile.h
/usr/include/qtshadowsocks/rc4.h
/usr/include/qtshadowsocks/socketstream.h
/usr/include/qtshadowsocks/tcprelay.h
/usr/include/qtshadowsocks/tcpserver.h
/usr/include/qtshadowsocks/udprelay.h
/usr/lib64/libQtShadowsocks.so
/usr/lib64/pkgconfig/QtShadowsocks.pc

Changelog

2016-02-12 - luigiwalser <luigiwalser> 1.8.2-2.mga6
+ Revision: 956064
- rebuild for botan
2015-12-26 - ovitters <ovitters> 1.8.2-1.mga6
+ Revision: 914894
- new version 1.8.2
2015-11-04 - ovitters <ovitters> 1.7.0-1.mga6
+ Revision: 897874
- new version 1.7.0
2015-09-01 - ovitters <ovitters> 1.6.1-4.mga6
+ Revision: 872077
- client/server should be in its own package
2015-09-01 - ovitters <ovitters> 1.6.1-3.mga6
+ Revision: 871702
- follow package naming guidelines
- follow packaging guidelines
2015-08-26 - ovitters <ovitters> 1.6.1-2.mga6
+ Revision: 870051
- fix requires
2015-08-26 - ovitters <ovitters> 1.6.1-1.mga6
+ Revision: 870040
- fix group
- cleanup spec
- imported package libQtShadowsocks

See Also

Package Description
lib64qtshadowsocks1-1.8.2-2.mga6.x86_64.rpm A Shadowsocks library written in C++/Qt5
lib64qtsingleapplication-devel-2.6.1-16.mga6.x86_64.rpm Development files for qtsingleapplication
lib64qtsingleapplication-qt5-devel-2.6.1-16.mga6.x86_64.rpm Development files for qtsingleapplication-qt5
lib64qtsingleapplication-qt5_1-2.6.1-16.mga6.x86_64.rpm Qt5 library to start applications only once per user
lib64qtsingleapplication1-2.6.1-16.mga6.x86_64.rpm Qt library to start applications only once per user
lib64qtsinglecoreapplication-devel-2.6.1-16.mga6.x86_64.rpm Development files for qtsinglecoreapplication
lib64qtsinglecoreapplication-qt5-devel-2.6.1-16.mga6.x86_64.rpm Development files for qtsinglecoreapplication-qt5
lib64qtsinglecoreapplication-qt5_1-2.6.1-16.mga6.x86_64.rpm Qt5 library to start applications only once per user
lib64qtsinglecoreapplication1-2.6.1-16.mga6.x86_64.rpm Qt library to start applications only once per user
lib64qtsolutions_soap2.7_1-1.0.0-8.mga6.x86_64.rpm Library for hupnp
lib64qtsql4-4.8.7-15.mga6.x86_64.rpm Qt4 Component Library
lib64qtsvg4-4.8.7-15.mga6.x86_64.rpm Qt4 Component Library
lib64qtsysteminfo1-1.2.2-4.mga6.x86_64.rpm QtSystemInfo runtime library
lib64qttest4-4.8.7-15.mga6.x86_64.rpm Qt4 Component Library
lib64qtversit1-1.2.2-4.mga6.x86_64.rpm QtVersit runtime library
Advertisement
Advertisement