lib64udev-devel-230-12.mga6.x86_64.rpm


Advertisement

Description

lib64udev-devel - udev library development files

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64udev-devel-230-12.mga6.x86_64.rpm
Package name lib64udev-devel
Package version 230
Package release 12.mga6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage http://www.freedesktop.org/wiki/Software/systemd
License GPLv2+
Maintainer -
Download size 15.86 KB
Installed size 10.59 KB
This package provides the development files for the udev shared library.

Alternatives

Package Version Architecture Repository
lib64udev-devel-230-12.3.mga6.x86_64.rpm 230 x86_64 Mageia Core Updates
lib64udev-devel-230-12.2.mga6.x86_64.rpm 230 x86_64 Mageia Core Updates
lib64udev-devel-230-12.1.mga6.x86_64.rpm 230 x86_64 Mageia Core Updates
lib64udev-devel - - -

Requires

Name Value
lib64udev1 == 230-12.mga6
pkgconfig -

Provides

Name Value
devel(libudev(64bit)) -
lib64udev-devel == 230-12.mga6
lib64udev-devel(x86-64) == 230-12.mga6
lib64udev0-devel == 230-12.mga6
libudev-devel == 230-12.mga6
pkgconfig(libudev) == 230
pkgconfig(udev) == 230
udev-devel == 230-12.mga6

Obsoletes

Name Value
lib64udev0-devel < 185

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64udev-devel-230-12.mga6.x86_64.rpm
Source Package systemd-230-12.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64udev-devel rpm package:
    # urpmi lib64udev-devel

Files

Path
/usr/include/libudev.h
/usr/lib64/libudev.so
/usr/lib64/pkgconfig/libudev.pc
/usr/share/pkgconfig/udev.pc

Changelog

2017-06-29 - tmb <tmb> 230-12.mga6
+ Revision: 1108690
- resolved: simplify alloc size calculation (CVE-2017-9445, mga#21159)
2017-06-02 - neoclust <neoclust> 230-11.mga6
+ Revision: 1105817
- Add P1000 - Fixes  CVE-2017-9217 (mga#20968)
2017-05-07 - tmb <tmb> 230-10.mga6
+ Revision: 1099541
- tmpfiles: downgrade error message when operation is not supported (mga#20753)
2017-02-09 - daviddavid <daviddavid> 230-9.mga6
+ Revision: 1085221
- backport and rebase upstream patch for gperf 3.1 api change
2017-01-16 - tv <tv> 230-8.mga6
+ Revision: 1081988
- remove BR on qemu
- disable systemd-timesyncd by default (mga#15019, mga#15534, mga#17091, mga#19113)
2016-11-30 - ngompa <ngompa> 230-6.mga6
+ Revision: 1071259
- Remove Conflicts on plymouth-quit.service to fix prefdm starting sddm (mga#19216, mga#19781, mga#19782)
2016-10-02 - colin <colin> 230-5.mga6
+ Revision: 1058131
- Add upstream fixes for CVE-2016-7795 mga#19494
2016-08-31 - colin <colin> 230-4.mga6
+ Revision: 1049609
- Hopefully fully fix rfkill stop job queue blockage mga#16647
2016-06-23 - tmb <tmb> 230-3.mga6
+ Revision: 1037329
- silence udev version print during boot as it breaks splash
2016-06-07 - colin <colin> 230-1.mga6
+ Revision: 1020575
- Disable dnssec for now (as recommended upstream)
- Lock down fbdev (upstream)
- Fix automount expiry+remount (upstream)
- * New version: v230
* Keep previous logind user process handling behaviour (do not kill screen)

See Also

Package Description
lib64udev1-230-12.mga6.x86_64.rpm udev library package
lib64udf0-0.94-1.mga6.x86_64.rpm Libraries from libcdio
lib64udftools-devel-1.0.0-0.b3.22.mga6.x86_64.rpm Devel files from udftools
lib64udftools-static-devel-1.0.0-0.b3.22.mga6.x86_64.rpm Static Library for developing applications with udftools
lib64udftools1-1.0.0-0.b3.22.mga6.x86_64.rpm Libraries from udftools
lib64udisks-gir2.0-2.1.8-2.mga6.x86_64.rpm GObject Introspection interface description for udisks2
lib64udisks2-devel-2.1.8-2.mga6.x86_64.rpm Development files for libudev
lib64udisks2_0-2.1.8-2.mga6.x86_64.rpm Dynamic library to access the udisks daemon
lib64udns-devel-0.2-6.mga6.x86_64.rpm Static library and header files for the libmemcached library
lib64udns0-0.2-6.mga6.x86_64.rpm DNS Resolver Library
lib64udunits2-devel-2.1.24-6.mga6.x86_64.rpm Headers and libraries for udunits
lib64udunits2_0-2.1.24-6.mga6.x86_64.rpm Libraries for udunits
lib64uhd-devel-3.10.1.1-1.mga6.x86_64.rpm Development files for UHD
lib64uhd003-3.10.1.1-1.mga6.x86_64.rpm Library files for UHD
lib64uhttpmock-devel-0.5.0-2.mga6.x86_64.rpm Support files necessary to compile applications with uhttpmock
Advertisement
Advertisement