lib64virt-devel-3.3.0-1.mga6.x86_64.rpm


Advertisement

Description

lib64virt-devel - Development tools for programs using libvirt

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lib64virt-devel-3.3.0-1.mga6.x86_64.rpm
Package name lib64virt-devel
Package version 3.3.0
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage http://libvirt.org/
License LGPLv2+
Maintainer -
Download size 152.90 KB
Installed size 1.95 MB
Libvirt is a C toolkit to interact with the virtualization
capabilities of recent versions of Linux.
This package contains the header files and libraries needed for
developing programs using the libvirt library.

Alternatives

Package Version Architecture Repository
lib64virt-devel-3.10.0-1.5.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt-devel-3.10.0-1.3.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt-devel-3.10.0-1.2.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt-devel-3.10.0-1.1.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt-devel - - -

Requires

Name Value
devel(libacl(64bit)) -
devel(libaudit(64bit)) -
devel(libavahi-client(64bit)) -
devel(libavahi-common(64bit)) -
devel(libcap-ng(64bit)) -
devel(libcrypto(64bit)) -
devel(libcurl(64bit)) -
devel(libdbus-1(64bit)) -
devel(libdevmapper(64bit)) -
devel(libdl(64bit)) -
devel(libgcc_s(64bit)) -
devel(libgnutls(64bit)) -
devel(libintl(64bit)) -
devel(libnl-3(64bit)) -
devel(libnuma(64bit)) -
devel(libsasl2(64bit)) -
devel(libssh2(64bit)) -
devel(libutil(64bit)) -
devel(libvirt(64bit)) -
devel(libxenlight(64bit)) -
devel(libxlutil(64bit)) -
devel(libxml2(64bit)) -
devel(libyajl(64bit)) -
lib64virt0 == 3.3.0
pkgconfig -
pkgconfig(libvirt) -
xen-devel -

Provides

Name Value
devel(libvirt(64bit)) -
devel(libvirt-admin(64bit)) -
devel(libvirt-lxc(64bit)) -
devel(libvirt-qemu(64bit)) -
lib64virt-devel == 3.3.0-1.mga6
lib64virt-devel(x86-64) == 3.3.0-1.mga6
libvirt-devel == 3.3.0-1.mga6
pkgconfig(libvirt) == 3.3.0
pkgconfig(libvirt-admin) == 3.3.0
pkgconfig(libvirt-lxc) == 3.3.0
pkgconfig(libvirt-qemu) == 3.3.0

Conflicts

Name Value
lib64virt0 < 3.3.0-1.mga6
libvirt-utils < 1.3.4-2

Obsoletes

Name Value
lib64virt0-devel -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64virt-devel-3.3.0-1.mga6.x86_64.rpm
Source Package libvirt-3.3.0-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64virt-devel rpm package:
    # urpmi lib64virt-devel

Files

Path
/usr/include/libvirt/libvirt-admin.h
/usr/include/libvirt/libvirt-common.h
/usr/include/libvirt/libvirt-domain-snapshot.h
/usr/include/libvirt/libvirt-domain.h
/usr/include/libvirt/libvirt-event.h
/usr/include/libvirt/libvirt-host.h
/usr/include/libvirt/libvirt-interface.h
/usr/include/libvirt/libvirt-lxc.h
/usr/include/libvirt/libvirt-network.h
/usr/include/libvirt/libvirt-nodedev.h
/usr/include/libvirt/libvirt-nwfilter.h
/usr/include/libvirt/libvirt-qemu.h
/usr/include/libvirt/libvirt-secret.h
/usr/include/libvirt/libvirt-storage.h
/usr/include/libvirt/libvirt-stream.h
/usr/include/libvirt/libvirt.h
/usr/include/libvirt/virterror.h
/usr/lib64/libvirt-admin.so
/usr/lib64/libvirt-lxc.so
/usr/lib64/libvirt-qemu.so
/usr/lib64/libvirt.so
/usr/lib64/pkgconfig/libvirt-admin.pc
/usr/lib64/pkgconfig/libvirt-lxc.pc
/usr/lib64/pkgconfig/libvirt-qemu.pc
/usr/lib64/pkgconfig/libvirt.pc
/usr/share/doc/lib64virt-devel/libvirt-api.xml
/usr/share/libvirt/api/libvirt-api.xml
/usr/share/libvirt/api/libvirt-lxc-api.xml
/usr/share/libvirt/api/libvirt-qemu-api.xml

Changelog

2017-05-25 - mrambo3501 <mrambo3501> 3.3.0-1.mga6
+ Revision: 1104524
- version 3.3.0 fixes CVE-2015-5160 (#19717)
- deleted two patches applied upstream
- deleted the systemd patch which no longer applies
2017-05-03 - akien <akien> 1.3.5-5.mga6
+ Revision: 1098914
- Disable glusterfs support, the package was dropped in mga6 as unmaintained
2016-08-19 - blino <blino> 1.3.5-4.mga6
+ Revision: 1046966
- recommend virtual netcat package instead of specific netcat-openbsd (to avoid conflict with task-printing which requires netcat-traditional), libvirt supports both as of commit a2b5c57db83559d4fe32ee90fbb6685555388e06 from 2011
2016-07-07 - luigiwalser <luigiwalser> 1.3.5-3.mga6
+ Revision: 1039476
- add upstream patch to fix CVE-2016-5008
2016-06-29 - tv <tv> 1.3.5-2.mga6
+ Revision: 1038152
- patch 100: add support for VirtualBox 5
2016-06-07 - tv <tv> 1.3.5-1.mga6
+ Revision: 1020554
- new release
2016-05-21 - tv <tv> 1.3.4-4.mga6
+ Revision: 1017279
- Fix libxl video config via virt-install (bz #1334557)
2016-05-04 - tv <tv> 1.3.4-3.mga6
+ Revision: 1009081
- better docs: include CSS files
- do not BR the full qemu
2016-05-03 - tv <tv> 1.3.4-2.mga6
+ Revision: 1008950
- adjust file list
- move api XML files back into devel (needed for python-libvirt build)
- split docs sub package
2016-05-03 - tv <tv> 1.3.4-1.mga6
+ Revision: 1008907
- new release

See Also

Package Description
lib64virt-gconfig-gir1.0-0.2.3-2.mga6.x86_64.rpm GObject Introspection interface description for libvirt-glib
lib64virt-gconfig1.0-devel-0.2.3-2.mga6.x86_64.rpm libvirt object APIs for processing object configuration development files
lib64virt-gconfig1.0_0-0.2.3-2.mga6.x86_64.rpm libvirt object APIs for processing object configuration
lib64virt-glib-gir1.0-0.2.3-2.mga6.x86_64.rpm GObject Introspection interface description for libvirt-glib
lib64virt-glib1.0-devel-0.2.3-2.mga6.x86_64.rpm libvirt glib integration for events development files
lib64virt-glib1.0_0-0.2.3-2.mga6.x86_64.rpm libvirt object APIs for processing object configuration
lib64virt-gobject-gir1.0-0.2.3-2.mga6.x86_64.rpm GObject Introspection interface description for libvirt-glib
lib64virt-gobject1.0-devel-0.2.3-2.mga6.x86_64.rpm libvirt object APIs for managing virtualization hosts development files
lib64virt-gobject1.0_0-0.2.3-2.mga6.x86_64.rpm libvirt object APIs for managing virtualization hosts
lib64virt-sandbox-devel-0.6.0-1.mga6.x86_64.rpm Libvirt application sandbox framework development files
lib64virt-sandbox5-0.6.0-1.mga6.x86_64.rpm Libvirt application sandbox framework libraries
lib64virt0-3.3.0-1.mga6.x86_64.rpm A library to interact with virtualization capabilities
lib64virtualgl-2.5.2-1.mga6.x86_64.rpm Libraries injected by VirtualGL into applications that are ran through it
lib64visio-devel-0.1.5-4.mga6.x86_64.rpm Development files for libvisio
lib64visio0.1_1-0.1.5-4.mga6.x86_64.rpm Development files for libvisio
Advertisement
Advertisement