libgnat1-5.4.0-5.mga6.x86_64.rpm


Advertisement

Description

libgnat1 - Ada 95 runtime libraries

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename libgnat1-5.4.0-5.mga6.x86_64.rpm
Package name libgnat1
Package version 5.4.0
Package release 5.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://gcc.gnu.org/
License GPLv3+
Maintainer -
Download size 940.94 KB
Installed size 3.62 MB
This package contains the shared libraries required to run programs
compiled with the GNU Ada compiler (GNAT) if they are compiled to use
shared libraries.  It also contains the shared libraries for the
Implementation of the Ada Semantic Interface Specification (ASIS), the
implementation of Distributed Systems Programming (GLADE) and the
Posix 1003.5 Binding (Florist).

Alternatives

Package Version Architecture Repository
libgnat1-5.5.0-1.mga6.x86_64.rpm 5.5.0 x86_64 Mageia Core Updates
libgnat1-5.5.0-1.mga6.i586.rpm 5.5.0 i586 Mageia Core Updates
libgnat1-5.4.0-5.mga6.i586.rpm 5.4.0 i586 Mageia Core
libgnat1 - - -

Requires

Name Value
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3)(64bit) -
libgcc_s.so.1(GCC_4.2.0)(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.4)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -

Provides

Name Value
gnat-runtime == 5.4.0-5.mga6
libgnarl-5.so.1()(64bit) -
libgnat == 5.4.0-5.mga6
libgnat-5.so.1()(64bit) -
libgnat1 == 5.4.0-5.mga6
libgnat1(x86-64) == 5.4.0-5.mga6

Obsoletes

Name Value
gnat-runtime -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libgnat1-5.4.0-5.mga6.x86_64.rpm
Source Package gcc-5.4.0-5.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libgnat1 rpm package:
    # urpmi libgnat1

Files

Path
/usr/lib64/libgnarl-5.so.1
/usr/lib64/libgnat-5.so.1

Changelog

2017-07-01 - tmb <tmb> 5.4.0-5.mga6
+ Revision: 1108810
- add Mageia branding (requested by Remi on dev@ ml)
2017-05-13 - tmb <tmb> 5.4.0-4.mga6
+ Revision: 1100979
- more miscompilation and ICE fixes from upstream gcc-5 branch
2017-04-26 - tmb <tmb> 5.4.0-3.mga6
+ Revision: 1097540
- more fixes from upstream gcc-5 branch
2017-03-26 - tmb <tmb> 5.4.0-2.mga6
+ Revision: 1094890
- add regression, miscompilation and ICE fixes from upstream gcc-5 branch
- Support exception propagation without lock-free atomic int
2016-06-03 - tmb <tmb> 5.4.0-1.mga6
+ Revision: 1020173
- update to 5.4.0 final
2016-05-29 - tmb <tmb> 5.4.0-0.RC.1.mga6
+ Revision: 1019344
- update to 5.4.0-RC
+ tv <tv>
- fix error on uninstalling gcc-doc
2016-05-05 - tmb <tmb> 5.3.1-0.20160503.1.mga6
+ Revision: 1009624
- update to 2016-05-03 snapshot
2016-04-20 - tmb <tmb> 5.3.1-0.20160419.1.mga6
+ Revision: 1003817
- update to 2016-04-19
+ pterjan <pterjan>
- Add flags for armv7hl
2016-04-06 - tmb <tmb> 5.3.1-0.20160405.1.mga6
+ Revision: 999024
- update to 2016-04-05
2016-03-24 - tmb <tmb> 5.3.1-0.20160322.1.mga6
+ Revision: 994763
- update to 2016-03-22

See Also

Package Description
libgnome-games-support-i18n-1.2.1-1.mga6.noarch.rpm Support library for GNOME games - translations
libgnome-keyring-i18n-3.12.0-9.mga6.noarch.rpm Localization data files for libgnome-keyring
libgnome-media-profiles-3.0.0-17.mga6.x86_64.rpm GNOME Media Profiles library
libgnome2-2.32.1-17.mga6.x86_64.rpm GNOME libraries
libgnome2-schemas-2.32.1-17.mga6.x86_64.rpm Default configuration for some GNOME software
libgnomecanvas-2.30.3-9.mga6.x86_64.rpm GnomeCanvas widget
libgnomecanvasmm2.6-doc-2.26.0-13.mga6.x86_64.rpm Documentation of libgnomecanvasmm library
libgnomecups-0.2.3-15.mga6.x86_64.rpm GNOME library for CUPS integration
libgnomekbd-common-3.22.0.1-2.mga6.x86_64.rpm Files used by GNOME keyboard libraries
libgnomeprint-2.18.8-9.mga6.x86_64.rpm GNOME print library
libgnomeprintui-2.18.6-9.mga6.x86_64.rpm GNOME print library
libgnomeui2-2.24.5-9.mga6.x86_64.rpm Main GNOME libraries
libgnomeuimm2.6-doc-2.28.0-11.mga6.x86_64.rpm Documentation of libgnomeuimm library
libgomp-devel-5.4.0-5.mga6.x86_64.rpm GCC OpenMP support
libgomp1-5.4.0-5.mga6.x86_64.rpm GCC OpenMP support library
Advertisement
Advertisement