lua-lxc-2.0.8-1.mga6.x86_64.rpm


Advertisement

Description

lua-lxc - Lua binding for lxc

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename lua-lxc-2.0.8-1.mga6.x86_64.rpm
Package name lua-lxc
Package version 2.0.8
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category Development/Other
Homepage http://linuxcontainers.org
License LGPLv2
Maintainer -
Download size 18.10 KB
Installed size 30.24 KB
Linux Resource Containers provide process and resource isolation without the
overhead of full virtualization.
The lua-lxc package contains the Lua binding for lxc.

Alternatives

Package Version Architecture Repository
lua-lxc-2.0.8-1.1.mga6.x86_64.rpm 2.0.8 x86_64 Mageia Core Updates
lua-lxc-2.0.8-1.1.mga6.i586.rpm 2.0.8 i586 Mageia Core Updates
lua-lxc-2.0.8-1.mga6.i586.rpm 2.0.8 i586 Mageia Core
lua-lxc - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
liblxc.so.1()(64bit) -
libpthread.so.0()(64bit) -
lua-filesystem -

Provides

Name Value
lua-lxc == 1:2.0.8-1.mga6
lua-lxc(x86-64) == 1:2.0.8-1.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lua-lxc-2.0.8-1.mga6.x86_64.rpm
Source Package lxc-2.0.8-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lua-lxc rpm package:
    # urpmi lua-lxc

Files

Path
/usr/lib64/lua/5.2/lxc/core.so
/usr/share/lua/5.2/lxc.lua

Changelog

2017-06-04 - luigiwalser <luigiwalser> 1:2.0.8-1.mga6
+ Revision: 1106652
- 2.0.8 (fixes CVE-2017-5985)
- do not patch SysV init scripts anymore
- replace patch 2 with a configure argument
- remove upstreamed CVE-2016-8649 patch
- rediff patch 1
2017-06-04 - luigiwalser <luigiwalser> 1:2.0.0-6.mga6
+ Revision: 1106627
- rediff patch from ubuntu to fix CVE-2016-8649
2016-04-22 - tv <tv> 1:2.0.0-5.mga6
+ Revision: 1004679
- really adjusb obsoletes
2016-04-22 - tv <tv> 1:2.0.0-4.mga6
+ Revision: 1004551
- adjusb obsoletes
2016-04-21 - tv <tv> 1:2.0.0-3.mga6
+ Revision: 1004194
- really fix upgrade (epoch!)
2016-04-21 - tv <tv> 1:2.0.0-2.mga6
+ Revision: 1004116
- fix upgrade: conflicts with lxc-extra instead of just provides+obsoletes
+ philippem <philippem>
- add BR on graphviz
2016-04-21 - tv <tv> 1:2.0.0-1.mga6
+ Revision: 1004054
- adjust file list
- rediff mga support patch
- update to 2.0.0
- obsolete the -extra subpackage
- move the completion file to %{_datadir}
2016-03-31 - tv <tv> 1:1.1.5-6.mga6
+ Revision: 997053
- own cache dir
- run testsuite
- add a doc package
- add patches from FC
- enable lua bindings
- use standard macros for building
- enable seccomp support
- simpler solution for rpath error
- onw include directory
2016-03-30 - tv <tv> 1:1.1.5-4.mga6
+ Revision: 996817
- enable python bindings
- split tools now using python instead of shell in extra pkg
2016-03-29 - tv <tv> 1:1.1.5-2.mga6
+ Revision: 996303
- BR ssystemd-devel
- explicitely specify we use systemd (though it's now autocomputed as part of mga support)
- add a mageia template
- adjust file list for systemd

See Also

Package Description
lua-moonscript-0.3.2-1.mga6.noarch.rpm A little language that compiles to Lua
lua-plplot-5.12.0-4.mga6.x86_64.rpm PLplot support for Lua
lua-posix-33.3.1-2.mga6.x86_64.rpm A POSIX library for Lua
lua-prelude-3.1.0-2.mga6.x86_64.rpm Lua bindings for prelude
lua-rrdtool-1.6.0-1.mga6.x86_64.rpm RRD Tool LUA interface
lua-sec-0.5-5.mga6.x86_64.rpm OpenSSL binding for LuaSocket
lua-socket-3.0-0.rc1.3.mga6.x86_64.rpm Network access library for the Lua programming language
lua-socket5.1-3.0-0.rc1.3.mga6.x86_64.rpm Network access library for the Lua programming language (Lua 5.1)
lua-sql-2.3.1-1.mga6.x86_64.rpm Database connectivity for the Lua programming language
lua-sql-doc-2.3.1-1.mga6.x86_64.rpm Documentation for LuaSQL
lua-sql-mysql-2.3.1-1.mga6.x86_64.rpm MySQL database connectivity for the Lua programming language
lua-sql-postgresql-2.3.1-1.mga6.x86_64.rpm PostgreSQL database connectivity for the Lua programming language
lua-sql-sqlite-2.3.1-1.mga6.x86_64.rpm SQLite database connectivity for the Lua programming language
lua5.1-5.1.5-11.mga6.x86_64.rpm Powerful, light-weight programming language
luadoc-3.0.1-12.mga6.noarch.rpm Documentation Generator Tool for the Lua language
Advertisement
Advertisement