nodejs-string-width-1.0.1-7.mga6.noarch.rpm


Advertisement

Description

nodejs-string-width - Get the visual width of a string - the number of columns required to display it

Property Value
Distribution Mageia 6.0
Repository Mageia Core x86_64
Package name nodejs-string-width
Package version 1.0.1
Package release 7.mga6
Package architecture noarch
Package type rpm
Installed size 1.80 KB
Download size 8.80 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Get the visual width of a string - the number of columns required to display it

Alternatives

Package Version Architecture Repository
nodejs-string-width-1.0.1-7.mga6.noarch.rpm 1.0.1 noarch Mageia Core
nodejs-string-width - - -

Requires

Name Value
nodejs(engine) >= 0.10.0
npm(code-point-at) >= 1.0.0
npm(code-point-at) < 2
npm(is-fullwidth-code-point) >= 1.0.0
npm(is-fullwidth-code-point) < 2
npm(strip-ansi) >= 3.0
npm(strip-ansi) < 3.1

Provides

Name Value
nodejs-string-width == 1.0.1-7.mga6
npm(string-width) == 1.0.1

Download

Type URL
Binary Package nodejs-string-width-1.0.1-7.mga6.noarch.rpm
Source Package nodejs-string-width-1.0.1-7.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install nodejs-string-width rpm package:
    # urpmi nodejs-string-width

Files

Path
/usr/lib/node_modules/string-width/index.js
/usr/lib/node_modules/string-width/package.json
/usr/lib/node_modules/string-width/node_modules/code-point-at
/usr/lib/node_modules/string-width/node_modules/is-fullwidth-code-point
/usr/lib/node_modules/string-width/node_modules/strip-ansi

Changelog

2016-02-20 - umeabot <umeabot> 1.0.1-7.mga6
+ Revision: 972454
- Mageia 6 Mass Rebuild
2015-11-05 - spuhler <spuhler> 1.0.1-6.mga6
+ Revision: 897884
- fix dep syntax
- fixed deps
2015-11-03 - spuhler <spuhler> 1.0.1-5.mga6
+ Revision: 897658
- temp changed require to get out of loop
2015-11-03 - spuhler <spuhler> 1.0.1-4.mga6
+ Revision: 897556
- add wrap-ansi.patch for version
2015-11-03 - spuhler <spuhler> 1.0.1-3.mga6
+ Revision: 897496
- bumped rel for building failed build
- adding missing BR
- bumped rel for building failed build
- local srpm build based on Opensuse

See Also

Package Description
nodejs-string_decoder-0.10.31-1.mga6.noarch.rpm The string_decoder module from Node core
nodejs-strip-ansi-3.0.0-2.mga6.noarch.rpm Strip ANSI escape codes (used for colorizing strings in the terminal)
nodejs-strip-json-comments-2.0.1-2.mga6.noarch.rpm Strip comments from JSON
nodejs-supports-color-1.2.0-4.mga6.noarch.rpm Detect whether a terminal supports color
nodejs-tap-0.4.4-5.mga6.noarch.rpm A Test Anything Protocol library
nodejs-tap-parser-1.2.2-5.mga6.noarch.rpm Parse the test anything protocol
nodejs-tape-4.5.1-2.mga6.noarch.rpm Tap-producing test harness for Node.js and browsers
nodejs-test-0.6.0-2.mga6.noarch.rpm (Un)CommonJS test runner
nodejs-through-2.3.8-1.mga6.noarch.rpm Simplified stream construction for Node.js
nodejs-through2-2.0.1-2.mga6.noarch.rpm Node streams2 Transform wrapper to avoid explicit subclassing noise
nodejs-timers-ext-0.1.0-2.mga6.noarch.rpm Timers extensions
nodejs-transformers-3.0.0-2.mga6.noarch.rpm String/Data transformations for Node.js
nodejs-traverse-0.6.5-2.mga6.noarch.rpm Traverse and transform objects
nodejs-type-check-0.3.2-3.mga6.noarch.rpm Allows you to check the types of JavaScript values at runtime
nodejs-type-detect-2.0.1-1.mga6.noarch.rpm Improved typeof detection for Node.js and the browser
Advertisement
Advertisement