ocaml-ppx_expect-113.24.00-4.mga6.x86_64.rpm


Advertisement

Description

ocaml-ppx_expect - Cram like framework for OCaml

Property Value
Distribution Mageia 6.0
Repository Mageia Core x86_64
Package name ocaml-ppx_expect
Package version 113.24.00
Package release 4.mga6
Package architecture x86_64
Package type rpm
Installed size 4.53 MB
Download size 1.02 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Cram like framework for OCaml

Alternatives

Package Version Architecture Repository
ocaml-ppx_expect-113.24.00-4.mga6.i586.rpm 113.24.00 i586 Mageia Core
ocaml-ppx_expect - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
ocaml(Arg) == 1a93c52516966fe6a58564a4c4d9e4fa
ocaml(ArrayLabels) == 58a6628d1722d835ca71a7e76108549e
ocaml(Ast_mapper) == 2f6edec5226c38ecac91e20726fcea36
ocaml(Bigarray) == 0643187a8b562858118690c393d01c2e
ocaml(Buffer) == a579f4a57e300ec755f84af883c1e51b
ocaml(Bytes) == 4c433013a088edac8556bb94512e4988
ocaml(BytesLabels) == f6f25f5328b09c590f56c7e37005c501
ocaml(CamlinternalFormatBasics) == 8b069fca1e4d9316b588e5554f38bb24
ocaml(CamlinternalOO) == 3d0b4eb4525ba4274c8885d7124f7bbc
ocaml(Char) == 60fd98ba6ff303baf9287e7bfb886f12
ocaml(Complex) == d0dcc1da3c694cf9a7e924c7832d1528
ocaml(Digest) == eab54f58b34b8a6fdc763db6966614a1
ocaml(Fieldslib) == d78f9550b468f1166a617738859cc53d
ocaml(Filename) == 3817bec1dad20c6f594d3a85b13020b8
ocaml(Format) == 61d4350242b30078d3ad96c904c9f7a1
ocaml(Hashtbl) == bb8e269d690301a1c4ff14a08e96e83e
ocaml(Ident) == 0e63cdedc04eeceaf13d25112bc4bf06
ocaml(Int32) == f43b8a2972804b40e28b661b6fdf157a
ocaml(Int64) == 3565b288ec68024088360805650448dd
ocaml(Lazy) == 7dba0bf02f60e5ff44e9e4057263f28d
ocaml(Lexing) == 1be6a5484fb3cfb69d2c981438a7be62
ocaml(List) == 8988208489274193e4e3f69dc6ec2f75
ocaml(ListLabels) == f9c893b10648fae8e31ad7bfcd64248f
ocaml(Location) == 48151c5a89ff874e2a73745b600c618b
ocaml(Longident) == 1abca0377f9b5ee27748e4348907b700
ocaml(Misc) == 42435de3bc0601e4a0c40cdb87e06d1f
ocaml(Nativeint) == d9e04753374f7110b66feda40414e5e3
ocaml(Obj) == 8b014ec57a472d9f3922b63e5de9d1f2
ocaml(Pervasives) == 0d015a5a2136659b0de431be7f1545be
ocaml(Ppx_core) == 54d76f5fcdf751005d5d68220cc0565a
ocaml(Ppx_driver) == f2dd1d996358b9c75828ec179fe5699f
ocaml(Ppx_inline_test) == 41bc3f1c952718634715d5a91946243a
ocaml(Ppx_inline_test_lib) == 4544c4e365040627df81996a29620fd3
ocaml(Ppx_inline_test_libname) == 626651b724ddb0c5d63d22438a53189e
ocaml(Printexc) == fb616c60404add6295347001c01bfcaa
ocaml(Printf) == eb49a17645c5ea2dd298430a3c986186
ocaml(Random) == 6d410ecc00aac669668fa399dbd6fca2
ocaml(Sexplib) == c57a8a4681da1442b4aef0c6a31e3bd2
ocaml(StdLabels) == bde0996731d345de202224fb701f3910
ocaml(String) == 9cb286f2c4569fd32c379b1a05c7b590
ocaml(StringLabels) == d53c23a5c85990103dbeef11dd5cf4f1
ocaml(Sys) == 0ce699458ce4430954d7e6a78874647c
ocaml(Unix) == 30a4cc8e5f4f902ea609c91caec48af7
ocaml(Warnings) == 644f347ec032c6c4524d44b97baeb72d
ocaml(runtime) == 4.02.3

Provides

Name Value
ocaml(Expect_test_collector) == 3df229ff13ec488794a8ccb18b87005b
ocaml(Ppx_expect) == fd4383f87e5f7f5689894bfc83d50b1f
ocaml-ppx_expect == 113.24.00-4.mga6
ocaml-ppx_expect(x86-64) == 113.24.00-4.mga6

Download

Type URL
Binary Package ocaml-ppx_expect-113.24.00-4.mga6.x86_64.rpm
Source Package ocaml-ppx_expect-113.24.00-4.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ocaml-ppx_expect rpm package:
    # urpmi ocaml-ppx_expect

Files

Path
/usr/lib64/ocaml/ppx_expect/META
/usr/lib64/ocaml/ppx_expect/expect_test_collector.a
/usr/lib64/ocaml/ppx_expect/expect_test_collector.cma
/usr/lib64/ocaml/ppx_expect/expect_test_collector.cmi
/usr/lib64/ocaml/ppx_expect/expect_test_collector.cmxa
/usr/lib64/ocaml/ppx_expect/expect_test_collector.cmxs
/usr/lib64/ocaml/ppx_expect/libexpect_test_evaluator_lib_stubs.a
/usr/lib64/ocaml/ppx_expect/ppx
/usr/lib64/ocaml/ppx_expect/ppx_expect.a
/usr/lib64/ocaml/ppx_expect/ppx_expect.cma
/usr/lib64/ocaml/ppx_expect/ppx_expect.cmi
/usr/lib64/ocaml/ppx_expect/ppx_expect.cmxa
/usr/lib64/ocaml/ppx_expect/ppx_expect.cmxs
/usr/lib64/ocaml/stubslibs/dllexpect_test_evaluator_lib_stubs.so

Changelog

2016-02-24 - pterjan <pterjan> 113.24.00-4.mga6
+ Revision: 977713
- Do not ship expect_test_evaluator_lib as it requires Ocaml_re which I failed to find
2016-02-23 - pterjan <pterjan> 113.24.00-3.mga6
+ Revision: 977425
- Rebuild for new sexplib
2016-02-23 - pterjan <pterjan> 113.24.00-2.mga6
+ Revision: 977397
- Rebuild for ocaml-re
2016-02-21 - pterjan <pterjan> 113.24.00-1.mga6
+ Revision: 975862
- imported package ocaml-ppx_expect

See Also

Package Description
ocaml-ppx_expect-devel-113.24.00-4.mga6.x86_64.rpm Development files for ocaml-ppx_expect
ocaml-ppx_fail-113.24.00-1.mga6.x86_64.rpm Add location to calls to failwiths
ocaml-ppx_fail-devel-113.24.00-1.mga6.x86_64.rpm Development files for ocaml-ppx_fail
ocaml-ppx_fields_conv-113.24.00-1.mga6.x86_64.rpm Generation of accessor and iteration functions for ocaml records
ocaml-ppx_fields_conv-devel-113.24.00-1.mga6.x86_64.rpm Development files for ocaml-ppx_fields_conv
ocaml-ppx_here-113.24.00-3.mga6.x86_64.rpm Expands here into its location
ocaml-ppx_here-devel-113.24.00-3.mga6.x86_64.rpm Development files for ocaml-ppx_here
ocaml-ppx_inline_test-113.24.00-1.mga6.x86_64.rpm Syntax extension for writing in-line tests in ocaml code
ocaml-ppx_inline_test-devel-113.24.00-1.mga6.x86_64.rpm Development files for ocaml-ppx_inline_test
ocaml-ppx_jane-113.24.01-1.mga6.x86_64.rpm Standard Jane Street ppx rewriters
ocaml-ppx_jane-devel-113.24.01-1.mga6.x86_64.rpm Development files for ocaml-ppx_jane
ocaml-ppx_let-113.24.00-1.mga6.x86_64.rpm Monadic let-bindings
ocaml-ppx_let-devel-113.24.00-1.mga6.x86_64.rpm Development files for ocaml-ppx_let
ocaml-ppx_optcomp-113.24.00-1.mga6.x86_64.rpm Optional compilation for OCaml
ocaml-ppx_optcomp-devel-113.24.00-1.mga6.x86_64.rpm Development files for ocaml-ppx_optcomp
Advertisement
Advertisement