perl-Dist-Zilla-Plugin-MatchManifest-4.20.0-6.mga6.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MatchManifest - Ensure that MANIFEST is correct

Property Value
Distribution Mageia 6.0
Repository Mageia Core x86_64
Package name perl-Dist-Zilla-Plugin-MatchManifest
Package version 4.20.0
Package release 6.mga6
Package architecture noarch
Package type rpm
Installed size 45.12 KB
Download size 23.00 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
If included, this plugin will ensure that the distribution contains a
_MANIFEST_ file and that its contents match the files collected by
Dist::Zilla. If not, it will display the differences and (if STDIN & STDOUT
are TTYs) offer to update the _MANIFEST_.
As I see it, there are 2 problems that a MANIFEST can protect against:
* 1.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MatchManifest-4.20.0-6.mga6.noarch.rpm 4.20.0 noarch Mageia Core
perl-Dist-Zilla-Plugin-MatchManifest - - -

Requires

Name Value
perl(Dist::Zilla) >= 4.101.780
perl(Dist::Zilla::Role::InstallTool) -
perl(Moose) >= 0.650.0
perl(Moose::Autobox) >= 0.90.0
perl(Text::Diff) -
perl(autodie) -
perl-base >= 2:5.22.2

Provides

Name Value
perl(Dist::Zilla::Plugin::MatchManifest) == 4.20.0
perl-Dist-Zilla-Plugin-MatchManifest == 4.20.0-6.mga6

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-MatchManifest-4.20.0-6.mga6.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MatchManifest-4.20.0-6.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-MatchManifest rpm package:
    # urpmi perl-Dist-Zilla-Plugin-MatchManifest

Files

Path
/usr/lib/perl5/vendor_perl/5.22.2/Dist/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.22.2/Dist/Zilla/Plugin/MatchManifest.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-MatchManifest/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MatchManifest/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-MatchManifest/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-MatchManifest/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-MatchManifest/README
/usr/share/man/man3/Dist::Zilla::Plugin::MatchManifest.3pm.xz

Changelog

2016-06-19 - pterjan <pterjan> 4.20.0-6.mga6
+ Revision: 1026315
- Rebuild for perl 5.22.2
2016-02-19 - umeabot <umeabot> 4.20.0-5.mga6
+ Revision: 970332
- Mageia 6 Mass Rebuild
2015-10-03 - sander85 <sander85> 4.20.0-4.mga6
+ Revision: 885943
- Fix BRs
2014-10-15 - umeabot <umeabot> 4.20.0-3.mga5
+ Revision: 749425
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2014-07-21 - sander85 <sander85> 4.20.0-1.mga5
+ Revision: 655083
- update to 4.02
2013-10-19 - umeabot <umeabot> 4.10.0-2.mga4
+ Revision: 531913
- Mageia 4 Mass Rebuild
2013-08-12 - sander85 <sander85> 4.10.0-1.mga4
+ Revision: 465696
- update to 4.01

See Also

Package Description
perl-Dist-Zilla-Plugin-Mercurial-0.80.0-3.mga6.noarch.rpm Check for modified/removed/unknown files
perl-Dist-Zilla-Plugin-MetaData-BuiltWith-1.4.3-1.mga6.noarch.rpm Go overkill and report everything in all name-spaces
perl-Dist-Zilla-Plugin-MetaProvides-2.1.11-2.mga6.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Class-2.1.0-3.mga6.noarch.rpm Scans Dist::Zilla's .pm files and tries to identify classes using Class::Discover
perl-Dist-Zilla-Plugin-MetaProvides-FromFile-2.1.1-3.mga6.noarch.rpm In the event nothing else works, pull in hand-crafted metadata from a specified file
perl-Dist-Zilla-Plugin-MetaProvides-Package-2.3.2-2.mga6.noarch.rpm Extract namespaces/version from traditional packages for provides
perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-7.mga6.noarch.rpm Metadata resource URLs from Git configuration
perl-Dist-Zilla-Plugin-MetaYAML-Minimal-0.1.0-3.mga6.noarch.rpm Generate a reductionist YAML META file for compatibility only
perl-Dist-Zilla-Plugin-MinimumPerl-1.6.0-3.mga6.noarch.rpm Detects the minimum version of Perl required for your dist
perl-Dist-Zilla-Plugin-ModuleBuild-XSOrPP-0.40.0-7.mga6.noarch.rpm Add a --pp option to your Build.PL to force an XS-less build
perl-Dist-Zilla-Plugin-ModuleBuildTiny-0.14.0-3.mga6.noarch.rpm Build a Build.PL that uses Module::Build::Tiny
perl-Dist-Zilla-Plugin-ModuleBuildTiny-Fallback-0.23.0-2.mga6.noarch.rpm Generate a Build.PL that uses Module::Build::Tiny, falling back to Module::Build as needed
perl-Dist-Zilla-Plugin-ModuleInstall-1.1.1-1.mga6.noarch.rpm Build Module::Install based Distributions with Dist::Zilla
perl-Dist-Zilla-Plugin-MojibakeTests-0.800.0-3.mga6.noarch.rpm Release tests for source encoding
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5-3.mga6.noarch.rpm Extract previous version from changelog
Advertisement
Advertisement