python2-dnf-plugin-versionlock-2.1.1-2.mga6.noarch.rpm


Advertisement

Description

python2-dnf-plugin-versionlock - Version Lock Plugin for DNF

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename python2-dnf-plugin-versionlock-2.1.1-2.mga6.noarch.rpm
Package name python2-dnf-plugin-versionlock
Package version 2.1.1
Package release 2.mga6
Package architecture noarch
Package type rpm
Category System/Packaging
Homepage https://github.com/rpm-software-management/dnf-plugins-core
License GPLv2+
Maintainer -
Download size 16.65 KB
Installed size 17.24 KB
Version lock plugin takes a set of name/versions for packages and excludes all other
versions of those packages. This allows you to e.g. protect packages from being
updated by newer versions.

Alternatives

Package Version Architecture Repository
python2-dnf-plugin-versionlock-2.1.5-1.mga6.noarch.rpm 2.1.5 noarch Mageia Core Updates
python2-dnf-plugin-versionlock-2.1.5-1.mga6.noarch.rpm 2.1.5 noarch Mageia Core Updates
python2-dnf-plugin-versionlock-2.1.3-1.mga6.noarch.rpm 2.1.3 noarch Mageia Core Updates
python2-dnf-plugin-versionlock-2.1.3-1.mga6.noarch.rpm 2.1.3 noarch Mageia Core Updates
python2-dnf-plugin-versionlock-2.1.1-2.mga6.noarch.rpm 2.1.1 noarch Mageia Core
python2-dnf-plugin-versionlock - - -

Requires

Name Value
config(python2-dnf-plugin-versionlock) == 2.1.1-2.mga6
python(abi) == 2.7
python2-dnf-plugins-core == 2.1.1-2.mga6

Provides

Name Value
config(python2-dnf-plugin-versionlock) == 2.1.1-2.mga6
python2-dnf-plugin-versionlock == 2.1.1-2.mga6
python2-dnf-plugins-extras-versionlock == 2.1.1-2.mga6

Conflicts

Name Value
dnf-plugins-extras-common-data < 2.0.0
python3-dnf-plugin-versionlock < 2.1.1-2.mga6

Obsoletes

Name Value
python2-dnf-plugins-extras-versionlock < 2.0.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python2-dnf-plugin-versionlock-2.1.1-2.mga6.noarch.rpm
Source Package dnf-plugins-core-2.1.1-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install python2-dnf-plugin-versionlock rpm package:
    # urpmi python2-dnf-plugin-versionlock

Files

Path
/etc/dnf/plugins/versionlock.conf
/etc/dnf/plugins/versionlock.list
/usr/lib/python2.7/site-packages/dnf-plugins/versionlock.py
/usr/lib/python2.7/site-packages/dnf-plugins/versionlock.pyc
/usr/lib/python2.7/site-packages/dnf-plugins/versionlock.pyo
/usr/share/man/man8/dnf.plugin.versionlock.8.xz

Changelog

2017-07-02 - ngompa <ngompa> 2.1.1-2.mga6
+ Revision: 1108984
- Backport patch to have debuginfo-install only install requested packages (rhbz#1322599)
2017-06-14 - ngompa <ngompa> 2.1.1-1.mga6
+ Revision: 1107634
- Upgrade to 2.1.1
2017-05-23 - ngompa <ngompa> 2.1.0-1.mga6
+ Revision: 1104148
- Upgrade to 2.1.0
2017-05-14 - ngompa <ngompa> 2.0.0-2.mga6
+ Revision: 1101003
- Have dnf-utils conflict with gdb with bundled debuginfo-install
2017-05-06 - ngompa <ngompa> 2.0.0-1.mga6
+ Revision: 1099367
- Upgrade to v2.0.0
- Add dnf-utils subpackage
- Resync spec with upstream version
2017-03-23 - ngompa <ngompa> 1.1.0-1.mga6
+ Revision: 1094583
- Upgrade to 1.1.0
- Remove reference to noroot plugin that is now part of DNF
2017-02-20 - ngompa <ngompa> 1.0.2-1.mga6
+ Revision: 1087001
- Update to 1.0.2, drop merged patches
2017-02-18 - ngompa <ngompa> 1.0.1-1.mga6
+ Revision: 1086668
- Upgrade to 1.0.1
2016-11-27 - ngompa <ngompa> 1.0.0-0.2.rc1.mga6
+ Revision: 1070521
- Fix description sections for packages
2016-11-26 - ngompa <ngompa> 1.0.0-0.1.rc1.mga6
+ Revision: 1070236
- Upgrade to 1.0.0rc1

See Also

Package Description
python2-dnf-plugins-core-2.1.1-2.mga6.noarch.rpm Python 2 interface to core plugins for DNF
python2-dnf-plugins-extras-common-2.0.1-1.mga6.noarch.rpm Common files for Extras Plugins for DNF
python2-dnfdaemon-0.3.18-1.mga6.noarch.rpm Python 2 API for communicating with the dnf-daemon D-Bus service
python2-editorconfig-0.12.1-1.mga6.noarch.rpm EditorConfig File Locator and Interpreter for Python 2
python2-flask-sqlalchemy-2.1-3.mga6.noarch.rpm Adds SQLAlchemy support to Flask application
python2-fonttools-3.13.1-1.mga6.noarch.rpm Python 2 fonttools library
python2-gpg-1.8.0-11.mga6.x86_64.rpm GnuPG Made Easy (GPGME) bindings for Python 2
python2-hawkey-0.9.2-1.mga6.x86_64.rpm Python 2 bindings for the hawkey interface
python2-imgcreate-24.4-1.mga6.x86_64.rpm Python 2 modules for building system images
python2-ipyparallel-5.0.1-2.mga6.noarch.rpm Interactive Parallel Computing with IPython (Python 2)
python2-jsbeautifier-1.6.4-1.mga6.noarch.rpm JavaScript unobfuscator and beautifier
python2-jupyter-client-4.2.2-1.mga6.noarch.rpm Jupyter protocol client APIs (Python 2)
python2-jupyter-console-5.0.0-1.mga6.noarch.rpm Jupyter terminal console APIs (Python 2)
python2-jupyter-core-4.1.0-1.mga6.noarch.rpm Core common functionality of Jupyter projects for Python 2
python2-jupyter-nbconvert-4.2.0-2.mga6.noarch.rpm Jupyter Notebook Conversion (Python 2)
Advertisement
Advertisement