zookeeper-3.4.9-2.mga6.x86_64.rpm


Advertisement

Description

zookeeper - A high-performance coordination service for distributed applications

Property Value
Distribution Mageia 6.1
Repository Mageia Core x86_64
Package filename zookeeper-3.4.9-2.mga6.x86_64.rpm
Package name zookeeper
Package version 3.4.9
Package release 2.mga6
Package architecture x86_64
Package type rpm
Category Development/Java
Homepage https://zookeeper.apache.org/
License ASL 2.0 and BSD
Maintainer -
Download size 83.38 KB
Installed size 216.78 KB
ZooKeeper is a centralized service for maintaining configuration information,
naming, providing distributed synchronization, and providing group services.

Alternatives

Package Version Architecture Repository
zookeeper-3.4.9-2.mga6.i586.rpm 3.4.9 i586 Mageia Core
zookeeper - - -

Requires

Name Value
bash -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
liblog4cxx.so.10()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libzookeeper_mt.so.2()(64bit) -
libzookeeper_st.so.2()(64bit) -

Provides

Name Value
zookeeper == 3.4.9-2.mga6
zookeeper(x86-64) == 3.4.9-2.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package zookeeper-3.4.9-2.mga6.x86_64.rpm
Source Package zookeeper-3.4.9-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install zookeeper rpm package:
    # urpmi zookeeper

Files

Path
/usr/bin/cli_mt
/usr/bin/cli_st
/usr/bin/load_gen
/usr/bin/zkCleanup.sh
/usr/bin/zkCli.sh
/usr/bin/zkServer.sh
/usr/bin/zktreeutil
/usr/libexec/zkEnv.sh
/usr/share/doc/zookeeper/ChangeLog
/usr/share/doc/zookeeper/LICENSE
/usr/share/doc/zookeeper/NOTICE.txt
/usr/share/doc/zookeeper/README
/usr/share/doc/zookeeper/README.txt

Changelog

2017-06-02 - daviddavid <daviddavid> 3.4.9-2.mga6
+ Revision: 1105831
- add debian patch to fix CVE-2017-5637 (mga#21014)
2017-01-01 - daviddavid <daviddavid> 3.4.9-1.mga6
+ Revision: 1079263
- new version: 3.4.9 (fixes CVE-2016-5017, sync with Fedora)
- remove merged upstream CVE-2016-5017 patch
2016-09-20 - daviddavid <daviddavid> 3.4.6-5.mga6
+ Revision: 1054539
- add patch from debian to fix CVE-2016-5017 (mga#19419)
2016-02-27 - daviddavid <daviddavid> 3.4.6-4.mga6
+ Revision: 980198
- sync zookeeper package with fedora 24
* Remove duplicates and fix broken classpath items in zkEnv
* Fix bz#1272694 Remove precondition on myid file for standalone defaults
* Update zkEnv.sh CLASSPATH to fix bz#1261458
* Update netty3 patch for 3.9.3
- use new python macros
- rebuild against current java stack
+ umeabot <umeabot>
- Mageia 6 Mass Rebuild
2015-12-06 - neoclust <neoclust> 3.4.6-3.mga6
+ Revision: 908553
- Rebuild for ARM
2015-09-25 - daviddavid <daviddavid> 3.4.6-2.mga6
+ Revision: 883457
- rebuild for new boost 1.59.0
2015-07-11 - daviddavid <daviddavid> 3.4.6-1.mga6
+ Revision: 853277
- new version: 3.4.6 (based on fc23)
- remove unneeded patches
- update BuildRequires and Requires
- rename subpackage python on python-zookeeper (instead of python-ZooKeeper)
- update zookeeper.service file
- update file list
2015-01-02 - daviddavid <daviddavid> 3.4.5-25.mga5
+ Revision: 808204
- switch to log4j12 (log4j-1.2.17)
- add patch to fix the path of log4j-1.2.17.jar
* zookeeper-3.4.5-mga-find_liblog4j12_path.patch
- update BuildRequires and Requires
- add missing BuildRequires on slf4j-log4j12 (fix build failure)
- use .mfiles generated during build (fix build failure)
- use appropriate post/pre/postun/preun macros for mageia
- use %makeinstall_std and %configure2_5x macros for mageia
- fix Group
- fix provides on python-ZooKeeper package
- add missing Requires on rpm-helper
- fix a non-conffile-in-etc for zoo_sample.cfg file
- add doc on -server subpackage
2014-10-15 - umeabot <umeabot> 3.4.5-24.mga5
+ Revision: 743568
- Second Mageia 5 Mass Rebuild
2014-09-27 - tv <tv> 3.4.5-23.mga5
+ Revision: 730759
- rebuild for missing pythoneggs deps

See Also

Package Description
zookeeper-java-3.4.9-2.mga6.noarch.rpm Zookeeper Java client library
zookeeper-javadoc-3.4.9-2.mga6.noarch.rpm Javadoc for zookeeper
zookeeper-lib-doc-3.4.9-2.mga6.noarch.rpm Documentation for the zookeeper library
zookeeper-server-3.4.9-2.mga6.noarch.rpm ZooKeeper server
zoom-1.1.5-8.mga6.x86_64.rpm Z-Machine: it plays text adventure games written in ZCode
zopfli-1.0.1-2.mga6.x86_64.rpm zlib compatible compressor
zramstart-1.0.2-1.mga6.noarch.rpm Sets up zram swap devices on boot
zsh-5.3.1-1.mga6.x86_64.rpm A shell with lots of features
zsh-doc-5.3.1-1.mga6.noarch.rpm The doc package of zsh
zsync-0.6.2-6.mga6.x86_64.rpm An rsync like transfer software over http
zukitwo-common-20170209-1.mga6.noarch.rpm Files common to Zukitwo themes
zukitwo-gtk2-theme-20170209-1.mga6.noarch.rpm Zukitwo GTK+2 themes
zukitwo-gtk3-theme-20170209-1.mga6.noarch.rpm Zukitwo GTK+3 themes
zukitwo-metacity-theme-20170209-1.mga6.noarch.rpm Zukitwo Metacity themes
zukitwo-xfwm4-theme-20170209-1.mga6.noarch.rpm Zukitwo Xfwm4 themes
Advertisement
Advertisement