libjasper-devel-1.900.23-5.2.mga6.i586.rpm


Advertisement

Description

libjasper-devel - Development tools for programs which will use the libjasper library

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package filename libjasper-devel-1.900.23-5.2.mga6.i586.rpm
Package name libjasper-devel
Package version 1.900.23
Package release 5.2.mga6
Package architecture i586
Package type rpm
Category Development/C
Homepage http://www.ece.uvic.ca/~mdadams/jasper/
License BSD-like
Maintainer -
Download size 370.64 KB
Installed size 632.55 KB
The libjasper1-devel package includes the header files necessary for
developing programs which will manipulate JPEG-2000 files using
the libjasper library.
If you are going to develop programs which will manipulate JPEG-2000 images,
you should install libjasper1-devel.  You'll also need to have the
libjasper1 package installed.

Alternatives

Package Version Architecture Repository
libjasper-devel-1.900.23-5.1.mga6.i586.rpm 1.900.23 i586 Mageia Core Updates
libjasper-devel-1.900.23-5.mga6.i586.rpm 1.900.23 i586 Mageia Core
libjasper-devel - - -

Requires

Name Value
devel(libjpeg) -
devel(libm) -
libjasper1 == 1.900.23-5.2.mga6
multiarch-utils -
pkgconfig -

Provides

Name Value
devel(libjasper) -
jasper-devel == 1.900.23-5.2.mga6
libjasper-devel == 1.900.23-5.2.mga6
libjasper-devel(x86-32) == 1.900.23-5.2.mga6
libjasper1-devel -
pkgconfig(jasper) == 1.900.23

Conflicts

Name Value
lib64jasper1.701_1-devel -

Obsoletes

Name Value
libjasper1-devel < 1.900.1-5

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libjasper-devel-1.900.23-5.2.mga6.i586.rpm
Source Package jasper-1.900.23-5.2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libjasper-devel rpm package:
    # urpmi libjasper-devel

Files

Path
/usr/include/jasper/jas_cm.h
/usr/include/jasper/jas_config.h
/usr/include/jasper/jas_config2.h
/usr/include/jasper/jas_debug.h
/usr/include/jasper/jas_fix.h
/usr/include/jasper/jas_getopt.h
/usr/include/jasper/jas_icc.h
/usr/include/jasper/jas_image.h
/usr/include/jasper/jas_init.h
/usr/include/jasper/jas_malloc.h
/usr/include/jasper/jas_math.h
/usr/include/jasper/jas_seq.h
/usr/include/jasper/jas_stream.h
/usr/include/jasper/jas_string.h
/usr/include/jasper/jas_tmr.h
/usr/include/jasper/jas_tvp.h
/usr/include/jasper/jas_types.h
/usr/include/jasper/jas_version.h
/usr/include/jasper/jasper.h
/usr/include/multiarch-i386-linux/jasper/jas_config.h
/usr/lib/libjasper.so
/usr/lib/pkgconfig/jasper.pc
/usr/share/doc/libjasper-devel/README.pdf
/usr/share/doc/libjasper-devel/jasper.pdf
/usr/share/doc/libjasper-devel/jpeg2000.pdf

Changelog

2019-05-04 - daviddavid <daviddavid> 1.900.23-5.2.mga6
+ Revision: 1396336
- add patches to fix CVE-2016-9398, CVE-2018-19539 and CVE-2018-19542 (mga#24760)
- patch9: fixes CVE-2016-9396 (mga#23139)
- patch10: fixes CVE-2018-9055 (mga#23139)
2017-04-19 - ns80 <ns80> 1.900.23-5.mga6
+ Revision: 1096765
- add patch for CVE-2016-9600 (mga#19605)
2017-03-07 - ns80 <ns80> 1.900.23-4.mga6
+ Revision: 1089446
- add a patch for NULL pointer dereference in jp2_encode (mga#19605)
2017-03-06 - ns80 <ns80> 1.900.23-3.mga6
+ Revision: 1089055
- add an upstream patch for NULL pointer dereference in jp2_cdef_destroy
2017-03-02 - ns80 <ns80> 1.900.23-2.mga6
+ Revision: 1088469
- update patch for CVE-2016-9557 to not modify the API
2017-02-22 - ns80 <ns80> 1.900.23-1.mga6
+ Revision: 1087360
- new version 1.900.23 for many security issues (mga#19605)
2016-08-16 - luigiwalser <luigiwalser> 1.900.1-26.mga6
+ Revision: 1046531
- add patches from fedora to fix CVE-2015-5203 and CVE-2015-5221

See Also

Package Description
libjasper-static-devel-1.900.23-5.1.mga6.i586.rpm Static libraries for programs which will use the libjasper library
libjasper-static-devel-1.900.23-5.2.mga6.i586.rpm Static libraries for programs which will use the libjasper library
libjasper1-1.900.23-5.1.mga6.i586.rpm Libraries for JasPer
libjasper1-1.900.23-5.2.mga6.i586.rpm Libraries for JasPer
libjavascriptcore-gir4.0-2.16.6-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.3-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.4-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.5-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.6-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.1-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.2-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.3-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.5-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcoregtk4.0_18-2.16.6-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.18.3-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
Advertisement
Advertisement