libjasper1-1.900.23-5.2.mga6.i586.rpm


Advertisement

Description

libjasper1 - Libraries for JasPer

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package filename libjasper1-1.900.23-5.2.mga6.i586.rpm
Package name libjasper1
Package version 1.900.23
Package release 5.2.mga6
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.ece.uvic.ca/~mdadams/jasper/
License BSD-like
Maintainer -
Download size 150.74 KB
Installed size 357.20 KB
JasPer is a software-based implementation of the codec specified in the
emerging JPEG-2000 Part-1 standard (i.e., ISO/IEC 15444-1).  This package
contains libraries for working with JPEG-2000 images.

Alternatives

Package Version Architecture Repository
libjasper1-1.900.23-5.1.mga6.i586.rpm 1.900.23 i586 Mageia Core Updates
libjasper1-1.900.23-5.mga6.i586.rpm 1.900.23 i586 Mageia Core
libjasper1 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -

Provides

Name Value
libjasper == 1.900.23-5.2.mga6
libjasper.so.1 -
libjasper1 == 1.900.23-5.2.mga6
libjasper1(x86-32) == 1.900.23-5.2.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libjasper1-1.900.23-5.2.mga6.i586.rpm
Source Package jasper-1.900.23-5.2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libjasper1 rpm package:
    # urpmi libjasper1

Files

Path
/usr/lib/libjasper.so.1
/usr/lib/libjasper.so.1.0.0

Changelog

2019-05-04 - daviddavid <daviddavid> 1.900.23-5.2.mga6
+ Revision: 1396336
- add patches to fix CVE-2016-9398, CVE-2018-19539 and CVE-2018-19542 (mga#24760)
- patch9: fixes CVE-2016-9396 (mga#23139)
- patch10: fixes CVE-2018-9055 (mga#23139)
2017-04-19 - ns80 <ns80> 1.900.23-5.mga6
+ Revision: 1096765
- add patch for CVE-2016-9600 (mga#19605)
2017-03-07 - ns80 <ns80> 1.900.23-4.mga6
+ Revision: 1089446
- add a patch for NULL pointer dereference in jp2_encode (mga#19605)
2017-03-06 - ns80 <ns80> 1.900.23-3.mga6
+ Revision: 1089055
- add an upstream patch for NULL pointer dereference in jp2_cdef_destroy
2017-03-02 - ns80 <ns80> 1.900.23-2.mga6
+ Revision: 1088469
- update patch for CVE-2016-9557 to not modify the API
2017-02-22 - ns80 <ns80> 1.900.23-1.mga6
+ Revision: 1087360
- new version 1.900.23 for many security issues (mga#19605)
2016-08-16 - luigiwalser <luigiwalser> 1.900.1-26.mga6
+ Revision: 1046531
- add patches from fedora to fix CVE-2015-5203 and CVE-2015-5221

See Also

Package Description
libjavascriptcore-gir4.0-2.16.6-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.3-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.4-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.5-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.18.6-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.1-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.2-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.3-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcore-gir4.0-2.20.5-1.mga6.i586.rpm GObject Introspection interface description for JSCore
libjavascriptcoregtk4.0_18-2.16.6-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.18.3-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.18.4-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.18.5-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.18.6-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
libjavascriptcoregtk4.0_18-2.20.1-1.mga6.i586.rpm GTK+ port of WebKit web browser engine
Advertisement
Advertisement