libpython2.7-2.7.15-1.4.mga6.i586.rpm


Advertisement

Description

libpython2.7 - Shared libraries for Python 2.7.15

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package filename libpython2.7-2.7.15-1.4.mga6.i586.rpm
Package name libpython2.7
Package version 2.7.15
Package release 1.4.mga6
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.python.org/
License Modified CNRI Open Source License
Maintainer -
Download size 618.57 KB
Installed size 1.81 MB
This packages contains Python shared object library.  Python is an
interpreted, interactive, object-oriented programming language often
compared to Tcl, Perl, Scheme or Java.

Alternatives

Package Version Architecture Repository
libpython2.7-2.7.15-1.3.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
libpython2.7-2.7.15-1.2.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
libpython2.7-2.7.15-1.1.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
libpython2.7-2.7.15-1.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
libpython2.7-2.7.13-1.1.mga6.i586.rpm 2.7.13 i586 Mageia Core Updates
libpython2.7-2.7.13-1.mga6.i586.rpm 2.7.13 i586 Mageia Core
libpython2.7 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpython2.7-stdlib == 2.7.15-1.4.mga6
libutil.so.1 -
libutil.so.1(GLIBC_2.0) -

Provides

Name Value
libpython2.7 == 2.7.15-1.4.mga6
libpython2.7(x86-32) == 2.7.15-1.4.mga6
libpython2.7.so.1.0 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libpython2.7-2.7.15-1.4.mga6.i586.rpm
Source Package python-2.7.15-1.4.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libpython2.7 rpm package:
    # urpmi libpython2.7

Files

Path
/usr/lib/libpython2.7.so.1.0

Changelog

2019-05-04 - daviddavid <daviddavid> 2.7.15-1.4.mga6
+ Revision: 1396345
- add patch to fix CVE-2019-9948 (mga#24758)
- add/rebase upstream patch to fix CVE-2019-9636 (mga#24640)
- add/rebase upstream patch to fix CVE-2019-5010 (mga#24340)
- add two patches to fix CVE-2018-1000802 and CVE-2018-14647 (mga#23061)
+ luigiwalser <luigiwalser>
- add patch from opensuse to fix CVE-2017-18207
- add patch from ubuntu to fix CVE-2017-1000158
+ philippem <philippem>
- update to 2.7.15
- disable emacs
- disable emacs, bump subrel
- disable emacs
- fix CVE-2018-1060 mga#22845
2017-01-28 - philippem <philippem> 2.7.13-1.mga6
+ Revision: 1083777
- update to 2.7.13
2016-09-10 - daviddavid <daviddavid> 2.7.12-4.mga6
+ Revision: 1051328
- rebuild to regenerate rpms (they were mistakenly replaced with those of Updates_testing)
2016-08-13 - philippem <philippem> 2.7.12-3.mga6
+ Revision: 1046402
- fix CVE-2016-1000110
2016-07-06 - tmb <tmb> 2.7.12-2.mga6
+ Revision: 1039104
- submit to release
2016-07-04 - philippem <philippem> 2.7.12-1.mga6
+ Revision: 1038599
- update to 2.7.12
2016-06-21 - philippem <philippem> 2.7.11-14.mga6
+ Revision: 1037112
- improve patch for zipimporter (mga#18691)
2016-06-19 - philippem <philippem> 2.7.11-13.mga6
+ Revision: 1036799
- fix CVE-2016-0772 mga#18691
2016-06-12 - philippem <philippem> 2.7.11-12.mga6
+ Revision: 1021227
- fix heap overflow in zipimporter module mga#18691
- add conflict for tkinter
2016-06-06 - tv <tv> 2.7.11-11.mga6
+ Revision: 1020342
- unbloat installation:
o remove recommends on tkinter-apps
o move recommends on python-doc in devel package

See Also

Package Description
libpython2.7-stdlib-2.7.13-1.1.mga6.i586.rpm Python 2.7.13 standard library
libpython2.7-stdlib-2.7.15-1.1.mga6.i586.rpm Python 2.7.15 standard library
libpython2.7-stdlib-2.7.15-1.2.mga6.i586.rpm Python 2.7.15 standard library
libpython2.7-stdlib-2.7.15-1.3.mga6.i586.rpm Python 2.7.15 standard library
libpython2.7-stdlib-2.7.15-1.4.mga6.i586.rpm Python 2.7.15 standard library
libpython2.7-stdlib-2.7.15-1.mga6.i586.rpm Python 2.7.15 standard library
libpython2.7-testsuite-2.7.13-1.1.mga6.i586.rpm Testsuite for the Python 2.7.13 standard library
libpython2.7-testsuite-2.7.15-1.1.mga6.i586.rpm Testsuite for the Python 2.7.15 standard library
libpython2.7-testsuite-2.7.15-1.2.mga6.i586.rpm Testsuite for the Python 2.7.15 standard library
libpython2.7-testsuite-2.7.15-1.3.mga6.i586.rpm Testsuite for the Python 2.7.15 standard library
libpython2.7-testsuite-2.7.15-1.4.mga6.i586.rpm Testsuite for the Python 2.7.15 standard library
libpython2.7-testsuite-2.7.15-1.mga6.i586.rpm Testsuite for the Python 2.7.15 standard library
libpython3-devel-3.5.3-1.1.mga6.i586.rpm The libraries and header files needed for Python development
libpython3-devel-3.5.3-1.2.mga6.i586.rpm The libraries and header files needed for Python development
libpython3-devel-3.5.3-1.4.mga6.i586.rpm The libraries and header files needed for Python development
Advertisement
Advertisement