libqtgui4-4.8.7-15.1.mga6.i586.rpm


Advertisement

Description

libqtgui4 - Qt4 Component Library

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package filename libqtgui4-4.8.7-15.1.mga6.i586.rpm
Package name libqtgui4
Package version 4.8.7
Package release 15.1.mga6
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://qt-project.org/
License LGPLv2 with exceptions or GPLv3 with exceptions and GFDL
Maintainer -
Download size 4.04 MB
Installed size 11.19 MB
Qt4 Component Library.
The QtGui module extends QtCore with GUI functionality.

Alternatives

Package Version Architecture Repository
libqtgui4-4.8.7-15.mga6.i586.rpm 4.8.7 i586 Mageia Core
libqtgui4 - - -

Requires

Name Value
libICE.so.6 -
libQtCore.so.4 -
libQtGui.so.4 -
libQtSvg.so.4 -
libSM.so.6 -
libX11.so.6 -
libXcursor.so.1 -
libXext.so.6 -
libXfixes.so.3 -
libXi.so.6 -
libXinerama.so.1 -
libXrandr.so.2 -
libXrender.so.1 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.2) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.9) -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libmng.so.2 -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libtiff.so.5 -
libtiff.so.5(LIBTIFF_4.0) -
libz.so.1 -
qt4-common == 4:4.8.7

Provides

Name Value
libQtGui.so.4 -
libqgif.so -
libqico.so -
libqimsw-multi.so -
libqjpeg.so -
libqmng.so -
libqsvg.so -
libqtga.so -
libqtgui4 == 4:4.8.7-15.1.mga6
libqtgui4(x86-32) == 4:4.8.7-15.1.mga6
libqtiff.so -
qtguilib == 4:4.8.7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libqtgui4-4.8.7-15.1.mga6.i586.rpm
Source Package qt4-4.8.7-15.1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqtgui4 rpm package:
    # urpmi libqtgui4

Files

Path
/usr/lib/libQtGui.so.4
/usr/lib/libQtGui.so.4.8
/usr/lib/libQtGui.so.4.8.7
/usr/lib/qt4/plugins/imageformats/libqgif.so
/usr/lib/qt4/plugins/imageformats/libqico.so
/usr/lib/qt4/plugins/imageformats/libqjpeg.so
/usr/lib/qt4/plugins/imageformats/libqmng.so
/usr/lib/qt4/plugins/imageformats/libqsvg.so
/usr/lib/qt4/plugins/imageformats/libqtga.so
/usr/lib/qt4/plugins/imageformats/libqtiff.so
/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so

Changelog

2019-04-01 - daviddavid <daviddavid> 4:4.8.7-15.1.mga6
+ Revision: 1384498
- add patch to fix CVE-2018-19872 (mga#24600)
2017-03-16 - mrambo3501 <mrambo3501> 4:4.8.7-15.mga6
+ Revision: 1093104
- Rebuild for icu-58.2
2016-08-29 - luigiwalser <luigiwalser> 4:4.8.7-14.mga6
+ Revision: 1049387
- actually replace renamed database plugins on upgrade from mga5
2016-05-13 - barjac <barjac> 4:4.8.7-13.mga6
+ Revision: 1014920
- rebuild for icu
2016-04-17 - neoclust <neoclust> 4:4.8.7-12.mga6
+ Revision: 1003140
- Rebuild because of missing signature

See Also

Package Description
libqthelp4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtmultimedia4-4.8.7-15.1.mga6.i586.rpm Qt4 Multimedia Lib
libqtnetwork4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtopengl4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtscript4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtscripttools4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtsql4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtsvg4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqttest4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtxdg-3.1.0-1.mga6.i586.rpm Library providing freedesktop.org specs implementations for Qt
libqtxml4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libqtxmlpatterns4-4.8.7-15.1.mga6.i586.rpm Qt4 Component Library
libquadmath-devel-5.5.0-1.mga6.i586.rpm GCC __float128 support
libquadmath0-5.5.0-1.mga6.i586.rpm GCC __float128 shared support library
libquagga-devel-0.99.24.1-6.1.mga6.i586.rpm Header and object files for quagga development
Advertisement
Advertisement