libsdl2.0_0-2.0.9-1.mga6.i586.rpm


Advertisement

Description

libsdl2.0_0 - Main library for sdl2

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package name libsdl2.0_0
Package version 2.0.9
Package release 1.mga6
Package architecture i586
Package type rpm
Installed size 1.30 MB
Download size 424.13 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package contains the library needed to run programs dynamically
linked with sdl2.

Alternatives

Package Version Architecture Repository
libsdl2.0_0-2.0.5-2.1.mga6.i586.rpm 2.0.5 i586 Mageia Core Updates
libsdl2.0_0-2.0.5-2.mga6.i586.rpm 2.0.5 i586 Mageia Core
libsdl2.0_0 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libc.so.6(GLIBC_2.9) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -

Provides

Name Value
libSDL2 2.0.so.0
libsdl2.0_0 == 2.0.9-1.mga6
libsdl2.0_0(x86-32) == 2.0.9-1.mga6

Download

Type URL
Binary Package libsdl2.0_0-2.0.9-1.mga6.i586.rpm
Source Package sdl2-2.0.9-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libsdl2.0_0 rpm package:
    # urpmi libsdl2.0_0

Files

Path
/usr/lib/libSDL2-2.0.so.0
/usr/lib/libSDL2-2.0.so.0.9.0
/usr/share/doc/libsdl2.0_0/BUGS.txt
/usr/share/doc/libsdl2.0_0/COPYING.txt
/usr/share/doc/libsdl2.0_0/CREDITS.txt
/usr/share/doc/libsdl2.0_0/README-SDL.txt
/usr/share/doc/libsdl2.0_0/README.txt
/usr/share/doc/libsdl2.0_0/TODO.txt
/usr/share/doc/libsdl2.0_0/WhatsNew.txt

Changelog

2018-11-16 - akien <akien> 2.0.9-1.mga6
+ Revision: 1330134
- Version 2.0.9, needed for SDL2_image 2.0.4 (mga#22769)
- Add upstream patch to fix dynapi system loader resolving the initializer to the wrong version
- Upstream patch to fix CVE-2017-2888 (mga#21882)
- Fix previously unapplied P0, fixing sdl#3571
2017-01-28 - akien <akien> 2.0.5-2.mga6
+ Revision: 1083868
- Add upstream (and own :)) patch to fix MessageBox display
2016-10-21 - akien <akien> 2.0.5-1.mga6
+ Revision: 1062901
- Version 2.0.5
2016-04-15 - tv <tv> 2.0.4-3.mga6
+ Revision: 1001740
- make devel package pull some commonly used backend devel pkgs
2016-04-15 - tv <tv> 2.0.4-2.mga6
+ Revision: 1001624
- provides SDL2-devel
2016-01-10 - akien <akien> 2.0.4-1.mga6
+ Revision: 921069
- Version 2.0.4

See Also

Package Description
libsdl2_image-devel-2.0.1-1.1.mga6.i586.rpm Headers for developing programs that will use sdl2_image
libsdl2_image-devel-2.0.4-1.mga6.i586.rpm Headers for developing programs that will use sdl2_image
libsdl2_image-static-devel-2.0.1-1.1.mga6.i586.rpm Static library for developing static programs that use sdl2_image
libsdl2_image-static-devel-2.0.4-1.mga6.i586.rpm Static library for developing static programs that use sdl2_image
libsdl2_image2.0_0-2.0.1-1.1.mga6.i586.rpm Main library for sdl2_image
libsdl2_image2.0_0-2.0.4-1.mga6.i586.rpm Main library for sdl2_image
libsdl2_image2.0_0-test-2.0.1-1.1.mga6.i586.rpm Test binary for sdl2_image
libsdl2_image2.0_0-test-2.0.4-1.mga6.i586.rpm Test binary for sdl2_image
libsdl2_mixer-devel-2.0.4-1.mga6.i586.rpm Headers for developing programs that will use sdl2_mixer
libsdl2_mixer-static-devel-2.0.4-1.mga6.i586.rpm Static library for developing static programs that use sdl2_mixer
libsdl2_mixer2.0_0-2.0.4-1.mga6.i586.rpm Main library for sdl2_mixer
libshadowsocks-devel-3.1.0-1.1.mga6.i586.rpm Development headers for shadowsocks-libev
libshadowsocks-devel-3.1.0-1.2.mga6.i586.rpm Development headers for shadowsocks-libev
libshadowsocks-devel-3.1.0-1.mga6.i586.rpm Development headers for shadowsocks-libev
libshadowsocks2-3.1.0-1.1.mga6.i586.rpm A lightweight and secure socks5 proxy
Advertisement
Advertisement