libsmbclient-devel-4.7.12-1.2.mga6.i586.rpm


Advertisement

Description

libsmbclient-devel - Developer tools for the SMB client library

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package filename libsmbclient-devel-4.7.12-1.2.mga6.i586.rpm
Package name libsmbclient-devel
Package version 4.7.12
Package release 1.2.mga6
Package architecture i586
Package type rpm
Category Development/C
Homepage http://www.samba.org/
License GPLv3+ and LGPLv3+
Maintainer -
Download size 29.99 KB
Installed size 120.78 KB
The libsmbclient-devel package contains the header files and libraries needed to
develop programs that link against the SMB client library in the Samba suite.

Alternatives

Package Version Architecture Repository
libsmbclient-devel-4.7.12-1.1.mga6.i586.rpm 4.7.12 i586 Mageia Core Updates
libsmbclient-devel-4.6.16-1.mga6.i586.rpm 4.6.16 i586 Mageia Core Updates
libsmbclient-devel-4.6.12-1.1.mga6.i586.rpm 4.6.12 i586 Mageia Core Updates
libsmbclient-devel-4.6.12-1.mga6.i586.rpm 4.6.12 i586 Mageia Core Updates
libsmbclient-devel-4.6.7-1.mga6.i586.rpm 4.6.7 i586 Mageia Core Updates
libsmbclient-devel-4.6.5-1.mga6.i586.rpm 4.6.5 i586 Mageia Core
libsmbclient-devel - - -

Requires

Name Value
devel(libndr) -
devel(libndr-standard) -
devel(libsamba-errors) -
devel(libsamba-util) -
devel(libsmbconf) -
devel(libtalloc) -
devel(libtevent) -
devel(libtevent-util) -
libsmbclient0 == 4.7.12-1.2.mga6
pkgconfig -

Provides

Name Value
devel(libsmbclient) -
libsmbclient-devel == 4.7.12-1.2.mga6
libsmbclient-devel(x86-32) == 4.7.12-1.2.mga6
pkgconfig(smbclient) == 0.2.3
smbclient-devel == 4.7.12-1.2.mga6

Obsoletes

Name Value
libsamba4-smbclient-devel < 4.1.17-12

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libsmbclient-devel-4.7.12-1.2.mga6.i586.rpm
Source Package samba-4.7.12-1.2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libsmbclient-devel rpm package:
    # urpmi libsmbclient-devel

Files

Path
/usr/include/samba-4.0/libsmbclient.h
/usr/lib/libsmbclient.so
/usr/lib/pkgconfig/smbclient.pc
/usr/share/man/man7/libsmbclient.7.xz

Changelog

2019-03-09 - luigiwalser <luigiwalser> 4.7.12-1.2.mga6
+ Revision: 1373019
- rebuild for ldb
- 4.6.12
- 4.6.8
+ buchan <buchan>
- Update to 4.7.12 for CVE-2018-14629, CVE-2018-16841,
CVE-2018-16851, CVE-2018-16853
Upgrade dependencies (tdb 1.3.14, tevent 0.9.36, ldb 1.2.3)
Clean up file lists
- Security updates for CVE-2018-1057 and CVE-2018-1050
+ bcornec <bcornec>
- update to upstream samba-4.6.16 to fix mga#23444
+ zezinho <zezinho>
- add dummy_client
+ semiletov <semiletov>
- spec update to 4.6.11
+ neoclust <neoclust>
- New version 4.6.7 ( Fixes CVE-2017-11103 (mga#21482)
2017-06-08 - luigiwalser <luigiwalser> 4.6.5-1.mga6
+ Revision: 1107268
- 4.6.5
2017-05-25 - neoclust <neoclust> 4.6.4-1.mga6
+ Revision: 1104505
- New version 4.6.4
2017-05-24 - luigiwalser <luigiwalser> 4.5.10-1.mga6
+ Revision: 1104363
- 4.5.10 (fixes CVE-2017-7494)
2017-05-23 - luigiwalser <luigiwalser> 4.5.9-1.mga6
+ Revision: 1104140
- 4.5.9
2017-03-31 - luigiwalser <luigiwalser> 4.5.8-1.mga6
+ Revision: 1095490
- 4.5.8
2017-03-23 - luigiwalser <luigiwalser> 4.5.7-1.mga6
+ Revision: 1094590
- 4.5.7 (fixes CVE-2017-2619)
- fix permissions of spool directory (mga#20513)
2017-03-14 - luigiwalser <luigiwalser> 4.5.6-1.mga6
+ Revision: 1092515
- 4.5.6
2017-03-12 - wally <wally> 4.5.5-2.mga6
+ Revision: 1092137
- add obsoletes to fix update from mga5 (mga#20456)
2017-01-31 - luigiwalser <luigiwalser> 4.5.5-1.mga6
+ Revision: 1084350
- 4.5.5

See Also

Package Description
libsmbclient0-4.6.12-1.1.mga6.i586.rpm The SMB client library
libsmbclient0-4.6.12-1.mga6.i586.rpm The SMB client library
libsmbclient0-4.6.16-1.mga6.i586.rpm The SMB client library
libsmbclient0-4.6.7-1.mga6.i586.rpm The SMB client library
libsmbclient0-4.7.12-1.1.mga6.i586.rpm The SMB client library
libsmbclient0-4.7.12-1.2.mga6.i586.rpm The SMB client library
libsmesh-devel-6.7.5-1.mga6.i586.rpm Development files for smesh
libsmesh3-6.7.5-1.mga6.i586.rpm OpenCascade based MESH framework
libsmm-local3-0.15.0-2.1.mga6.i586.rpm Secure Messaging 'local' module for OpenSC
libsmm-local6-0.19.0-1.mga6.i586.rpm Secure Messaging 'local' module for OpenSC
libsndfile-devel-1.0.28-3.1.mga6.i586.rpm Libraries, includes, etc to develop libsndfile applications
libsndfile-devel-1.0.28-3.2.mga6.i586.rpm Libraries, includes, etc to develop libsndfile applications
libsndfile-devel-1.0.28-3.3.mga6.i586.rpm Libraries, includes, etc to develop libsndfile applications
libsndfile-devel-1.0.28-3.4.mga6.i586.rpm Libraries, includes, etc to develop libsndfile applications
libsndfile-progs-1.0.28-3.1.mga6.i586.rpm Example progs based on libsndfile
Advertisement
Advertisement