python-2.7.15-1.2.mga6.i586.rpm


Advertisement

Description

python - An interpreted, interactive object-oriented programming language

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates i586
Package name python
Package version 2.7.15
Package release 1.2.mga6
Package architecture i586
Package type rpm
Installed size 12.73 KB
Download size 20.17 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Python is an interpreted, interactive, object-oriented programming
language often compared to Tcl, Perl, Scheme or Java. Python includes
modules, classes, exceptions, very high level dynamic data types and
dynamic typing. Python supports interfaces to many system calls and
libraries, as well as to various windowing systems (X11, Motif, Tk,
Mac and MFC).
Programmers can write new built-in modules for Python in C or C++.
Python can be used as an extension language for applications that
need a programmable interface. This package contains most of the
standard Python modules, as well as modules for interfacing to the
Tix widget set for Tk and RPM.
Note that documentation for Python is provided in the python-docs
package.

Alternatives

Package Version Architecture Repository
python-2.7.15-1.2.mga6.x86_64.rpm 2.7.15 x86_64 Mageia Core Updates
python-2.7.15-1.1.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
python-2.7.15-1.1.mga6.x86_64.rpm 2.7.15 x86_64 Mageia Core Updates
python-2.7.15-1.mga6.x86_64.rpm 2.7.15 x86_64 Mageia Core Updates
python-2.7.15-1.mga6.i586.rpm 2.7.15 i586 Mageia Core Updates
python-2.7.13-1.1.mga6.x86_64.rpm 2.7.13 x86_64 Mageia Core Updates
python-2.7.13-1.1.mga6.i586.rpm 2.7.13 i586 Mageia Core Updates
python-2.7.13-1.mga6.x86_64.rpm 2.7.13 x86_64 Mageia Core
python-2.7.13-1.mga6.i586.rpm 2.7.13 i586 Mageia Core
python - - -

Requires

Name Value
config(python) == 2.7.15-1.2.mga6
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpython2.7 == 2.7.15-1.2.mga6
libpython2.7.so.1.0 -
python(abi) -
python2-rpm macros

Provides

Name Value
config(python) == 2.7.15-1.2.mga6
python == 2.7.15-1.2.mga6
python(abi) == 2.7
python(x86-32) == 2.7.15-1.2.mga6
python-base == 2.7.15
python-ctypes == 0:2.7.15-1.2.mga6
python-elementtree == 0:2.7.15-1.2.mga6
python2 == 2.7.15-1.2.mga6

Conflicts

Name Value
python-devel < 2.7-6
tkinter < 2.7.15

Obsoletes

Name Value
python-base < 2.6
python-ctypes <= 0:2.7.15-1.2.mga6
python-elementtree <= 0:2.7.15-1.2.mga6

Download

Type URL
Binary Package python-2.7.15-1.2.mga6.i586.rpm
Source Package python-2.7.15-1.2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install python rpm package:
    # urpmi python

Files

Path
/etc/pythonrc.py
/etc/profile.d/30python2.csh
/etc/profile.d/30python2.sh
/usr/bin/2to3
/usr/bin/pydoc
/usr/bin/python
/usr/bin/python2
/usr/bin/python2.7
/usr/share/doc/python/README.mga
/usr/share/man/man1/python.1.xz
/usr/share/man/man1/python2.1.xz
/usr/share/man/man1/python2.7.1.xz

Changelog

2019-02-12 - daviddavid <daviddavid> 2.7.15-1.2.mga6
+ Revision: 1365457
- add/rebase upstream patch to fix CVE-2019-5010 (mga#24340)
- add two patches to fix CVE-2018-1000802 and CVE-2018-14647 (mga#23061)
+ luigiwalser <luigiwalser>
- add patch from opensuse to fix CVE-2017-18207
- add patch from ubuntu to fix CVE-2017-1000158
+ philippem <philippem>
- update to 2.7.15
- disable emacs
- disable emacs, bump subrel
- disable emacs
- fix CVE-2018-1060 mga#22845
2017-01-28 - philippem <philippem> 2.7.13-1.mga6
+ Revision: 1083777
- update to 2.7.13
2016-09-10 - daviddavid <daviddavid> 2.7.12-4.mga6
+ Revision: 1051328
- rebuild to regenerate rpms (they were mistakenly replaced with those of Updates_testing)
2016-08-13 - philippem <philippem> 2.7.12-3.mga6
+ Revision: 1046402
- fix CVE-2016-1000110
2016-07-06 - tmb <tmb> 2.7.12-2.mga6
+ Revision: 1039104
- submit to release
2016-07-04 - philippem <philippem> 2.7.12-1.mga6
+ Revision: 1038599
- update to 2.7.12
2016-06-21 - philippem <philippem> 2.7.11-14.mga6
+ Revision: 1037112
- improve patch for zipimporter (mga#18691)
2016-06-19 - philippem <philippem> 2.7.11-13.mga6
+ Revision: 1036799
- fix CVE-2016-0772 mga#18691
2016-06-12 - philippem <philippem> 2.7.11-12.mga6
+ Revision: 1021227
- fix heap overflow in zipimporter module mga#18691
- add conflict for tkinter
2016-06-06 - tv <tv> 2.7.11-11.mga6
+ Revision: 1020342
- unbloat installation:
o remove recommends on tkinter-apps
o move recommends on python-doc in devel package

See Also

Package Description
python-OpenSSL-16.1.0-1.mga6.noarch.rpm Python interface to the OpenSSL library
python-OpenSSL-doc-16.1.0-1.mga6.noarch.rpm Documentation for python-OpenSSL
python-SWF-0.4.5-14.1.mga6.i586.rpm Ming python module
python-attrs-17.4.0-1.mga6.noarch.rpm Attributes without boilerplate
python-aubio-0.4.2-2.1.mga6.i586.rpm Python bindings for aubio
python-aubio-0.4.2-2.2.mga6.i586.rpm Python bindings for aubio
python-bind-9.10.5.P3-1.mga6.i586.rpm A module allowing rndc commands to be sent from Python programs
python-bind-9.10.6.P1-1.mga6.i586.rpm A module allowing rndc commands to be sent from Python programs
python-bind-9.10.8.P1-1.mga6.i586.rpm A module allowing rndc commands to be sent from Python programs
python-caca-0.99-0.beta18.13.1.mga6.i586.rpm Python binding for libcaca
python-cffi-1.7.0-1.mga6.i586.rpm Foreign Function Interface for Python calling C code
python-cffi-doc-1.7.0-1.mga6.noarch.rpm Documentation for CFFI
python-constantly-15.1.0-1.mga6.noarch.rpm Python 2 library for symbolic constants
python-cryptography-2.3.1-1.mga6.i586.rpm PyCA's cryptography library
python-cryptography-vectors-2.3.1-1.mga6.noarch.rpm Test vectors for the cryptography package
Advertisement
Advertisement