rpm-build-4.13.0.2-3.1.mga6.i586.rpm


Advertisement

Description

rpm-build - Scripts and executable programs used to build packages

Property Value
Distribution Mageia 6.0
Repository Mageia Core Updates i586
Package name rpm-build
Package version 4.13.0.2
Package release 3.1.mga6
Package architecture i586
Package type rpm
Installed size 399.50 KB
Download size 158.75 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The rpm-build package contains the scripts and executable programs
that are used to build packages using the RPM Package Manager.

Alternatives

Package Version Architecture Repository
rpm-build-4.13.1-3.2.mga6.i586.rpm 4.13.1 i586 Mageia Core Updates
rpm-build-4.13.1-3.2.mga6.x86_64.rpm 4.13.1 x86_64 Mageia Core Updates
rpm-build-4.13.0.2-3.1.mga6.x86_64.rpm 4.13.0.2 x86_64 Mageia Core Updates
rpm-build-4.13.0.1-3.1.mga6.x86_64.rpm 4.13.0.1 x86_64 Mageia Core Updates
rpm-build-4.13.0.1-3.1.mga6.i586.rpm 4.13.0.1 i586 Mageia Core Updates
rpm-build-4.13.0.1-3.mga6.i586.rpm 4.13.0.1 i586 Mageia Core
rpm-build-4.13.0.1-3.mga6.x86_64.rpm 4.13.0.1 x86_64 Mageia Core
rpm-build - - -

Requires

Name Value
autoconf -
automake -
elfutils >= 0.167-2
file -
gcc-c++ -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.17) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.8) -
libelf.so.1 -
libelf.so.1(ELFUTILS_1.0) -
libpopt.so.0 -
libpopt.so.0(LIBPOPT_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
librpm.so.7 -
librpmbuild.so.7 -
librpmbuild7 == 1:4.13.0.2
librpmio.so.7 -
libtool-base -
make -
patch -
perl(CPAN::Meta) >= 2.112.150
perl(ExtUtils::MakeMaker) >= 6.570_700
perl(YAML::Tiny) -
perl-base >= 2:5.22.3
python(abi) -
rpm == 1:4.13.0.2-3.1.mga6
rpm-mageia-setup-build >= 1.34
tar -
unzip -

Provides

Name Value
rpm-build == 1:4.13.0.2-3.1.mga6
rpm-build(x86-32) == 1:4.13.0.2-3.1.mga6

Download

Type URL
Binary Package rpm-build-4.13.0.2-3.1.mga6.i586.rpm
Source Package rpm-4.13.0.2-3.1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install rpm-build rpm package:
    # urpmi rpm-build

Files

Path
/usr/bin/rpmbuild
/usr/bin/rpmspec
/usr/lib/rpm/appdata.prov
/usr/lib/rpm/brp-compress
/usr/lib/rpm/brp-java-gcjcompile
/usr/lib/rpm/brp-python-bytecompile
/usr/lib/rpm/brp-python-hardlink
/usr/lib/rpm/brp-strip
/usr/lib/rpm/brp-strip-comment-note
/usr/lib/rpm/brp-strip-shared
/usr/lib/rpm/brp-strip-static-archive
/usr/lib/rpm/check-buildroot
/usr/lib/rpm/check-files
/usr/lib/rpm/check-prereqs
/usr/lib/rpm/check-rpaths
/usr/lib/rpm/check-rpaths-worker
/usr/lib/rpm/debugedit
/usr/lib/rpm/desktop-file.prov
/usr/lib/rpm/find-debuginfo.sh
/usr/lib/rpm/find-lang.sh
/usr/lib/rpm/find-provides
/usr/lib/rpm/find-requires
/usr/lib/rpm/fontconfig.prov
/usr/lib/rpm/libtooldeps.sh
/usr/lib/rpm/macros.perl
/usr/lib/rpm/macros.php
/usr/lib/rpm/macros.python
/usr/lib/rpm/mono-find-provides
/usr/lib/rpm/mono-find-requires
/usr/lib/rpm/ocaml-find-provides.sh
/usr/lib/rpm/ocaml-find-requires.sh
/usr/lib/rpm/perl.prov
/usr/lib/rpm/perl.req
/usr/lib/rpm/pkgconfigdeps.sh
/usr/lib/rpm/pythondeps.sh
/usr/lib/rpm/pythondistdeps.py
/usr/lib/rpm/pythondistdeps.pyc
/usr/lib/rpm/pythondistdeps.pyo
/usr/lib/rpm/rpmdeps
/usr/lib/rpm/sepdebugcrcfix
/usr/share/doc/rpm-build/CHANGES
/usr/share/doc/rpm-build/builddependencies
/usr/share/doc/rpm-build/buildroot
/usr/share/doc/rpm-build/conditionalbuilds
/usr/share/doc/rpm-build/dependencies
/usr/share/doc/rpm-build/format
/usr/share/doc/rpm-build/hregions
/usr/share/doc/rpm-build/macros
/usr/share/doc/rpm-build/multiplebuilds
/usr/share/doc/rpm-build/queryformat
/usr/share/doc/rpm-build/relocatable
/usr/share/doc/rpm-build/signatures
/usr/share/doc/rpm-build/spec
/usr/share/doc/rpm-build/triggers
/usr/share/doc/rpm-build/tsort
/usr/share/man/man8/rpmbuild.8.xz
/usr/share/man/man8/rpmdeps.8.xz
/usr/share/man/man8/rpmspec.8.xz

Changelog

See rpm-4.13.0.2-3.1.mga6.i586.rpm changelog.

See Also

Package Description
rpm-mageia-setup-2.20-9.1.mga6.i586.rpm The Mageia rpm configuration and scripts
rpm-mageia-setup-2.20.1-1.mga6.i586.rpm The Mageia rpm configuration and scripts
rpm-mageia-setup-build-2.20-9.1.mga6.i586.rpm The Mageia rpm configuration and scripts to build rpms
rpm-mageia-setup-build-2.20.1-1.mga6.i586.rpm The Mageia rpm configuration and scripts to build rpms
rpm-sign-4.13.0.1-3.1.mga6.i586.rpm Package signing support
rpm-sign-4.13.0.2-3.1.mga6.i586.rpm Package signing support
rpm-sign-4.13.1-3.2.mga6.i586.rpm Package signing support
rpmlint-mageia-policy-0.2.29-2.1.mga6.noarch.rpm Rpmlint policy for Mageia
rsync-3.1.2-1.1.mga6.i586.rpm A program for synchronizing files over a network
rsync-3.1.2-1.2.mga6.i586.rpm A program for synchronizing files over a network
rsync-3.1.2-1.3.mga6.i586.rpm A program for synchronizing files over a network
ruby-2.2.7-1.mga6.i586.rpm Object Oriented Script Language
ruby-2.2.8-1.1.mga6.i586.rpm Object Oriented Script Language
ruby-2.2.8-1.mga6.i586.rpm Object Oriented Script Language
ruby-RubyGems-2.4.8-7.1.mga6.noarch.rpm Ruby package manager
Advertisement
Advertisement