libubsan-devel-5.5.0-2.mga6.i586.rpm


Advertisement

Description

libubsan-devel - The Undefined Behaviour Sanitizer runtime library devel files

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates Testing i586
Package filename libubsan-devel-5.5.0-2.mga6.i586.rpm
Package name libubsan-devel
Package version 5.5.0
Package release 2.mga6
Package architecture i586
Package type rpm
Category Development/C
Homepage http://gcc.gnu.org/
License GPLv3+
Maintainer -
Download size 534.63 KB
Installed size 2.08 MB
This package contains the devel files for Undefined Behaviour Sanitizer
library which is used for -fsanitize=undefined instrumented programs.

Alternatives

Package Version Architecture Repository
libubsan-devel-5.5.0-2.mga6.x86_64.rpm 5.5.0 x86_64 Mageia Core Updates Testing
libubsan-devel-5.5.0-1.mga6.i586.rpm 5.5.0 i586 Mageia Core Updates
libubsan-devel-5.5.0-1.mga6.x86_64.rpm 5.5.0 x86_64 Mageia Core Updates
libubsan-devel-5.4.0-5.mga6.i586.rpm 5.4.0 i586 Mageia Core
libubsan-devel-5.4.0-5.mga6.x86_64.rpm 5.4.0 x86_64 Mageia Core
libubsan-devel - - -

Requires

Name Value
devel(libdl) -
devel(libgcc_s) -
devel(libm) -
devel(libstdc++) -
libubsan0 == 5.5.0-2.mga6

Provides

Name Value
devel(libubsan) -
libubsan-devel == 5.5.0-2.mga6
libubsan-devel(x86-32) == 5.5.0-2.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libubsan-devel-5.5.0-2.mga6.i586.rpm
Source Package gcc-5.5.0-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates Testing repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libubsan-devel rpm package:
    # urpmi libubsan-devel

Files

Path
/usr/lib/libubsan.a
/usr/lib/libubsan.so

Changelog

2018-09-11 - tmb <tmb> 5.5.0-2.mga6
(not released yet)
+ Revision: 1258482
- fix c++ ICE in verify_ctor_sanity when compiling chromium (mga#23554)
* Use VECTOR_TYPE_P
* PR c++/70386: Handle PMFs
* PR c++/70501: Handle VECTOR_TYPE similarly to PMF
- add retpoline support (backport provided by H.J Lu)
- update to 5.5.0
2017-07-01 - tmb <tmb> 5.4.0-5.mga6
+ Revision: 1108810
- add Mageia branding (requested by Remi on dev@ ml)
2017-05-13 - tmb <tmb> 5.4.0-4.mga6
+ Revision: 1100979
- more miscompilation and ICE fixes from upstream gcc-5 branch
2017-04-26 - tmb <tmb> 5.4.0-3.mga6
+ Revision: 1097540
- more fixes from upstream gcc-5 branch
2017-03-26 - tmb <tmb> 5.4.0-2.mga6
+ Revision: 1094890
- add regression, miscompilation and ICE fixes from upstream gcc-5 branch
- Support exception propagation without lock-free atomic int
2016-06-03 - tmb <tmb> 5.4.0-1.mga6
+ Revision: 1020173
- update to 5.4.0 final
2016-05-29 - tmb <tmb> 5.4.0-0.RC.1.mga6
+ Revision: 1019344
- update to 5.4.0-RC
+ tv <tv>
- fix error on uninstalling gcc-doc
2016-05-05 - tmb <tmb> 5.3.1-0.20160503.1.mga6
+ Revision: 1009624
- update to 2016-05-03 snapshot
2016-04-20 - tmb <tmb> 5.3.1-0.20160419.1.mga6
+ Revision: 1003817
- update to 2016-04-19
+ pterjan <pterjan>
- Add flags for armv7hl
2016-04-06 - tmb <tmb> 5.3.1-0.20160405.1.mga6
+ Revision: 999024
- update to 2016-04-05

See Also

Package Description
libubsan0-5.5.0-2.mga6.i586.rpm The Undefined Behaviour Sanitizer runtime library
libudev-devel-230-12.4.mga6.i586.rpm udev library development files
libudev1-230-12.4.mga6.i586.rpm udev library package
libuv-devel-1.16.1-1.mga6.i586.rpm Development libraries for libuv
libuv-static-devel-1.16.1-1.mga6.i586.rpm Platform layer for node.js - static library
libuv1-1.16.1-1.mga6.i586.rpm Platform layer for node.js
libvisio-devel-0.1.6-1.mga6.i586.rpm Development files for libvisio
libvisio-doc-0.1.6-1.mga6.noarch.rpm Documentation of libvisio API
libvisio-tools-0.1.6-1.mga6.i586.rpm Tools to transform Microsoft Visio diagrams into other formats
libvisio0.1_1-0.1.6-1.mga6.i586.rpm A library for import of Microsoft Visio diagrams
libvtv-devel-5.5.0-2.mga6.i586.rpm The Virtual Table Verification runtime library devel files
libvtv0-5.5.0-2.mga6.i586.rpm The Virtual Table Verification runtime libraries
libwbclient-devel-4.7.12-1.2.mga6.i586.rpm Developer tools for the winbind library
libwbclient0-4.7.12-1.2.mga6.i586.rpm The winbind client library
libwebkit2-devel-2.22.2-1.1.mga6.i586.rpm Development files for WebKit GTK+ port
Advertisement
Advertisement