nodejs-devel-6.17.1-6.mga6.x86_64.rpm


Advertisement

Description

nodejs-devel - JavaScript runtime - development headers

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates Testing x86_64
Package filename nodejs-devel-6.17.1-6.mga6.x86_64.rpm
Package name nodejs-devel
Package version 6.17.1
Package release 6.mga6
Package architecture x86_64
Package type rpm
Category Development/Other
Homepage http://nodejs.org/
License MIT and ASL 2.0 and ISC and BSD
Maintainer -
Download size 5.05 MB
Installed size 19.05 MB
Development headers for the Node.js JavaScript runtime.

Alternatives

Package Version Architecture Repository
nodejs-devel-6.17.1-6.mga6.i586.rpm 6.17.1 i586 Mageia Core Updates Testing
nodejs-devel-6.10.3-2.mga6.i586.rpm 6.10.3 i586 Mageia Core
nodejs-devel-6.10.3-2.mga6.x86_64.rpm 6.10.3 x86_64 Mageia Core
nodejs-devel - - -

Requires

Name Value
http-parser-devel(x86-64) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcrypto.so.1.0.0()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libhttp_parser.so.2()(64bit) -
libicudata.so.58()(64bit) -
libicui18n.so.58()(64bit) -
libicuuc.so.58()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libssl.so.1.0.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.10)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libuv-devel(x86-64) -
libuv.so.1()(64bit) -
libz.so.1()(64bit) -
nodejs(x86-64) == 1:6.17.1
nodejs-packaging -
openssl-devel(x86-64) -
zlib-devel(x86-64) -

Provides

Name Value
nodejs-devel == 1:6.17.1-6.mga6
nodejs-devel(x86-64) == 1:6.17.1-6.mga6

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package nodejs-devel-6.17.1-6.mga6.x86_64.rpm
Source Package nodejs-6.17.1-6.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates Testing repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install nodejs-devel rpm package:
    # urpmi nodejs-devel

Files

Path
/usr/bin/node_g
/usr/include/node/ares.h
/usr/include/node/ares_build.h
/usr/include/node/ares_rules.h
/usr/include/node/ares_version.h
/usr/include/node/common.gypi
/usr/include/node/config.gypi
/usr/include/node/nameser.h
/usr/include/node/node.h
/usr/include/node/node_api.h
/usr/include/node/node_api_types.h
/usr/include/node/node_buffer.h
/usr/include/node/node_object_wrap.h
/usr/include/node/node_version.h
/usr/include/node/v8-debug.h
/usr/include/node/v8-experimental.h
/usr/include/node/v8-platform.h
/usr/include/node/v8-profiler.h
/usr/include/node/v8-testing.h
/usr/include/node/v8-util.h
/usr/include/node/v8-version.h
/usr/include/node/v8.h
/usr/include/node/v8config.h
/usr/include/node/libplatform/libplatform.h
/usr/share/doc/nodejs-3.10.10/gdbinit
/usr/share/node/common.gypi

Changelog

2019-05-09 - kekepower <kekepower> 1:6.17.1-6.mga6
+ Revision: 1396966
- Second try at fixing installation issue
- Hopefully fix the issue of not being able to install
- Fix bogus release tag for npm
- Fix npm release version
- Update to version 6.17.1
- Fixes several security issues (mga#21330)
+ neoclust <neoclust>
- New LTS version 6.11.2
- Try to rebuild to make it instalable
- Fix release to install smoothly
- Rebuild with fixed release
- Do not use %mkrel
- Rebuild with fixed deps
- Relax requires
- New version v6.11.1
2017-05-05 - neoclust <neoclust> 1:6.10.3-2.mga6
+ Revision: 1099146
- Rebuild because of missing package
2017-05-04 - neoclust <neoclust> 1:6.10.3-1.mga6
+ Revision: 1099118
- New version 6.10.3 (LTS)
2017-05-04 - neoclust <neoclust> 1:6.10.2-1.mga6
+ Revision: 1099101
- New version v6.10.2 ( LTS )
- New version 6.9.2
2017-03-15 - mrambo3501 <mrambo3501> 1:6.9.1-3.mga6
+ Revision: 1092754
- Rebuild for icu-58.2
2016-12-11 - ngompa <ngompa> 1:6.9.1-2.mga6
+ Revision: 1074259
- Convert %pretrans to Lua
2016-11-12 - shlomif <shlomif> 1:6.9.1-1.mga6
+ Revision: 1066886
- New stable version v6.9.1.
2016-09-08 - luigiwalser <luigiwalser> 1:4.5.0-1.mga6
+ Revision: 1050787
- 4.5.0 (sync with f24)
- split npm into a subpackage
- build Node.js with internationalization support
2016-05-25 - neoclust <neoclust> 1:4.4.4-3.mga6
+ Revision: 1018324
- Rebuild for ARM
2016-05-17 - tv <tv> 1:4.4.4-2.mga6
+ Revision: 1016533
- fix upgrade

See Also

Package Description
nodejs-docs-6.17.1-5.mga6.noarch.rpm Node.js API documentation
nodejs-docs-6.17.1-6.mga6.noarch.rpm Node.js API documentation
nodejs-fs.realpath-1.0.0-2.mga6.noarch.rpm Use node's fs
nodejs-js-yaml-3.13.1-1.mga6.noarch.rpm YAML 1.2 parser and serializer
npm-3.10.10-6.mga6.x86_64.rpm Node.js Package Manager
nss-myhostname-230-12.4.mga6.x86_64.rpm systemd provided glibc plugin for local system host name resolution
null-12-65.mga6.x86_64.rpm A dummy package for bs testing purpose
null-dummy6-12-65.mga6.x86_64.rpm Test package
openshot-qt-2.4.0-1.mga6.noarch.rpm Simple and Powerful video editor
p7zip-16.02-2.2.mga6.x86_64.rpm 7-zip compatible compression program
pango-1.40.6-1.1.mga6.x86_64.rpm System for layout and rendering of internationalized text
pango-doc-1.40.6-1.1.mga6.noarch.rpm GObject Introspection interface description for pango
pango-tests-1.40.6-1.1.mga6.x86_64.rpm Tests for the pango package
perl-Archive-Tar-2.280.0-1.mga6.noarch.rpm Module for manipulation of tar archives
perl-Config-Identity-0.1.900-1.mga6.noarch.rpm Load (and optionally decrypt via GnuPG) user/pass identity information
Advertisement
Advertisement