lib64cups2-devel-2.2.6-1.mga6.x86_64.rpm


Advertisement

Description

lib64cups2-devel - CUPS printing system - Development environment "libcups"

Property Value
Distribution Mageia 6.0
Repository Mageia Core Updates x86_64
Package name lib64cups2-devel
Package version 2.2.6
Package release 1.mga6
Package architecture x86_64
Package type rpm
Installed size 200.71 KB
Download size 53.51 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The CUPS printing system provides a portable printing layer for
UNIX(TM) operating systems. This is the development package for
creating additional printer drivers, printing software, and other CUPS
services using the main CUPS library "libcups".

Alternatives

Package Version Architecture Repository
lib64cups2-devel-2.2.4-1.mga6.x86_64.rpm 2.2.4 x86_64 Mageia Core Updates
lib64cups2-devel-2.2.3-2.mga6.x86_64.rpm 2.2.3 x86_64 Mageia Core
lib64cups2-devel - - -

Requires

Name Value
cups-common == 2.2.6-1.mga6
devel(libavahi-client(64bit)) -
devel(libavahi-common(64bit)) -
devel(libcups(64bit)) -
devel(libgcc_s(64bit)) -
devel(libgnutls(64bit)) -
devel(libgssapi_krb5(64bit)) -
devel(libm(64bit)) -
devel(libstdc++(64bit)) -
devel(libz(64bit)) -
gnutls-devel -
lib64cups2 >= 2.2.6-1.mga6
libgnutls-devel -
multiarch-utils -

Provides

Name Value
cups-devel == 2.2.6
devel(libcups(64bit)) -
devel(libcupscgi(64bit)) -
devel(libcupsimage(64bit)) -
devel(libcupsmime(64bit)) -
devel(libcupsppdc(64bit)) -
lib64cups2-devel == 2.2.6-1.mga6
lib64cups2-devel(x86-64) == 2.2.6-1.mga6
libcups-devel == 2.2.6-1.mga6
libcups1-devel == 2.2.6
libcups2_1-devel == 2.2.6-1.mga6

Obsoletes

Name Value
cups-devel -
libcups1-devel -

Download

Type URL
Binary Package lib64cups2-devel-2.2.6-1.mga6.x86_64.rpm
Source Package cups-2.2.6-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64cups2-devel rpm package:
    # urpmi lib64cups2-devel

Files

Path
/usr/bin/cups-config
/usr/include/cups/adminutil.h
/usr/include/cups/array.h
/usr/include/cups/backend.h
/usr/include/cups/config.h
/usr/include/cups/cups.h
/usr/include/cups/debug-private.h
/usr/include/cups/dir.h
/usr/include/cups/file.h
/usr/include/cups/http.h
/usr/include/cups/ipp.h
/usr/include/cups/language.h
/usr/include/cups/ppd.h
/usr/include/cups/pwg.h
/usr/include/cups/raster.h
/usr/include/cups/sidechannel.h
/usr/include/cups/string-private.h
/usr/include/cups/transcode.h
/usr/include/cups/versioning.h
/usr/include/multiarch-x86_64-linux/cups/config.h
/usr/lib/rpm/macros.d/macros.cups
/usr/lib64/libcups.so
/usr/lib64/libcupscgi.so
/usr/lib64/libcupsimage.so
/usr/lib64/libcupsmime.so
/usr/lib64/libcupsppdc.so

Changelog

See cups-2.2.6-1.mga6.x86_64.rpm changelog.

See Also

Package Description
lib64curl-devel-7.54.1-2.2.mga6.x86_64.rpm Header files and static libraries for libcurl
lib64curl-devel-7.54.1-2.4.mga6.x86_64.rpm Header files and static libraries for libcurl
lib64curl-devel-7.54.1-2.5.mga6.x86_64.rpm Header files and static libraries for libcurl
lib64curl4-7.54.1-2.2.mga6.x86_64.rpm A library of functions for file transfer
lib64curl4-7.54.1-2.4.mga6.x86_64.rpm A library of functions for file transfer
lib64curl4-7.54.1-2.5.mga6.x86_64.rpm A library of functions for file transfer
lib64d3d1-17.1.5-1.mga6.x86_64.rpm Mesa Direct3D9 state tracker
lib64d3d1-17.3.2-1.1.mga6.x86_64.rpm Mesa Direct3D9 state tracker
lib64d3d1-17.3.6-1.mga6.x86_64.rpm Mesa Direct3D9 state tracker
lib64d3d1-17.3.9-1.mga6.x86_64.rpm Mesa Direct3D9 state tracker
lib64d3d1-devel-17.1.5-1.mga6.x86_64.rpm Development files for Mesa Direct3D9 state tracker
lib64d3d1-devel-17.3.2-1.1.mga6.x86_64.rpm Development files for Mesa Direct3D9 state tracker
lib64d3d1-devel-17.3.6-1.mga6.x86_64.rpm Development files for Mesa Direct3D9 state tracker
lib64d3d1-devel-17.3.9-1.mga6.x86_64.rpm Development files for Mesa Direct3D9 state tracker
lib64db4.8-4.8.30-21.1.mga6.x86_64.rpm The Berkeley DB database library for C
Advertisement
Advertisement