lib64dbcxx4.8-4.8.30-21.1.mga6.x86_64.rpm


Advertisement

Description

lib64dbcxx4.8 - The Berkeley DB database library for C++

Property Value
Distribution Mageia 6.0
Repository Mageia Core Updates x86_64
Package name lib64dbcxx4.8
Package version 4.8.30
Package release 21.1.mga6
Package architecture x86_64
Package type rpm
Installed size 1.64 MB
Download size 601.36 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
embedded database support for both traditional and client/server applications.
Berkeley DB is used by many applications, including Python and Perl, so this
should be installed on all systems.
This package contains the files needed to build C++ programs which use
Berkeley DB.

Alternatives

Package Version Architecture Repository
lib64dbcxx4.8-4.8.30-21.mga6.x86_64.rpm 4.8.30 x86_64 Mageia Core
lib64dbcxx4.8 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
lib64dbcxx4.8 == 4.8.30-21.1.mga6
lib64dbcxx4.8(x86-64) == 4.8.30-21.1.mga6
libdb_cxx-4.8.so()(64bit) -

Download

Type URL
Binary Package lib64dbcxx4.8-4.8.30-21.1.mga6.x86_64.rpm
Source Package db48-4.8.30-21.1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64dbcxx4.8 rpm package:
    # urpmi lib64dbcxx4.8

Files

Path
/usr/lib64/libdb_cxx-4.8.so

Changelog

2017-08-12 - luigiwalser <luigiwalser> 4.8.30-21.1.mga6
+ Revision: 1139866
- add patch to fix security issue mga#21203
2016-02-11 - umeabot <umeabot> 4.8.30-21.mga6
+ Revision: 953657
- Mageia 6 Mass Rebuild
2015-10-03 - shlomif <shlomif> 4.8.30-20.mga6
+ Revision: 885925
- Rebuild for the new tcl
2015-10-03 - sander85 <sander85> 4.8.30-19.mga6
+ Revision: 885905
- Rebuild for tcl 8.6.4
2014-11-30 - sander85 <sander85> 4.8.30-18.mga5
+ Revision: 800091
- Disable java
2014-10-31 - pterjan <pterjan> 4.8.30-17.mga5
+ Revision: 794869
- Drop no longer needed BuildRequires on java-rpmbuild
2014-10-15 - umeabot <umeabot> 4.8.30-16.mga5
+ Revision: 745755
- Second Mageia 5 Mass Rebuild
2014-09-18 - umeabot <umeabot> 4.8.30-15.mga5
+ Revision: 693728
- Rebuild to fix library dependencies
2014-09-16 - umeabot <umeabot> 4.8.30-14.mga5
+ Revision: 678678
- Mageia 5 Mass Rebuild

See Also

Package Description
lib64dbcxx5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for C++
lib64dbjava5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for C++
lib64dbnss4.8-4.8.30-21.1.mga6.x86_64.rpm The Berkeley DB database library for NSS modules
lib64dbnss4.8-devel-4.8.30-21.1.mga6.x86_64.rpm Development libraries/header files for building nss modules with Berkeley DB
lib64dbnss5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for NSS modules
lib64dbnss5.3-devel-5.3.28-10.1.mga6.x86_64.rpm Development libraries/header files for building nss modules with Berkeley DB
lib64dbsql5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for SQL
lib64dbtcl4.8-4.8.30-21.1.mga6.x86_64.rpm The Berkeley DB database library for TCL
lib64dbtcl5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for TCL
lib64dbus-gir1.0-1.54.1-1.mga6.x86_64.rpm GObject Introspection interface description for dbus
lib64dbusglib-gir1.0-1.54.1-1.mga6.x86_64.rpm GObject Introspection interface description for dbusglib
lib64digidocpp-devel-3.13.2-1.mga6.x86_64.rpm Development files for libdigidocpp
lib64digidocpp1-3.13.2-1.mga6.x86_64.rpm Library for creating and validating bdoc and ddoc containers
lib64digikam-devel-5.5.0-2.1.mga6.x86_64.rpm Static libraries and headers for digikam
lib64digikam-devel-5.9.0-1.mga6.x86_64.rpm Static libraries and headers for digikam
Advertisement
Advertisement