lib64dbcxx5.3-5.3.28-10.1.mga6.x86_64.rpm


Advertisement

Description

lib64dbcxx5.3 - The Berkeley DB database library for C++

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package name lib64dbcxx5.3
Package version 5.3.28
Package release 10.1.mga6
Package architecture x86_64
Package type rpm
Installed size 1.91 MB
Download size 712.34 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
embedded database support for both traditional and client/server applications.
Berkeley DB is used by many applications, including Python and Perl, so this
should be installed on all systems.
This package contains the files needed to build C++ programs which use
Berkeley DB.

Alternatives

Package Version Architecture Repository
lib64dbcxx5.3-5.3.28-10.mga6.x86_64.rpm 5.3.28 x86_64 Mageia Core
lib64dbcxx5.3 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
lib64dbcxx5.3 == 5.3.28-10.1.mga6
lib64dbcxx5.3(x86-64) == 5.3.28-10.1.mga6
libdb_cxx-5.3.so()(64bit) -

Download

Type URL
Binary Package lib64dbcxx5.3-5.3.28-10.1.mga6.x86_64.rpm
Source Package db53-5.3.28-10.1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64dbcxx5.3 rpm package:
    # urpmi lib64dbcxx5.3

Files

Path
/usr/lib64/libdb_cxx-5.3.so

Changelog

2017-08-11 - neoclust <neoclust> 5.3.28-10.1.mga6
+ Revision: 1139843
- Add P102 (mga#21203)
2016-03-23 - blino <blino> 5.3.28-10.mga6
+ Revision: 994683
- rebuild on arm
2016-03-02 - neoclust <neoclust> 5.3.28-9.mga6
+ Revision: 981756
- Rebuild on java8
+ blino <blino>
- buildrequire ant for com.sleepycat.persist javadoc (suggested by neoclust)
+ umeabot <umeabot>
- Mageia 6 Mass Rebuild
2015-10-11 - blino <blino> 5.3.28-7.mga6
+ Revision: 889441
- add systemtap conditional flag (to boostrap and avoid cycle: db53 -> systemtap -> rpm-devel -> db53)
2015-10-03 - tv <tv> 5.3.28-6.mga6
+ Revision: 885849
- rebuild for new tcl
2015-08-21 - tmb <tmb> 5.3.28-5.mga6
+ Revision: 867563
- rebuild for new gcc
+ pterjan <pterjan>
- Fix arm build
2014-10-20 - cjw <cjw> 5.3.28-4.mga5
+ Revision: 792173
- fix build with jdk 1.8
+ umeabot <umeabot>
- Second Mageia 5 Mass Rebuild
- Rebuild to fix library dependencies
- Mageia 5 Mass Rebuild

See Also

Package Description
lib64dbjava5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for C++
lib64dbnss4.8-4.8.30-21.1.mga6.x86_64.rpm The Berkeley DB database library for NSS modules
lib64dbnss4.8-devel-4.8.30-21.1.mga6.x86_64.rpm Development libraries/header files for building nss modules with Berkeley DB
lib64dbnss5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for NSS modules
lib64dbnss5.3-devel-5.3.28-10.1.mga6.x86_64.rpm Development libraries/header files for building nss modules with Berkeley DB
lib64dbsql5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for SQL
lib64dbtcl4.8-4.8.30-21.1.mga6.x86_64.rpm The Berkeley DB database library for TCL
lib64dbtcl5.3-5.3.28-10.1.mga6.x86_64.rpm The Berkeley DB database library for TCL
lib64dbus-gir1.0-1.54.1-1.mga6.x86_64.rpm GObject Introspection interface description for dbus
lib64dbusglib-gir1.0-1.54.1-1.mga6.x86_64.rpm GObject Introspection interface description for dbusglib
lib64digidocpp-devel-3.13.2-1.mga6.x86_64.rpm Development files for libdigidocpp
lib64digidocpp1-3.13.2-1.mga6.x86_64.rpm Library for creating and validating bdoc and ddoc containers
lib64digikam-devel-5.5.0-2.1.mga6.x86_64.rpm Static libraries and headers for digikam
lib64digikam-devel-5.9.0-1.mga6.x86_64.rpm Static libraries and headers for digikam
lib64digikamcore5-5.5.0-2.1.mga6.x86_64.rpm Runtime library for digikam
Advertisement
Advertisement