lib64samba-devel-4.6.16-1.mga6.x86_64.rpm


Advertisement

Description

lib64samba-devel - Developer tools for Samba libraries

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package filename lib64samba-devel-4.6.16-1.mga6.x86_64.rpm
Package name lib64samba-devel
Package version 4.6.16
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage http://www.samba.org/
License GPLv3+ and LGPLv3+
Maintainer -
Download size 213.39 KB
Installed size 1.43 MB
The samba4-devel package contains the header files for the libraries
needed to develop programs that link against the SMB, RPC and other
libraries in the Samba suite.

Alternatives

Package Version Architecture Repository
lib64samba-devel-4.7.12-1.2.mga6.x86_64.rpm 4.7.12 x86_64 Mageia Core Updates
lib64samba-devel-4.7.12-1.1.mga6.x86_64.rpm 4.7.12 x86_64 Mageia Core Updates
lib64samba-devel-4.6.12-1.1.mga6.x86_64.rpm 4.6.12 x86_64 Mageia Core Updates
lib64samba-devel-4.6.12-1.mga6.x86_64.rpm 4.6.12 x86_64 Mageia Core Updates
lib64samba-devel-4.6.7-1.mga6.x86_64.rpm 4.6.7 x86_64 Mageia Core Updates
lib64samba-devel-4.6.5-1.mga6.x86_64.rpm 4.6.5 x86_64 Mageia Core
lib64samba-devel - - -

Requires

Name Value
devel(libcap(64bit)) -
devel(libdcerpc(64bit)) -
devel(libdcerpc-binding(64bit)) -
devel(libgnutls(64bit)) -
devel(liblber-2.4(64bit)) -
devel(libldap-2.4(64bit)) -
devel(libldb(64bit)) -
devel(libndr(64bit)) -
devel(libndr-nbt(64bit)) -
devel(libndr-standard(64bit)) -
devel(libnsl(64bit)) -
devel(libsamba-credentials(64bit)) -
devel(libsamba-errors(64bit)) -
devel(libsamba-hostconfig(64bit)) -
devel(libsamba-passdb(64bit)) -
devel(libsamba-util(64bit)) -
devel(libsamdb(64bit)) -
devel(libsmbconf(64bit)) -
devel(libsystemd(64bit)) -
devel(libtalloc(64bit)) -
devel(libtdb(64bit)) -
devel(libtevent(64bit)) -
devel(libtevent-util(64bit)) -
devel(libwbclient(64bit)) -
lib64samba1 == 4.6.16-1.mga6
pkgconfig -
pkgconfig(dcerpc) -
pkgconfig(ldb) -
pkgconfig(ndr) -
pkgconfig(samba-util) -
pkgconfig(talloc) -
pkgconfig(tevent) -

Provides

Name Value
devel(libdcerpc(64bit)) -
devel(libdcerpc-binding(64bit)) -
devel(libdcerpc-samr(64bit)) -
devel(libdcerpc-server(64bit)) -
devel(libndr(64bit)) -
devel(libndr-krb5pac(64bit)) -
devel(libndr-nbt(64bit)) -
devel(libndr-standard(64bit)) -
devel(libnetapi(64bit)) -
devel(libsamba-credentials(64bit)) -
devel(libsamba-errors(64bit)) -
devel(libsamba-hostconfig(64bit)) -
devel(libsamba-passdb(64bit)) -
devel(libsamba-policy(64bit)) -
devel(libsamba-util(64bit)) -
devel(libsamdb(64bit)) -
devel(libsmbconf(64bit)) -
devel(libsmbldap(64bit)) -
devel(libtevent-util(64bit)) -
lib64samba-devel == 4.6.16-1.mga6
lib64samba-devel(x86-64) == 4.6.16-1.mga6
libsamba-devel == 4.6.16-1.mga6
pkgconfig(dcerpc) == 0.0.1
pkgconfig(dcerpc_samr) == 0.0.1
pkgconfig(dcerpc_server) == 0.0.1
pkgconfig(ndr) == 0.0.8
pkgconfig(ndr_krb5pac) == 0.0.1
pkgconfig(ndr_nbt) == 0.0.1
pkgconfig(ndr_standard) == 0.0.1
pkgconfig(netapi) == 0
pkgconfig(samba-credentials) == 0.0.1
pkgconfig(samba-hostconfig) == 0.0.1
pkgconfig(samba-policy) == 0.0.1
pkgconfig(samba-util) == 0.0.1
pkgconfig(samdb) == 0.0.1
samba-devel == 4.6.16-1.mga6

Obsoletes

Name Value
lib64samba4-devel < 4.1.17-11

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64samba-devel-4.6.16-1.mga6.x86_64.rpm
Source Package samba-4.6.16-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64samba-devel rpm package:
    # urpmi lib64samba-devel

Files

Path
/usr/include/samba-4.0/charset.h
/usr/include/samba-4.0/credentials.h
/usr/include/samba-4.0/dcerpc.h
/usr/include/samba-4.0/dcerpc_server.h
/usr/include/samba-4.0/domain_credentials.h
/usr/include/samba-4.0/ldb_wrap.h
/usr/include/samba-4.0/lookup_sid.h
/usr/include/samba-4.0/machine_sid.h
/usr/include/samba-4.0/ndr.h
/usr/include/samba-4.0/netapi.h
/usr/include/samba-4.0/param.h
/usr/include/samba-4.0/passdb.h
/usr/include/samba-4.0/policy.h
/usr/include/samba-4.0/rpc_common.h
/usr/include/samba-4.0/share.h
/usr/include/samba-4.0/smb2_lease_struct.h
/usr/include/samba-4.0/smb_ldap.h
/usr/include/samba-4.0/smbconf.h
/usr/include/samba-4.0/smbldap.h
/usr/include/samba-4.0/tdr.h
/usr/include/samba-4.0/tsocket.h
/usr/include/samba-4.0/tsocket_internal.h
/usr/include/samba-4.0/util_ldb.h
/usr/include/samba-4.0/core/doserr.h
/usr/include/samba-4.0/core/error.h
/usr/include/samba-4.0/core/hresult.h
/usr/include/samba-4.0/core/ntstatus.h
/usr/include/samba-4.0/core/werror.h
/usr/include/samba-4.0/gen_ndr/atsvc.h
/usr/include/samba-4.0/gen_ndr/auth.h
/usr/include/samba-4.0/gen_ndr/dcerpc.h
/usr/include/samba-4.0/gen_ndr/drsblobs.h
/usr/include/samba-4.0/gen_ndr/drsuapi.h
/usr/include/samba-4.0/gen_ndr/krb5pac.h
/usr/include/samba-4.0/gen_ndr/lsa.h
/usr/include/samba-4.0/gen_ndr/misc.h
/usr/include/samba-4.0/gen_ndr/nbt.h
/usr/include/samba-4.0/gen_ndr/ndr_atsvc.h
/usr/include/samba-4.0/gen_ndr/ndr_dcerpc.h
/usr/include/samba-4.0/gen_ndr/ndr_drsblobs.h
/usr/include/samba-4.0/gen_ndr/ndr_drsuapi.h
/usr/include/samba-4.0/gen_ndr/ndr_krb5pac.h
/usr/include/samba-4.0/gen_ndr/ndr_misc.h
/usr/include/samba-4.0/gen_ndr/ndr_nbt.h
/usr/include/samba-4.0/gen_ndr/ndr_samr.h
/usr/include/samba-4.0/gen_ndr/ndr_samr_c.h
/usr/include/samba-4.0/gen_ndr/ndr_svcctl.h
/usr/include/samba-4.0/gen_ndr/ndr_svcctl_c.h
/usr/include/samba-4.0/gen_ndr/netlogon.h
/usr/include/samba-4.0/gen_ndr/samr.h
/usr/include/samba-4.0/gen_ndr/security.h
/usr/include/samba-4.0/gen_ndr/server_id.h
/usr/include/samba-4.0/gen_ndr/svcctl.h
/usr/include/samba-4.0/ndr/ndr_dcerpc.h
/usr/include/samba-4.0/ndr/ndr_drsblobs.h
/usr/include/samba-4.0/ndr/ndr_drsuapi.h
/usr/include/samba-4.0/ndr/ndr_krb5pac.h
/usr/include/samba-4.0/ndr/ndr_nbt.h
/usr/include/samba-4.0/ndr/ndr_svcctl.h
/usr/include/samba-4.0/samba/session.h
/usr/include/samba-4.0/samba/version.h
/usr/include/samba-4.0/util/attr.h
/usr/include/samba-4.0/util/blocking.h
/usr/include/samba-4.0/util/byteorder.h
/usr/include/samba-4.0/util/data_blob.h
/usr/include/samba-4.0/util/debug.h
/usr/include/samba-4.0/util/fault.h
/usr/include/samba-4.0/util/genrand.h
/usr/include/samba-4.0/util/idtree.h
/usr/include/samba-4.0/util/idtree_random.h
/usr/include/samba-4.0/util/memory.h
/usr/include/samba-4.0/util/safe_string.h
/usr/include/samba-4.0/util/signal.h
/usr/include/samba-4.0/util/string_wrappers.h
/usr/include/samba-4.0/util/substitute.h
/usr/include/samba-4.0/util/talloc_stack.h
/usr/include/samba-4.0/util/tevent_ntstatus.h
/usr/include/samba-4.0/util/tevent_unix.h
/usr/include/samba-4.0/util/tevent_werror.h
/usr/include/samba-4.0/util/time.h
/usr/lib64/libdcerpc-binding.so
/usr/lib64/libdcerpc-samr.so
/usr/lib64/libdcerpc-server.so
/usr/lib64/libdcerpc.so
/usr/lib64/libndr-krb5pac.so
/usr/lib64/libndr-nbt.so
/usr/lib64/libndr-standard.so
/usr/lib64/libndr.so
/usr/lib64/libnetapi.so
/usr/lib64/libsamba-credentials.so
/usr/lib64/libsamba-errors.so
/usr/lib64/libsamba-hostconfig.so
/usr/lib64/libsamba-passdb.so
/usr/lib64/libsamba-policy.so
/usr/lib64/libsamba-util.so
/usr/lib64/libsamdb.so
/usr/lib64/libsmbconf.so
/usr/lib64/libsmbldap.so
/usr/lib64/libtevent-util.so
/usr/lib64/pkgconfig/dcerpc.pc
/usr/lib64/pkgconfig/dcerpc_samr.pc
/usr/lib64/pkgconfig/dcerpc_server.pc
/usr/lib64/pkgconfig/ndr.pc
/usr/lib64/pkgconfig/ndr_krb5pac.pc
/usr/lib64/pkgconfig/ndr_nbt.pc
/usr/lib64/pkgconfig/ndr_standard.pc
/usr/lib64/pkgconfig/netapi.pc
/usr/lib64/pkgconfig/samba-credentials.pc
/usr/lib64/pkgconfig/samba-hostconfig.pc
/usr/lib64/pkgconfig/samba-policy.pc
/usr/lib64/pkgconfig/samba-util.pc
/usr/lib64/pkgconfig/samdb.pc

Changelog

2018-10-28 - bcornec <bcornec> 4.6.16-1.mga6
+ Revision: 1326304
- update to upstream samba-4.6.16 to fix mga#23444
+ buchan <buchan>
- Security updates for CVE-2018-1057 and CVE-2018-1050
+ luigiwalser <luigiwalser>
- 4.6.12
- 4.6.8
+ zezinho <zezinho>
- add dummy_client
+ semiletov <semiletov>
- spec update to 4.6.11
+ neoclust <neoclust>
- New version 4.6.7 ( Fixes CVE-2017-11103 (mga#21482)
2017-06-08 - luigiwalser <luigiwalser> 4.6.5-1.mga6
+ Revision: 1107268
- 4.6.5
2017-05-25 - neoclust <neoclust> 4.6.4-1.mga6
+ Revision: 1104505
- New version 4.6.4
2017-05-24 - luigiwalser <luigiwalser> 4.5.10-1.mga6
+ Revision: 1104363
- 4.5.10 (fixes CVE-2017-7494)
2017-05-23 - luigiwalser <luigiwalser> 4.5.9-1.mga6
+ Revision: 1104140
- 4.5.9
2017-03-31 - luigiwalser <luigiwalser> 4.5.8-1.mga6
+ Revision: 1095490
- 4.5.8
2017-03-23 - luigiwalser <luigiwalser> 4.5.7-1.mga6
+ Revision: 1094590
- 4.5.7 (fixes CVE-2017-2619)
- fix permissions of spool directory (mga#20513)
2017-03-14 - luigiwalser <luigiwalser> 4.5.6-1.mga6
+ Revision: 1092515
- 4.5.6
2017-03-12 - wally <wally> 4.5.5-2.mga6
+ Revision: 1092137
- add obsoletes to fix update from mga5 (mga#20456)
2017-01-31 - luigiwalser <luigiwalser> 4.5.5-1.mga6
+ Revision: 1084350
- 4.5.5

See Also

Package Description
lib64samba-test0-4.6.12-1.1.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba-test0-4.6.12-1.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba-test0-4.6.16-1.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba-test0-4.6.7-1.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba-test0-4.7.12-1.1.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba-test0-4.7.12-1.2.mga6.x86_64.rpm Libraries need by teh testing tools for Samba servers and clients
lib64samba1-4.6.12-1.1.mga6.x86_64.rpm Samba libraries
lib64samba1-4.6.12-1.mga6.x86_64.rpm Samba libraries
lib64samba1-4.6.16-1.mga6.x86_64.rpm Samba libraries
lib64samba1-4.6.7-1.mga6.x86_64.rpm Samba libraries
lib64samba1-4.7.12-1.1.mga6.x86_64.rpm Samba libraries
lib64samba1-4.7.12-1.2.mga6.x86_64.rpm Samba libraries
lib64sane-hpaio1-3.17.10-1.mga6.x86_64.rpm SANE driver for scanners in HP's multi-function devices (from HPLIP)
lib64sane-hpaio1-3.19.5-1.mga6.x86_64.rpm SANE driver for scanners in HP's multi-function devices (from HPLIP)
lib64science5-17.12.2-1.mga6.x86_64.rpm Runtime library for KDE Education Application
Advertisement
Advertisement