lib64virt0-3.10.0-1.2.mga6.x86_64.rpm


Advertisement

Description

lib64virt0 - A library to interact with virtualization capabilities

Property Value
Distribution Mageia 6.0
Repository Mageia Core Updates x86_64
Package name lib64virt0
Package version 3.10.0
Package release 1.2.mga6
Package architecture x86_64
Package type rpm
Installed size 4.41 MB
Download size 1.11 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Libvirt is a C toolkit to interact with the virtualization
capabilities of recent versions of Linux.
This package contains the library needed to run programs dynamically
linked with libvirt.

Alternatives

Package Version Architecture Repository
lib64virt0-3.10.0-1.3.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt0-3.10.0-1.1.mga6.x86_64.rpm 3.10.0 x86_64 Mageia Core Updates
lib64virt0-3.3.0-1.mga6.x86_64.rpm 3.3.0 x86_64 Mageia Core
lib64virt0 - - -

Requires

Name Value
libacl.so.1()(64bit) -
libacl.so.1(ACL_1.0)(64bit) -
libaudit.so.1()(64bit) -
libavahi-client.so.3()(64bit) -
libavahi-common.so.3()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.13)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libc.so.6(GLIBC_2.9)(64bit) -
libcap-ng.so.0()(64bit) -
libcrypto.so.1.0.0()(64bit) -
libcurl.so.4()(64bit) -
libdbus-1.so.3()(64bit) -
libdbus-1.so.3(LIBDBUS_1_3)(64bit) -
libdevmapper.so.1.02()(64bit) -
libdevmapper.so.1.02(Base)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3.1)(64bit) -
libgnutls.so.30()(64bit) -
libgnutls.so.30(GNUTLS_3_4)(64bit) -
libintl.so.8()(64bit) -
libnl-3.so.200()(64bit) -
libnl-3.so.200(libnl_3)(64bit) -
libnuma.so.1()(64bit) -
libnuma.so.1(libnuma_1.1)(64bit) -
libnuma.so.1(libnuma_1.2)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libsasl2.so.3()(64bit) -
libssh2.so.1()(64bit) -
libutil.so.1()(64bit) -
libutil.so.1(GLIBC_2.2.5)(64bit) -
libvirt.so.0()(64bit) -
libvirt.so.0(LIBVIRT_0.1.0)(64bit) -
libvirt.so.0(LIBVIRT_0.6.1)(64bit) -
libvirt.so.0(LIBVIRT_PRIVATE_3.10.0)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.5.2)(64bit) -
libxml2.so.2(LIBXML2_2.5.4)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libyajl.so.2()(64bit) -

Provides

Name Value
lib64virt0 == 3.10.0-1.2.mga6
lib64virt0(x86-64) == 3.10.0-1.2.mga6
libvirt-admin.so.0()(64bit) -
libvirt-admin.so.0(LIBVIRT_ADMIN_2.0.0)(64bit) -
libvirt-admin.so.0(LIBVIRT_ADMIN_3.0.0)(64bit) -
libvirt-admin.so.0(LIBVIRT_ADMIN_PRIVATE_3.10.0)(64bit) -
libvirt-lxc.so.0()(64bit) -
libvirt-lxc.so.0(LIBVIRT_LXC_1.0.2)(64bit) -
libvirt-lxc.so.0(LIBVIRT_LXC_1.0.4)(64bit) -
libvirt-lxc.so.0(LIBVIRT_LXC_2.0.0)(64bit) -
libvirt-qemu.so.0()(64bit) -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.10.0)(64bit) -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.8.3)(64bit) -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.9.4)(64bit) -
libvirt-qemu.so.0(LIBVIRT_QEMU_1.2.3)(64bit) -
libvirt.so.0()(64bit) -
libvirt.so.0(LIBVIRT_0.0.3)(64bit) -
libvirt.so.0(LIBVIRT_0.0.5)(64bit) -
libvirt.so.0(LIBVIRT_0.1.0)(64bit) -
libvirt.so.0(LIBVIRT_0.1.1)(64bit) -
libvirt.so.0(LIBVIRT_0.1.4)(64bit) -
libvirt.so.0(LIBVIRT_0.1.5)(64bit) -
libvirt.so.0(LIBVIRT_0.1.9)(64bit) -
libvirt.so.0(LIBVIRT_0.10.0)(64bit) -
libvirt.so.0(LIBVIRT_0.10.2)(64bit) -
libvirt.so.0(LIBVIRT_0.2.0)(64bit) -
libvirt.so.0(LIBVIRT_0.2.1)(64bit) -
libvirt.so.0(LIBVIRT_0.2.3)(64bit) -
libvirt.so.0(LIBVIRT_0.3.0)(64bit) -
libvirt.so.0(LIBVIRT_0.3.2)(64bit) -
libvirt.so.0(LIBVIRT_0.3.3)(64bit) -
libvirt.so.0(LIBVIRT_0.4.0)(64bit) -
libvirt.so.0(LIBVIRT_0.4.1)(64bit) -
libvirt.so.0(LIBVIRT_0.4.2)(64bit) -
libvirt.so.0(LIBVIRT_0.4.5)(64bit) -
libvirt.so.0(LIBVIRT_0.5.0)(64bit) -
libvirt.so.0(LIBVIRT_0.6.0)(64bit) -
libvirt.so.0(LIBVIRT_0.6.1)(64bit) -
libvirt.so.0(LIBVIRT_0.6.3)(64bit) -
libvirt.so.0(LIBVIRT_0.6.4)(64bit) -
libvirt.so.0(LIBVIRT_0.7.0)(64bit) -
libvirt.so.0(LIBVIRT_0.7.1)(64bit) -
libvirt.so.0(LIBVIRT_0.7.2)(64bit) -
libvirt.so.0(LIBVIRT_0.7.3)(64bit) -
libvirt.so.0(LIBVIRT_0.7.5)(64bit) -
libvirt.so.0(LIBVIRT_0.7.7)(64bit) -
libvirt.so.0(LIBVIRT_0.8.0)(64bit) -
libvirt.so.0(LIBVIRT_0.8.1)(64bit) -
libvirt.so.0(LIBVIRT_0.8.2)(64bit) -
libvirt.so.0(LIBVIRT_0.8.5)(64bit) -
libvirt.so.0(LIBVIRT_0.8.6)(64bit) -
libvirt.so.0(LIBVIRT_0.8.8)(64bit) -
libvirt.so.0(LIBVIRT_0.9.0)(64bit) -
libvirt.so.0(LIBVIRT_0.9.10)(64bit) -
libvirt.so.0(LIBVIRT_0.9.11)(64bit) -
libvirt.so.0(LIBVIRT_0.9.13)(64bit) -
libvirt.so.0(LIBVIRT_0.9.2)(64bit) -
libvirt.so.0(LIBVIRT_0.9.3)(64bit) -
libvirt.so.0(LIBVIRT_0.9.4)(64bit) -
libvirt.so.0(LIBVIRT_0.9.5)(64bit) -
libvirt.so.0(LIBVIRT_0.9.7)(64bit) -
libvirt.so.0(LIBVIRT_0.9.8)(64bit) -
libvirt.so.0(LIBVIRT_0.9.9)(64bit) -
libvirt.so.0(LIBVIRT_1.0.0)(64bit) -
libvirt.so.0(LIBVIRT_1.0.1)(64bit) -
libvirt.so.0(LIBVIRT_1.0.2)(64bit) -
libvirt.so.0(LIBVIRT_1.0.3)(64bit) -
libvirt.so.0(LIBVIRT_1.0.5)(64bit) -
libvirt.so.0(LIBVIRT_1.0.6)(64bit) -
libvirt.so.0(LIBVIRT_1.1.0)(64bit) -
libvirt.so.0(LIBVIRT_1.1.1)(64bit) -
libvirt.so.0(LIBVIRT_1.1.3)(64bit) -
libvirt.so.0(LIBVIRT_1.2.1)(64bit) -
libvirt.so.0(LIBVIRT_1.2.11)(64bit) -
libvirt.so.0(LIBVIRT_1.2.12)(64bit) -
libvirt.so.0(LIBVIRT_1.2.14)(64bit) -
libvirt.so.0(LIBVIRT_1.2.15)(64bit) -
libvirt.so.0(LIBVIRT_1.2.16)(64bit) -
libvirt.so.0(LIBVIRT_1.2.17)(64bit) -
libvirt.so.0(LIBVIRT_1.2.19)(64bit) -
libvirt.so.0(LIBVIRT_1.2.3)(64bit) -
libvirt.so.0(LIBVIRT_1.2.5)(64bit) -
libvirt.so.0(LIBVIRT_1.2.6)(64bit) -
libvirt.so.0(LIBVIRT_1.2.7)(64bit) -
libvirt.so.0(LIBVIRT_1.2.8)(64bit) -
libvirt.so.0(LIBVIRT_1.2.9)(64bit) -
libvirt.so.0(LIBVIRT_1.3.3)(64bit) -
libvirt.so.0(LIBVIRT_2.0.0)(64bit) -
libvirt.so.0(LIBVIRT_2.2.0)(64bit) -
libvirt.so.0(LIBVIRT_3.0.0)(64bit) -
libvirt.so.0(LIBVIRT_3.1.0)(64bit) -
libvirt.so.0(LIBVIRT_3.4.0)(64bit) -
libvirt.so.0(LIBVIRT_3.7.0)(64bit) -
libvirt.so.0(LIBVIRT_3.9.0)(64bit) -
libvirt.so.0(LIBVIRT_PRIVATE_3.10.0)(64bit) -

Conflicts

Name Value
lib64virt-devel < 3.10.0-1.2.mga6

Download

Type URL
Binary Package lib64virt0-3.10.0-1.2.mga6.x86_64.rpm
Source Package libvirt-3.10.0-1.2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64virt0 rpm package:
    # urpmi lib64virt0

Files

Path
/usr/lib64/libvirt-admin.so.0
/usr/lib64/libvirt-admin.so.0.3010.0
/usr/lib64/libvirt-lxc.so.0
/usr/lib64/libvirt-lxc.so.0.3010.0
/usr/lib64/libvirt-qemu.so.0
/usr/lib64/libvirt-qemu.so.0.3010.0
/usr/lib64/libvirt.so.0
/usr/lib64/libvirt.so.0.3010.0

Changelog

2018-03-21 - mrambo3501 <mrambo3501> 3.10.0-1.2.mga6
(not released yet)
+ Revision: 1211136
- add upstream patch which fixes CVE-2018-1064 (mga#22777)
- add ubuntu/debian patches which fix CVE-2018-5748 and CVE-2018-6764 (mga#22280)
- new version 3.10.0 fixes security vulnerabilities and build failures (mga#22280)
- removed both patches (applied upstream)
+ luigiwalser <luigiwalser>
- add patches from opensuse to fix security issues (bsc#1053600 and CVE-2017-1000256)
2017-05-25 - mrambo3501 <mrambo3501> 3.3.0-1.mga6
+ Revision: 1104524
- version 3.3.0 fixes CVE-2015-5160 (#19717)
- deleted two patches applied upstream
- deleted the systemd patch which no longer applies
2017-05-03 - akien <akien> 1.3.5-5.mga6
+ Revision: 1098914
- Disable glusterfs support, the package was dropped in mga6 as unmaintained
2016-08-19 - blino <blino> 1.3.5-4.mga6
+ Revision: 1046966
- recommend virtual netcat package instead of specific netcat-openbsd (to avoid conflict with task-printing which requires netcat-traditional), libvirt supports both as of commit a2b5c57db83559d4fe32ee90fbb6685555388e06 from 2011
2016-07-07 - luigiwalser <luigiwalser> 1.3.5-3.mga6
+ Revision: 1039476
- add upstream patch to fix CVE-2016-5008
2016-06-29 - tv <tv> 1.3.5-2.mga6
+ Revision: 1038152
- patch 100: add support for VirtualBox 5
2016-06-07 - tv <tv> 1.3.5-1.mga6
+ Revision: 1020554
- new release
2016-05-21 - tv <tv> 1.3.4-4.mga6
+ Revision: 1017279
- Fix libxl video config via virt-install (bz #1334557)
2016-05-04 - tv <tv> 1.3.4-3.mga6
+ Revision: 1009081
- better docs: include CSS files
- do not BR the full qemu
2016-05-03 - tv <tv> 1.3.4-2.mga6
+ Revision: 1008950
- adjust file list
- move api XML files back into devel (needed for python-libvirt build)
- split docs sub package

See Also

Package Description
lib64vlc-devel-3.0.2-0.1.mga6.x86_64.rpm Development files for the VLC media player
lib64vlc-devel-3.0.4-1.mga6.x86_64.rpm Development files for the VLC media player
lib64vlc5-3.0.2-0.1.mga6.x86_64.rpm Shared code for the VLC media player
lib64vlc5-3.0.4-1.mga6.x86_64.rpm Shared code for the VLC media player
lib64vlccore9-3.0.2-0.1.mga6.x86_64.rpm Shared core code for the VLC media player
lib64vlccore9-3.0.4-1.mga6.x86_64.rpm Shared core code for the VLC media player
lib64vncserver-devel-0.9.11-1.1.mga6.x86_64.rpm Headers for developing programs that will use libvncserver
lib64vncserver1-0.9.11-1.1.mga6.x86_64.rpm An easy API to write one's own VNC server
lib64vorbis-devel-1.3.5-2.1.mga6.x86_64.rpm Headers for developing programs that will use libvorbis
lib64vorbis-devel-1.3.5-2.3.mga6.x86_64.rpm Headers for developing programs that will use libvorbis
lib64vorbis-devel-1.3.5-2.4.mga6.x86_64.rpm Headers for developing programs that will use libvorbis
lib64vorbis0-1.3.5-2.1.mga6.x86_64.rpm Main library for libvorbis
lib64vorbis0-1.3.5-2.3.mga6.x86_64.rpm Main library for libvorbis
lib64vorbis0-1.3.5-2.4.mga6.x86_64.rpm Main library for libvorbis
lib64vorbisenc2-1.3.5-2.1.mga6.x86_64.rpm Encoder specialized library for libvorbis
Advertisement
Advertisement