lib64wxgtkugl3.0_0-3.0.3.1-1.1.mga6.x86_64.rpm


Advertisement

Description

lib64wxgtkugl3.0_0 - GTK+ port of the wxWidgets library, OpenGl add-on - unicode

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package filename lib64wxgtkugl3.0_0-3.0.3.1-1.1.mga6.x86_64.rpm
Package name lib64wxgtkugl3.0_0
Package version 3.0.3.1
Package release 1.1.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.wxwidgets.org/
License wxWidgets Library Licence
Maintainer -
Download size 32.46 KB
Installed size 94.11 KB
OpenGl add-on library for the unicode enabled version of wxGTK, the
GTK+ port of the wxWidgets library.

Alternatives

Package Version Architecture Repository
lib64wxgtkugl3.0_0-3.0.3.1-1.mga6.x86_64.rpm 3.0.3.1 x86_64 Mageia Core
lib64wxgtkugl3.0_0 - - -

Requires

Name Value
libGL.so.1()(64bit) -
libX11.so.6()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libwx_baseu-3.0.so.0()(64bit) -
libwx_baseu-3.0.so.0(WXU_3.0)(64bit) -
libwx_gtk2u_core-3.0.so.0()(64bit) -
libwx_gtk2u_core-3.0.so.0(WXU_3.0)(64bit) -

Provides

Name Value
lib64wxgtkugl3.0_0 == 3.0.3.1-1.1.mga6
lib64wxgtkugl3.0_0(x86-64) == 3.0.3.1-1.1.mga6
libwx_gtk2u_gl-3.0.so.0()(64bit) -
libwx_gtk2u_gl-3.0.so.0(WXU_3.0)(64bit) -
libwx_gtk2u_gl-3.0.so.0(WXU_3.0.1)(64bit) -
libwx_gtk2u_gl-3.0.so.0(WXU_3.0.2)(64bit) -
libwx_gtk2u_gl-3.0.so.0(WXU_3.0.3)(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64wxgtkugl3.0_0-3.0.3.1-1.1.mga6.x86_64.rpm
Source Package wxgtk-3.0.3.1-1.1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64wxgtkugl3.0_0 rpm package:
    # urpmi lib64wxgtkugl3.0_0

Files

Path
/usr/lib64/libwx_gtk2u_gl-3.0.so.0
/usr/lib64/libwx_gtk2u_gl-3.0.so.0.3.0

Changelog

2019-04-29 - daviddavid <daviddavid> 3.0.3.1-1.1.mga6
+ Revision: 1395853
- add upstream patch to avoid delayed destruction if TLW was never created
thus fixing filezilla popup (mga#24547#c13)
2017-06-03 - akien <akien> 3.0.3.1-1.mga6
+ Revision: 1106032
- Version 3.0.3.1
- Rediff P2 and drop upstreamed P3
2017-02-18 - cjw <cjw> 3.0.2-11.mga6
+ Revision: 1086672
- package wxwin.m4 to fix build of spek
2017-02-18 - cjw <cjw> 3.0.2-10.mga6
+ Revision: 1086660
- patch3: build with gstreamer1.0 instead of gstreamer0.10
2016-06-02 - daviddavid <daviddavid> 3.0.2-9.mga6
+ Revision: 1019795
- return back wxgtk built with gtk2 (fixes some gtk3 regressions)
2016-05-25 - daviddavid <daviddavid> 3.0.2-8.mga6
+ Revision: 1018261
- add upstream patch to fix window sizing issue with gtk 3.19+
* https://github.com/wxWidgets/wxWidgets/commit/9fea81c069f9d803d79c4ce82f87a00a6e10b490
+ luigiwalser <luigiwalser>
- back to webkit1 for now
- try building with webkit2

See Also

Package Description
lib64x11-devel-1.6.5-1.1.mga6.x86_64.rpm Development files for libx11
lib64x11-xcb1-1.6.5-1.1.mga6.x86_64.rpm X Library
lib64x11_6-1.6.5-1.1.mga6.x86_64.rpm X Library
lib64xatracker2-17.1.5-1.mga6.x86_64.rpm Files for Mesa XA state tracker
lib64xatracker2-17.3.2-1.1.mga6.x86_64.rpm Files for Mesa XA state tracker
lib64xatracker2-17.3.6-1.mga6.x86_64.rpm Files for Mesa XA state tracker
lib64xatracker2-17.3.9-1.mga6.x86_64.rpm Files for Mesa XA state tracker
lib64xatracker2-devel-17.1.5-1.mga6.x86_64.rpm Development files for XA libs
lib64xatracker2-devel-17.3.2-1.1.mga6.x86_64.rpm Development files for XA libs
lib64xatracker2-devel-17.3.6-1.mga6.x86_64.rpm Development files for XA libs
lib64xatracker2-devel-17.3.9-1.mga6.x86_64.rpm Development files for XA libs
lib64xcomp3-3.5.0.33-1.mga6.x86_64.rpm Xcomp library for NX
lib64xcompext3-3.5.0.33-1.mga6.x86_64.rpm Xcompext/Xcompshad library for NX
lib64xcursor-devel-1.1.14-6.1.mga6.x86_64.rpm Development files for libxcursor
lib64xcursor-devel-1.1.14-6.2.mga6.x86_64.rpm Development files for libxcursor
Advertisement
Advertisement