lib64xml2_2-2.9.9-1.mga6.x86_64.rpm


Advertisement

Description

lib64xml2_2 - Shared libraries providing XML and HTML support

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package filename lib64xml2_2-2.9.9-1.mga6.x86_64.rpm
Package name lib64xml2_2
Package version 2.9.9
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.xmlsoft.org/
License MIT
Maintainer -
Download size 557.00 KB
Installed size 1.43 MB
This library allows you to manipulate XML files. It includes support
for reading, modifying and writing XML and HTML files. There is DTDs
support: this includes parsing and validation even with complex DtDs,
either at parse time or later once the document has been modified.

Alternatives

Package Version Architecture Repository
lib64xml2_2-2.9.7-1.mga6.x86_64.rpm 2.9.7 x86_64 Mageia Core Updates
lib64xml2_2-2.9.4-8.mga6.x86_64.rpm 2.9.4 x86_64 Mageia Core
lib64xml2_2 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.2)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
liblzma.so.5()(64bit) -
liblzma.so.5(XZ_5.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.2.3)(64bit) -
libz.so.1(ZLIB_1.2.3.3)(64bit) -

Provides

Name Value
lib64xml2_2 == 2.9.9-1.mga6
lib64xml2_2(x86-64) == 2.9.9-1.mga6
libxml2 == 2.9.9-1.mga6
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.5.0)(64bit) -
libxml2.so.2(LIBXML2_2.5.2)(64bit) -
libxml2.so.2(LIBXML2_2.5.4)(64bit) -
libxml2.so.2(LIBXML2_2.5.5)(64bit) -
libxml2.so.2(LIBXML2_2.5.6)(64bit) -
libxml2.so.2(LIBXML2_2.5.7)(64bit) -
libxml2.so.2(LIBXML2_2.5.8)(64bit) -
libxml2.so.2(LIBXML2_2.5.9)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libxml2.so.2(LIBXML2_2.6.1)(64bit) -
libxml2.so.2(LIBXML2_2.6.10)(64bit) -
libxml2.so.2(LIBXML2_2.6.11)(64bit) -
libxml2.so.2(LIBXML2_2.6.12)(64bit) -
libxml2.so.2(LIBXML2_2.6.14)(64bit) -
libxml2.so.2(LIBXML2_2.6.15)(64bit) -
libxml2.so.2(LIBXML2_2.6.16)(64bit) -
libxml2.so.2(LIBXML2_2.6.17)(64bit) -
libxml2.so.2(LIBXML2_2.6.18)(64bit) -
libxml2.so.2(LIBXML2_2.6.19)(64bit) -
libxml2.so.2(LIBXML2_2.6.2)(64bit) -
libxml2.so.2(LIBXML2_2.6.20)(64bit) -
libxml2.so.2(LIBXML2_2.6.21)(64bit) -
libxml2.so.2(LIBXML2_2.6.23)(64bit) -
libxml2.so.2(LIBXML2_2.6.24)(64bit) -
libxml2.so.2(LIBXML2_2.6.25)(64bit) -
libxml2.so.2(LIBXML2_2.6.27)(64bit) -
libxml2.so.2(LIBXML2_2.6.28)(64bit) -
libxml2.so.2(LIBXML2_2.6.29)(64bit) -
libxml2.so.2(LIBXML2_2.6.3)(64bit) -
libxml2.so.2(LIBXML2_2.6.32)(64bit) -
libxml2.so.2(LIBXML2_2.6.5)(64bit) -
libxml2.so.2(LIBXML2_2.6.6)(64bit) -
libxml2.so.2(LIBXML2_2.6.7)(64bit) -
libxml2.so.2(LIBXML2_2.6.8)(64bit) -
libxml2.so.2(LIBXML2_2.7.0)(64bit) -
libxml2.so.2(LIBXML2_2.7.3)(64bit) -
libxml2.so.2(LIBXML2_2.7.4)(64bit) -
libxml2.so.2(LIBXML2_2.8.0)(64bit) -
libxml2.so.2(LIBXML2_2.9.0)(64bit) -
libxml2.so.2(LIBXML2_2.9.1)(64bit) -
libxml2.so.2(LIBXML2_2.9.8)(64bit) -

Obsoletes

Name Value
lib64xml2 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64xml2_2-2.9.9-1.mga6.x86_64.rpm
Source Package libxml2-2.9.9-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64xml2_2 rpm package:
    # urpmi lib64xml2_2

Files

Path
/usr/lib64/libxml2.so.2
/usr/lib64/libxml2.so.2.9.9

Changelog

2019-01-21 - luigiwalser <luigiwalser> 2.9.9-1.mga6
+ Revision: 1358561
- 2.9.9 (fixes CVE-2018-9251, CVE-2018-14404, CVE-2018-14567)
- 2.9.7 (sync with cauldron) to fix security issues (mga#22130)
2017-07-07 - akien <akien> 2.9.4-8.mga6
+ Revision: 1109384
- Run autoreconf to fix automake 1.15 vs 1.15.1 version mismatch (duh...)
+ luigiwalser <luigiwalser>
- resync patches for CVE-2017-904[7-9] and CVE-2017-9050 with opensuse
- add patches from opensuse to fix CVE-2017-7375 and CVE-2017-7376
2017-07-01 - luigiwalser <luigiwalser> 2.9.4-7.mga6
+ Revision: 1108886
- add patches from opensuse to fix CVE-2017-0663 and CVE-2017-5969
- drop libxml2-NULL-deref-xmlDumpElementContent.patch, like opensuse did
2017-06-04 - ngompa <ngompa> 2.9.4-6.mga6
+ Revision: 1106745
- Add python 3 bindings
2017-06-04 - luigiwalser <luigiwalser> 2.9.4-5.mga6
+ Revision: 1106623
- sync patches from debian and opensuse to fix security issues (mga#19695)
+ neoclust <neoclust>
- Fix CVE-2016-4658
+ tv <tv>
- add a big fat warning about rebuilding perl-XML-LibXML on new version upload!
2016-07-22 - shlomif <shlomif> 2.9.4-4.mga6
+ Revision: 1043158
- Patch was already applied upstream
2016-07-22 - shlomif <shlomif> 2.9.4-3.mga6
+ Revision: 1043147
- Remove a patch that was fixed upstream differently and add new patch.
2016-07-22 - shlomif <shlomif> 2.9.4-2.mga6
+ Revision: 1043140
- New patch from RHEL/CentOS
2016-07-20 - luigiwalser <luigiwalser> 2.9.4-1.mga6
+ Revision: 1042929
- 2.9.4
- rediff CVE-2016-3627 patch
- remove upstreamed CVE-2016-3705 patch
2016-05-18 - luigiwalser <luigiwalser> 2.9.3-3.mga6
+ Revision: 1016804
- add patches suggested upstream to fix CVE-2016-3627 and CVE-2016-3705

See Also

Package Description
lib64xmlsec1-devel-1.2.24-1.mga6.x86_64.rpm Development files for xmlsec1
lib64xmlsec1-gcrypt1-1.2.24-1.mga6.x86_64.rpm Gcrypt crypto plugin for XML Security Library
lib64xmlsec1-gnutls1-1.2.24-1.mga6.x86_64.rpm Gnutls crypto plugin for XML Security Library
lib64xmlsec1-nss1-1.2.24-1.mga6.x86_64.rpm NSS crypto plugin for XML Security Library
lib64xmlsec1-openssl1-1.2.24-1.mga6.x86_64.rpm OpenSSL crypto plugin for XML Security Library
lib64xmlsec1_1-1.2.24-1.mga6.x86_64.rpm Library providing support for "XML Signature" and "XML Encryption" standards
lib64xrandr-gir1.3-1.54.1-1.mga6.x86_64.rpm GObject Introspection interface description for xrandr
lib64xslt-devel-1.1.29-6.1.mga6.x86_64.rpm Libraries, includes, etc. to develop XML and HTML applications
lib64xslt1-1.1.29-6.1.mga6.x86_64.rpm Library providing XSLT support
lib64yaml-cpp-devel-0.5.1-6.1.mga6.x86_64.rpm Development files for yaml-cpp
lib64yaml-cpp0.5-0.5.1-6.1.mga6.x86_64.rpm Shared library for yaml-cpp
lib64zbar-devel-0.10-3.20121014.8.1.mga6.x86_64.rpm ZBAR Development headers and libraries
lib64zbar0-0.10-3.20121014.8.1.mga6.x86_64.rpm ZBAR Libraries
lib64zbargtk0-0.10-3.20121014.8.1.mga6.x86_64.rpm ZBAR Libraries
lib64zbarqt0-0.10-3.20121014.8.1.mga6.x86_64.rpm ZBAR Libraries
Advertisement
Advertisement