mbedtls-2.7.6-1.mga6.x86_64.rpm


Advertisement

Description

mbedtls - An SSL library

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package name mbedtls
Package version 2.7.6
Package release 1.mga6
Package architecture x86_64
Package type rpm
Installed size 742.45 KB
Download size 182.09 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
mbed TLS (formerly known as PolarSSL) is an SSL library written in ANSI C.
mbed TLS makes it easy for developers to include cryptographic and SSL/TLS
capabilities in their (embedded) products with as little hassle as possible.
It is designed to be readable, documented, tested, loosely coupled and
portable.
This package contains mbed TLS programs.

Alternatives

Package Version Architecture Repository
mbedtls-2.7.8-1.mga6.i586.rpm 2.7.8 i586 Mageia Core Updates
mbedtls-2.7.8-1.mga6.x86_64.rpm 2.7.8 x86_64 Mageia Core Updates
mbedtls-2.7.6-1.mga6.i586.rpm 2.7.6 i586 Mageia Core Updates
mbedtls-2.7.3-1.mga6.x86_64.rpm 2.7.3 x86_64 Mageia Core Updates
mbedtls-2.7.3-1.mga6.i586.rpm 2.7.3 i586 Mageia Core Updates
mbedtls-2.7.0-1.mga6.x86_64.rpm 2.7.0 x86_64 Mageia Core Updates
mbedtls-2.7.0-1.mga6.i586.rpm 2.7.0 i586 Mageia Core Updates
mbedtls-2.6.0-1.mga6.x86_64.rpm 2.6.0 x86_64 Mageia Core Updates
mbedtls-2.6.0-1.mga6.i586.rpm 2.6.0 i586 Mageia Core Updates
mbedtls-2.4.2-1.mga6.x86_64.rpm 2.4.2 x86_64 Mageia Core
mbedtls-2.4.2-1.mga6.i586.rpm 2.4.2 i586 Mageia Core
mbedtls - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libmbedcrypto.so.2()(64bit) -
libmbedtls.so.10()(64bit) -
libmbedx509.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -

Provides

Name Value
mbedtls == 2.7.6-1.mga6
mbedtls(x86-64) == 2.7.6-1.mga6
polarssl == 2.7.6-1.mga6

Obsoletes

Name Value
polarssl < 1.3.16-1

Download

Type URL
Binary Package mbedtls-2.7.6-1.mga6.x86_64.rpm
Source Package mbedtls-2.7.6-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install mbedtls rpm package:
    # urpmi mbedtls

Files

Path
/usr/bin/mbedtls-aescrypt2
/usr/bin/mbedtls-benchmark
/usr/bin/mbedtls-cert_app
/usr/bin/mbedtls-cert_req
/usr/bin/mbedtls-cert_write
/usr/bin/mbedtls-crl_app
/usr/bin/mbedtls-crypt_and_hash
/usr/bin/mbedtls-dh_client
/usr/bin/mbedtls-dh_genprime
/usr/bin/mbedtls-dh_server
/usr/bin/mbedtls-dtls_client
/usr/bin/mbedtls-dtls_server
/usr/bin/mbedtls-gen_entropy
/usr/bin/mbedtls-gen_key
/usr/bin/mbedtls-gen_random_ctr_drbg
/usr/bin/mbedtls-gen_random_havege
/usr/bin/mbedtls-generic_sum
/usr/bin/mbedtls-hello
/usr/bin/mbedtls-key_app
/usr/bin/mbedtls-mini_client
/usr/bin/mbedtls-mpi_demo
/usr/bin/mbedtls-pem2der
/usr/bin/mbedtls-pk_decrypt
/usr/bin/mbedtls-pk_encrypt
/usr/bin/mbedtls-pk_sign
/usr/bin/mbedtls-pk_verify
/usr/bin/mbedtls-req_app
/usr/bin/mbedtls-rsa_decrypt
/usr/bin/mbedtls-rsa_encrypt
/usr/bin/mbedtls-rsa_genkey
/usr/bin/mbedtls-rsa_sign
/usr/bin/mbedtls-rsa_verify
/usr/bin/mbedtls-selftest
/usr/bin/mbedtls-ssl_cert_test
/usr/bin/mbedtls-ssl_client1
/usr/bin/mbedtls-ssl_client2
/usr/bin/mbedtls-ssl_fork_server
/usr/bin/mbedtls-ssl_mail_client
/usr/bin/mbedtls-ssl_pthread_server
/usr/bin/mbedtls-ssl_server
/usr/bin/mbedtls-strerror
/usr/bin/mbedtls-udp_proxy
/usr/share/doc/mbedtls/ChangeLog
/usr/share/doc/mbedtls/README.md

Changelog

2018-10-12 - mrambo3501 <mrambo3501> 2.7.6-1.mga6
+ Revision: 1319867
- version 2.7.6 fixes CVE-2018-049[7-8] (mga#23660)
+ kekepower <kekepower>
- Update to version 2.7.3
- Fixes CVE-2018-9988 and CVE-2018-9989 (mga#22914)
- Update to version 2.8.0
- Fixes CVE-2018-9988 and CVE-2018-9989 (mga#22914)
- Update to version 2.7.0
- This fixes CVE-2017-18187, CVE-2018-0487 and CVE-2018-0488 (mga#22653)
+ luigiwalser <luigiwalser>
- 2.6.0
2017-03-23 - luigiwalser <luigiwalser> 2.4.2-1.mga6
+ Revision: 1094596
- 2.4.2 (fixes CVE-2017-2784)
2017-01-22 - akien <akien> 2.4.0-1.mga6
+ Revision: 1083018
- Version 2.4.0
- Version 2.2.1, major 10
- Package ASL 2.0 version instead of GPLv2+
2016-07-05 - luigiwalser <luigiwalser> 1.3.17-1.mga6
+ Revision: 1039028
- 1.3.17
2016-01-14 - luigiwalser <luigiwalser> 1.3.16-1.mga6
+ Revision: 923139
- library major is now 9
- 1.3.16 (mga#17187)
2016-01-12 - luigiwalser <luigiwalser> 2.2.1-1.mga6
+ Revision: 922231
- 2.2.1
2015-11-16 - oden <oden> 2.2.0-2.mga6
+ Revision: 903639
- the polarssl -> mbedtls switch was simply premature...
2015-11-16 - oden <oden> 2.2.0-1.mga6
+ Revision: 903624
- imported package mbedtls

See Also

Package Description
mbox-importer-17.12.2-1.mga6.x86_64.rpm Wizard to assist with importing MBox email archives into Akonadi
mc-4.8.20-1.mga6.x86_64.rpm A user-friendly file manager and visual shell
mediawiki-1.27.4-1.mga6.noarch.rpm A wiki engine
mediawiki-1.27.5-1.mga6.noarch.rpm A wiki engine
mediawiki-mysql-1.27.4-1.mga6.noarch.rpm Mediawiki with mysql database
mediawiki-mysql-1.27.5-1.mga6.noarch.rpm Mediawiki with mysql database
mediawiki-pgsql-1.27.4-1.mga6.noarch.rpm Mediawiki with postgresql database
mediawiki-pgsql-1.27.5-1.mga6.noarch.rpm Mediawiki with postgresql database
mediawiki-sqlite-1.27.4-1.mga6.noarch.rpm Mediawiki with sqlite database
mediawiki-sqlite-1.27.5-1.mga6.noarch.rpm Mediawiki with sqlite database
medit-1.2.0-1.mga6.x86_64.rpm Multiplatform GTK+2 text editor
memcached-1.4.39-1.mga6.x86_64.rpm High-performance memory object caching system
memcached-1.5.6-1.mga6.x86_64.rpm High-performance memory object caching system
memcached-devel-1.4.39-1.mga6.x86_64.rpm Files needed for development using memcached protocol
memcached-devel-1.5.6-1.mga6.x86_64.rpm Files needed for development using memcached protocol
Advertisement
Advertisement