openssh-askpass-7.5p1-2.4.mga6.x86_64.rpm


Advertisement

Description

openssh-askpass - OpenSSH X11 passphrase dialog

Property Value
Distribution Mageia 6.1
Repository Mageia Core Updates x86_64
Package filename openssh-askpass-7.5p1-2.4.mga6.x86_64.rpm
Package name openssh-askpass
Package version 7.5p1
Package release 2.4.mga6
Package architecture x86_64
Package type rpm
Category Networking/Remote access
Homepage http://www.openssh.com/
License BSD
Maintainer -
Download size 39.10 KB
Installed size 91.96 KB
Ssh (Secure Shell) is a program for logging into a remote machine and for
executing commands in a remote machine.  It is intended to replace
rlogin and rsh, and provide secure encrypted communications between
two untrusted hosts over an insecure network.  X11 connections and
arbitrary TCP/IP ports can also be forwarded over the secure channel.
OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
up to date in terms of security and features, as well as removing all
patented algorithms to separate libraries (OpenSSL).
This package contains Jim Knoble's <jmknoble@pobox.com> X11 passphrase
dialog.

Alternatives

Package Version Architecture Repository
openssh-askpass-7.5p1-2.4.mga6.i586.rpm 7.5p1 i586 Mageia Core Updates
openssh-askpass-7.5p1-2.3.mga6.x86_64.rpm 7.5p1 x86_64 Mageia Core Updates
openssh-askpass-7.5p1-2.3.mga6.i586.rpm 7.5p1 i586 Mageia Core Updates
openssh-askpass-7.5p1-2.2.mga6.x86_64.rpm 7.5p1 x86_64 Mageia Core Updates
openssh-askpass-7.5p1-2.2.mga6.i586.rpm 7.5p1 i586 Mageia Core Updates
openssh-askpass-7.5p1-2.1.mga6.x86_64.rpm 7.5p1 x86_64 Mageia Core Updates
openssh-askpass-7.5p1-2.1.mga6.i586.rpm 7.5p1 i586 Mageia Core Updates
openssh-askpass-7.5p1-2.mga6.x86_64.rpm 7.5p1 x86_64 Mageia Core
openssh-askpass-7.5p1-2.mga6.i586.rpm 7.5p1 i586 Mageia Core
openssh-askpass - - -

Requires

Name Value
libX11.so.6()(64bit) -
libXt.so.6()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
openssh == 7.5p1-2.4.mga6
openssh-askpass-common -
update-alternatives -

Provides

Name Value
openssh-askpass == 7.5p1-2.4.mga6
openssh-askpass(x86-64) == 7.5p1-2.4.mga6
ssh-askpass -
ssh-extras -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package openssh-askpass-7.5p1-2.4.mga6.x86_64.rpm
Source Package openssh-7.5p1-2.4.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install openssh-askpass rpm package:
    # urpmi openssh-askpass

Files

Path
/etc/X11/app-defaults/SshAskpass
/usr/libexec/openssh/x11-ssh-askpass
/usr/share/doc/openssh-askpass/ChangeLog
/usr/share/doc/openssh-askpass/README
/usr/share/doc/openssh-askpass/SshAskpass-1337.ad
/usr/share/doc/openssh-askpass/SshAskpass-NeXTish.ad
/usr/share/doc/openssh-askpass/SshAskpass-default.ad
/usr/share/doc/openssh-askpass/SshAskpass-green.ad
/usr/share/doc/openssh-askpass/SshAskpass-motif.ad
/usr/share/doc/openssh-askpass/SshAskpass.ad
/usr/share/doc/openssh-askpass/x11-ssh-askpass.1.html
/usr/share/man/man1/x11-ssh-askpass.1.xz

Changelog

2019-05-02 - guillomovitch <guillomovitch> 7.5p1-2.4.mga6
+ Revision: 1396211
- fix CVE-2019-6109 and CVE-2019-6110, using debian patches
- add patch for CVE-2018-15473, stolen from Debian (#23452)
+ luigiwalser <luigiwalser>
- add patch from opensuse to fix CVE-2018-20685
- add patch from fedora to fix CVE-2017-15906
2017-04-02 - wally <wally> 7.5p1-2.mga6
+ Revision: 1095660
- revert some changes in sshd.service and thus fix server key generation (mga#20618)
2017-03-27 - luigiwalser <luigiwalser> 7.5p1-1.mga6
+ Revision: 1094919
- 7.5p1
- sync more patch changes from fedora
2017-03-27 - luigiwalser <luigiwalser> 7.4p1-2.mga6
+ Revision: 1094915
- sync some patch changes for 7.4p1 from fedora
2017-01-04 - guillomovitch <guillomovitch> 7.4p1-1.mga6
+ Revision: 1080116
- new version 7.4
2016-10-22 - guillomovitch <guillomovitch> 7.3p1-3.mga6
+ Revision: 1063112
- use upstream patch to fix CVE-2016-8858
2016-10-04 - luigiwalser <luigiwalser> 7.3p1-2.mga6
+ Revision: 1058559
- add patch from fedora to fix NULL dereference
2016-08-07 - guillomovitch <guillomovitch> 7.3p1-1.mga6
+ Revision: 1044939
- sync patches with fedora
- new version 7.3p1
2016-07-26 - guillomovitch <guillomovitch> 7.2p2-3.mga6
+ Revision: 1043667
- sync patches with Fedora, fixing CVE-2016-6210

See Also

Package Description
openssh-askpass-common-7.5p1-2.1.mga6.x86_64.rpm OpenSSH X11 passphrase common scripts
openssh-askpass-common-7.5p1-2.2.mga6.x86_64.rpm OpenSSH X11 passphrase common scripts
openssh-askpass-common-7.5p1-2.3.mga6.x86_64.rpm OpenSSH X11 passphrase common scripts
openssh-askpass-common-7.5p1-2.4.mga6.x86_64.rpm OpenSSH X11 passphrase common scripts
openssh-askpass-gnome-7.5p1-2.1.mga6.x86_64.rpm OpenSSH GNOME passphrase dialog
openssh-askpass-gnome-7.5p1-2.2.mga6.x86_64.rpm OpenSSH GNOME passphrase dialog
openssh-askpass-gnome-7.5p1-2.3.mga6.x86_64.rpm OpenSSH GNOME passphrase dialog
openssh-askpass-gnome-7.5p1-2.4.mga6.x86_64.rpm OpenSSH GNOME passphrase dialog
openssh-clients-7.5p1-2.1.mga6.x86_64.rpm OpenSSH Secure Shell protocol clients
openssh-clients-7.5p1-2.2.mga6.x86_64.rpm OpenSSH Secure Shell protocol clients
openssh-clients-7.5p1-2.3.mga6.x86_64.rpm OpenSSH Secure Shell protocol clients
openssh-clients-7.5p1-2.4.mga6.x86_64.rpm OpenSSH Secure Shell protocol clients
openssh-ldap-7.5p1-2.1.mga6.x86_64.rpm A LDAP support for open source SSH server daemon
openssh-ldap-7.5p1-2.2.mga6.x86_64.rpm A LDAP support for open source SSH server daemon
openssh-ldap-7.5p1-2.3.mga6.x86_64.rpm A LDAP support for open source SSH server daemon
Advertisement
Advertisement